Remote control requested

garuda inxi:

System:
Kernel: 6.9.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: hpet avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=37143950-d1f3-4a2a-8cb8-05120360fc01 rw rootflags=subvol=@
rd.luks.uuid=9c588456-2255-4964-b21f-0d2a956fab7a loglevel=3yz
plymouth.enable=0 disablehooks=plymouth ibt=off
Desktop: KDE Plasma v: 6.1.1 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Garuda
base: Arch Linux
Machine:
Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1560
serial: <superuser required>
Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1560 serial: <superuser required>
part-nu: C100 uuid: <superuser required> UEFI: HUAWEI v: 1.06
date: 09/14/2020
Battery:
ID-1: BAT0 charge: 5.8 Wh (12.5%) condition: 46.5/54.9 Wh (84.5%) volts: 7.2
min: 7.6 model: DYNAPACK HB4593R1ECW-22T0 type: Li-ion serial: <filter>
status: discharging cycles: 410
CPU:
Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 2320 high: 2900 min/max: 1400/2900 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2900 2: 1522
3: 2544 4: 2545 5: 2900 6: 2900 7: 2900 8: 2900 9: 1282 10: 2900 11: 1397
12: 2900 13: 1318 14: 1272 15: 2047 16: 2900 bogomips: 92621
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Renoir [Radeon Vega Series / Radeon Mobile Series]
vendor: Huaqin driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
chip-ID: 1002:1636 class-ID: 0300 temp: 41.0 C
Device-2: IMC Networks HD Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:3 chip-ID: 13d3:5451
class-ID: 0e02 serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
Monitor-1: eDP-1 res: 1800x1200 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.2-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
renoir LLVM 17.0.6 DRM 3.57 6.9.6-zen1-1-zen) device-ID: 1002:1636
memory: 500 MiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 13 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 24.1.2-arch1.1
device-ID: 1002:1636 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.1.2-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: Huaqin
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Huaqin driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
snd_sof_amd_rembrandt, snd_sof_amd_vangogh, snd_sof_amd_acp63 pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Huaqin driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.9.6-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 01:00.0
chip-ID: 8086:2725 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
IF-ID-1: br-362fc8bf733b state: down mac: <filter>
IF-ID-2: br-71f4b1a5cea3 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-3: br-dc056ff6fa0d state: down mac: <filter>
IF-ID-4: docker0 state: down mac: <filter>
IF-ID-5: vethbcea2ee state: up speed: 10000 Mbps duplex: full
mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 8087:0032
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c010c
Drives:
Local Storage: total: 931.51 GiB used: 227.16 GiB (24.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 2B4QFXO7 temp: 40.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 931.01 GiB size: 931.01 GiB (100.00%)
used: 227.07 GiB (24.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-9c588456-2255-4964-b21f-0d2a956fab7a
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 90.4 MiB (17.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.01 GiB size: 931.01 GiB (100.00%)
used: 227.07 GiB (24.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-9c588456-2255-4964-b21f-0d2a956fab7a
ID-4: /var/log raw-size: 931.01 GiB size: 931.01 GiB (100.00%)
used: 227.07 GiB (24.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-9c588456-2255-4964-b21f-0d2a956fab7a
ID-5: /var/tmp raw-size: 931.01 GiB size: 931.01 GiB (100.00%)
used: 227.07 GiB (24.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-9c588456-2255-4964-b21f-0d2a956fab7a
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.8 C mobo: N/A gpu: amdgpu temp: 42.0 C
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB note: est. available: 15 GiB used: 7.62 GiB (50.8%)
Processes: 415 Power: uptime: 13m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 5.97 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: 2228 pm: pacman pkgs: 2220 libs: 597
tools: gnome-software,octopi,paru pm: flatpak pkgs: 8 Compilers:
clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-04-07
Last full system update: 2024-06-27
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Always when I switch to another desktop with three finger swiping on the mousepad, I get the following dialog:
image

When I accept it, it comes again later. Sometimes keyboard inputs are broken after it. Sometimes it freezes the OS. But mostly it’s just annoying. So is there a way to disable this dialog?
I mean - I can just not click it. Also: using keyboard or mouse to switch desktop works fine without this message.

No solution to the admittedly annoying problem, just a description of how I deal with it. I get this in conjunction with keepassxc and autotype.

The system probably doesn’t freeze, you may just have to wait a bit longer. It takes 30-40 seconds for the system to respond after I click “Ok”. Then, as with you, only fragments are filled in. Then I try again and the dialogue appears again. Only now the dialogue buttons are in German. There is no longer a freeze, but the required keystrokes appear again in fragments. After the 3rd attempt, the dialogue box no longer appears and Autotype works normally.

You probably have krfb installed for KDEConnect or Desktop Sharing. As far as I know, this behavior is due to a bug in xdg-desktop-portal-kde, and this should be fixed in version 6.1.1 of xdg-desktop-portal-kde.

Try a simple garuda-update to update to version 6.1.1-1.

2 Likes

Even with your said version

pacman -Qs xdg-desktop-portal-kde
local/xdg-desktop-portal-kde 6.1.1-1 (plasma)
A backend implementation for xdg-desktop-portal using Qt/KF5

it’s still not fixed. I still get the box and after klicking it, all keybaord buttons are in some way broken - like tapping e opens an editor for some weird reason.

You didn’t answer the question whether you have krfb, krdc or something similar installed. So I’m going to get my crystal ball out: If you have KDEConnect, desktop sharing applications or keepassxc installed that you don’t need, then remove them and the dialog should disappear.

Try using the same password in krfb under “Enable Unattended Access” as for the normal connection.

Try starting with an empty session if you’ve been starting with a saved session by default in plasma.

This is a security feature that is probably not implemented correctly on wayland:

You can also try switching to x11 and check whether these issues occur there too.

If none of that helps, then you’ll have to wait until someone jumps in here with another idea.

3 Likes

Checking with pacman -Qs, I have none of these two packages, but I do have KDEConnect and need it. But I don’t need any desktop sharing feature it might have. If there is one, do you know if I can disable it?

Sharing is sharing, that’s the point of KDEconnect.

Have you tried it?

2 Likes

Oddly enough I’ve experienced the issue with the “remote control requested” dialog box but with using Steam Input and mapping keyboard keys to the gamepad while on a Wayland session.
Switching to X11 does fix that issue, although I’ve yet to find any other workaround.

As far as I know, this has to do with the security architecture of wayland. I personally can’t test it because I don’t have any of these applications installed (and don’t have the time :smiling_face:), but have you played around with this?


Sorry for German, I don’t have an English VM right now :innocent:


Edit:
https://bugs.kde.org/show_bug.cgi?id=480412

1 Like

I had the same problem “remote control requested” when switching between plasma desktops using three fingers on my trackpad. Curiously it does not happen if I swipe with four fingers.

If I swipe with 4 fingers and release all fingers simultaneously it will flick to the left- or right-most desktop, whereas if I successively release my fingers in a somewhat slower succession it will stay on the desktop in view.

Turns out not related to keepassxc etc.

Am happy to have figured this out but also find it curious, where can I modify behaviour depending on 3 or 4 finger gestures? (Acer Swift 3)