"Remember application association" not working

This is another issue that I ignored for a long time but still persists on a clean install.

I have Jetbrains Rider installed. When I click on a .sln file it opens Kate. I instead right-click on it, Open With, Choose Other Application. I select Rider and click “Remember application association”.

It opens up in Rider. I close it and click the file again, it opens in Kate!

This time I went a step further, went in Default Applications, created a new profile “application/Rider”, associated with “.sln” to open “Rider”.

I click the .sln file and… it opens Kate.

Is this by design?

(I posted a lot today because I’m reporting all the small issues I had been ignoring in the past, but from a clean install)

Kernel: 6.9.3-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
root=UUID=b3842975-a07f-4abe-a1f6-66b8fcf79638 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Acer product: Predator PH315-53 v: V2.04
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V2.04 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 2.04
date: 08/20/2021
ID-1: BAT1 charge: 40.7 Wh (100.0%) condition: 40.7/58.8 Wh (69.2%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xFA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1427 high: 2757 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 1400 2: 800 3: 1767
4: 800 5: 800 6: 1700 7: 2757 8: 2385 9: 1400 10: 800 11: 800 12: 1725
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s ports: active: none off: HDMI-A-1 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Device-3: Quanta HD User Facing driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:a061
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 note: disabled model: AU Optronics 0x82ed built: 2018
res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.0-arch1.1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 7.54 GiB unified: yes
API: Vulkan v: 1.3.285 layers: 8 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 24.1.0-arch1.1.1
device-ID: 8086:9bc4 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.78
device-ID: 10de:1f15 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.0-arch1.1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl, snd_soc_avs,
snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:6 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.9.3-1-cachyos status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks Dual Band
Wi-Fi 6 Killer AX1650i 160MHz 2x2 driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek Killer E2600 GbE vendor: Acer Incorporated ALI
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 08:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 6.83 TiB used: 3.17 TiB (46.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Western Digital
model: WD Blue SN570 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234200WD temp: 41.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11101100 temp: 74.8 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD40NDZW-11A8JS1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1023 scheme: GPT
ID-1: / raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 369.88 GiB (47.4%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:3
ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:5
ID-3: /home raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 369.88 GiB (47.4%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:3
ID-4: /var/log raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 369.88 GiB (47.4%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:3
ID-5: /var/tmp raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 369.88 GiB (47.4%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.45 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
ID-2: swap-2 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:4
System Temperatures: cpu: 58.0 C pch: 81.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.45 GiB used: 4.46 GiB (28.9%)
Processes: 388 Power: uptime: 2h 12m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1648 libs: 447 tools: octopi,pamac,paru
Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-30
Last full system update: 2024-05-30 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

(haven’t done any major updates since last reboot)


Too bad you didn’t mention dolphin, with

has nothing to do with it.

But maybe I’m wrong.

1 Like

I found since Plasma 6 that it has an annoying habit of iognoring what one has set for the default app for a particular file type. The solution I found was to go into default and remove anyother program listed for that particular file type only leaving the program I wanted assigned to it. Video files were the most annoying cause VLC could be at the bottom of the list and still take over being the default.

1 Like

What is the mechanism behind this function? If it is some internal configuration specific to your file manager, perhaps it can be overridden by whatever you have set in ~/.config/mimeapps.list.

Read through the issues on whatever file explorer you are using to see if anyone has mentioned seeing the same behavior, and if so what the devs have said in response.

Again, I’m not sure what the behind-the-scenes mechanism is here but if it is not directly modifying ~/.config/mimeapps.list, it is possible your mimeapps.list is getting the final say.

Try reordering the applications in ~/.config/mimeapps.list according to your preference. Or, if the associations are provided by a mimetype file you can use xdg-mime to change them.

If you want a nice easy GUI tool I sometimes use this one: AUR (en) - selectdefaultapplication-fork-git It’s a lot faster and easier than doing it manually. The package hasn’t been updated in over a year, but then again it’s already feature complete so I don’t know what there would be to update unless the app developed a bug.

An easy way to give back to the community is to read through some other issues in the forum and try to help out other users, as others have read through your posts to try and help you.


Apps show in “Open With” list.

My custom app type is in ~/.config/mimeapps.list, at the top of both Added Associations and Default Applications lists. Note that there’s no information about file extensions whatsoever here.

This is not a new issue; been having that issue for ages. I was having success setting default app for video files and several file types; but .sln specifically has never worked.

An easy way to give back to the community is to read through some other issues in the forum and try to help out other users, as others have read through your posts to try and help you.

I have been so incredibly busy and saturated for a while now, adding anything on my plate is not possible. Believe me, I’m doing enough “giving to others”. What I can do is try to report bugs where they belong.

But for something like this… where do you report it? KDE Dolphin? Or the underlying mimeapps.list mechanism? I never know where things should be reported. This is such a long-standing bug… I’d think they’re already aware of it. If they even know who the bug belongs to.

OH. If I manually move the custom meme type to the END of the list, then it works.

That solves the problem; but why does it behave that way, and where to report it?

It kind of looks like .sln is considered as having 2 different mime types at the same time, and the 2nd one overrides the first?

1 Like

Where to report issues isn’t so much of a searching issue; but need to first figure out which component in the chain is responsible for a problem. Is it Rider not configuring itself correctly? Dolphin not handling mimeapps correctly, or an underlying linux kernel issue, or the various layers not working well together for some reason? Often it can be like bureaucrats passing the hot potato to each other.

In this case it’s definitely looking like a KDE issue. There are only 13 open Dolphin issues and it’s not there.

Alright it’s reported where it belongs.

If that is true, then the file has been misconfigured. Each line in ~/.config/mimeapps.list should have an extension, and then the desktop file for whatever application you are associating with it.

It should be in this format:

[Default Applications]

And so on and so on.

Your initial comment made me think you were feeling guilty about the excessive number of help requests you have opened over the past day or so. I was just mentioning that yes, you have been asking for a lot of time from the community to help you set up your computer, but you can always give time back as well.

It sounds like I was mistaken about that; I’m not sure why you brought it up.

1 Like

Yes it looks like this


What’s not here is any reference to .sln file type.

I ‘fixed’ the issue locally at least for that file type. Let’s see what KDE has to say about it.

btw I just tried with .docx file to open with WPS and that works just fine.

Still not sure what’s the deal with .sln files.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.