Reinstall : sda disk not in partitioning

Hey all,

Here’s my inxi

Kernel: 6.9.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=67e1e13a-4842-4384-b3eb-3f6fa6d905be rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 splash
pcie_aspm=off ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Acer product: Aspire A517-51 v: V2.03
serial: <superuser required>
Mobo: KBL model: Dragonite_KL v: V2.03 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 2.03
date: 05/22/2019
ID-1: BAT1 charge: 34.6 Wh (100.0%) condition: 34.6/48.9 Wh (70.8%)
volts: 16.2 min: 15.2 model: LG 004B384234314341 type: Li-ion
serial: <filter> status: full
Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 500 high: 800 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 800 3: 400 4: 400
5: 800 6: 400 7: 400 8: 400 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917
class-ID: 0300
Device-2: Quanta HD Webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:4 chip-ID: 0408:a060
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x139d built: 2017 res: 1920x1080
hz: 60 dpi: 128 gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2")
ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.1.1-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL
GT2) device-ID: 8086:5917 memory: 3.73 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: Intel
UHD Graphics 620 (KBL GT2) driver: mesa intel v: 24.1.1-arch1.1
device-ID: 8086:5917 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
API: ALSA v: k6.9.5-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.1 chip-ID: 10ec:8168
class-ID: 0200
IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Info: services: NetworkManager
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:3
chip-ID: 04ca:3015 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Local Storage: total: 1.14 TiB used: 258.97 GiB (22.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1J
ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SD9SN8W256G1014
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 7000 scheme: GPT
ID-1: / raw-size: 118.93 GiB size: 118.93 GiB (100.00%)
used: 94.34 GiB (79.3%) fs: btrfs dev: /dev/sdb8 maj-min: 8:24
ID-2: /boot/efi raw-size: 547 MiB size: 545.9 MiB (99.80%)
used: 584 KiB (0.1%) fs: vfat dev: /dev/sdb6 maj-min: 8:22
ID-3: /home raw-size: 118.93 GiB size: 118.93 GiB (100.00%)
used: 94.34 GiB (79.3%) fs: btrfs dev: /dev/sdb8 maj-min: 8:24
ID-4: /var/log raw-size: 118.93 GiB size: 118.93 GiB (100.00%)
used: 94.34 GiB (79.3%) fs: btrfs dev: /dev/sdb8 maj-min: 8:24
ID-5: /var/tmp raw-size: 118.93 GiB size: 118.93 GiB (100.00%)
used: 94.34 GiB (79.3%) fs: btrfs dev: /dev/sdb8 maj-min: 8:24
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.63 GiB used: 176.5 MiB (2.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 8 GiB available: 7.63 GiB used: 2.75 GiB (36.0%)
Processes: 254 Power: uptime: 26m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 3.01 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1540 libs: 447 tools: octopi,pamac,paru,yay
Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish
v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2023-09-12
Last full system update: 2024-06-19
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

I have decided to reinstall Garuda with the latest iso (garuda-dr460nized-linux-zen-240428.iso). But during the install, when doing partitioning, i can see my sdb disk with the / and the /boot/efi partitions.

But i cant see de the sda disk containing my data. So i cant mount sda2.
It’s strange because in the live session Gparted can see the sda disk and the two partitions.

[root@jacques-aspirea51751 jacques]# parted -l
Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition table: gpt
Disk flags :

Number Start End Size File system Name Flags
1 1049kB 490GB 490GB ntfs msftdata
2 490GB 1000GB 510GB ext4

Model: ATA SanDisk SD9SN8W2 (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/512B
Partition table: gpt
Disk flags :

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16.8MB Microsoft reserved partition msftres
3 123MB 74.2GB 74.1GB ntfs Basic data partition msftdata
4 74.2GB 75.3GB 1074MB ntfs Basic data partition hidden, diag
5 75.3GB 128GB 52.5GB ext4
6 128GB 128GB 574MB fat32 boot, esp
8 128GB 256GB 128GB btrfs

Model: Unknown
Disk /dev/zram0: 8195MB
Sector size (logical/physical): 4096B/4096B
Partition table: loop
Disk flags :

Number Start End Size File system Flags
1 0.00B 8195MB 8195MB linux-swap(v1)

[root@jacques-aspirea51751 jacques]#

What am i doing wrong again ?

Maybe you have mounted /dev/sda, e.g. to browse files on it.
If I remember correctly, it should be unmounted when you launch the installer.


I have checked that, both sda1 and sda2 are unmounted.
I also tried mounting them, but with no luck…

Expecting sda to represent something other that the first physical drive on your computer’s hardware bus.

1 Like

Is there a way to check this ?

It’s bit strange because when i installed it for the first time (last year), i didn’t have any problem…

Here’s the message when trying to use sda during install

unpartitioned space or unknown partition table

What do you mean, “unpartitioned…unknown?”

Output of lsblk please. lsblk(8) - Linux manual page


IDK if ntfs is supported on live ISO’s :grin:
Check if ntfs-3g is installed.

1 Like

It’s only the message i have in the installer when i try to enter in sda…

Her’s the lsblk

jacques@jacques in ~
λ lsblk
sda      8:0    0 931.5G  0 disk
├─sda1   8:1    0 456.4G  0 part
└─sda2   8:2    0 475.1G  0 part /datalinux
sdb      8:16   0 238.5G  0 disk
├─sdb1   8:17   0   100M  0 part
├─sdb2   8:18   0    16M  0 part
├─sdb3   8:19   0  97.9G  0 part
├─sdb4   8:20   0     1G  0 part
├─sdb6   8:22   0   547M  0 part /boot/efi
└─sdb8   8:24   0   139G  0 part /var/tmp
sr0     11:0    1  1024M  0 rom
zram0  254:0    0   7.6G  0 disk [SWAP]

We need lsblk -f
and did you read my post above?


You have two drives and one you store both Windows (ntfs) & Linux (ext4) data on, in separate partitions.

The second drive contains both Windows & Linux operating systems.

When you’re in the LiveISO install window, be sure to choose the right drive whose Garuda install you want to replace from the drop-down box.


Make sure to unmount this before trying again

1 Like


Yep, i went back to the live iso and did

pacman -Sy archlinux-keyring

Because i had a signature’s problem
After that, just to be sure

pacman -Sy ntfs-3g

and tried installing again, but with no luck…

And here’s the lsblk -f with my actual installed Garuda…

jacques@jacques in ~
λ lsblk -f
├─sda1 ntfs                  7AE61C58425CCCB8
└─sda2 ext4   1.0            fa6ccbbe-aa40-4bf9-8c5b-4d893f6cfc36  280.8G    35% /datalinux
├─sdb1 vfat   FAT32 ESP      96FB-5A10
├─sdb3 ntfs         Acer     4028FD7928FD6E72
├─sdb4 ntfs         Recovery 44D0FE3CD0FE33B0
├─sdb6 vfat   FAT32 NO_LABEL 44C1-541D                             545.3M     0% /boot/efi
└─sdb8 btrfs                 67e1e13a-4842-4384-b3eb-3f6fa6d905be                /var/log


Yep exactly. I have set sdb8 for / and sdb6 for /boot/efi without any problem…
But after that i wanted to mount /dev/sda2 to /datalinux for mountig my data partition.
But as i said, i can’t see sdb1 and sdb2 in the partition manager…


Yep both sda1 and sda2 are unmounted…

Ok, ok so this was from your current system not from the USB.

You can do this after the reinstallation.
You don’t need sda at all for reinstalling.


I wasn’t sure that if the installer didn’t see sda2, that I could then mount it manually.
I’ll try this tomorrow and keep you posted.
Is this a problem with the installer or am I just doing it wrong?
Thank you all for your help…

I’ve been following this topic from the beginning and maybe I should have written something about it earlier, when my blood pressure was still below 200.

Why on earth do you want to keep mounting sda?

Would you finally tell us where you want to install Garuda?

The latter :wink:

Edit: @FenDanT Please don’t get me wrong, but you would have to explain yourself better if you want someone to help you :slight_smile:


What you are trying to do is supported by the installer if you use the “manual partitioning” option.

When you get to the manual partitioning step, first set up the disk which is the installation target. You need to specify a FAT32 partition to mount at /boot/efi and a Btrfs partition to mount at /. Select the partition and click Edit at the bottom to add your mount specifications.

Once you have those set up, click the storage device drop down menu and select the other disk.


Choose the partition you want to mount as a data partition, and again click Edit.

If you have data on here you want to keep, be sure to leave it on “Content: Keep”. Then, if you have a custom mount point you want for it you just type that in to the mount point field.

On the overview screen, double-check everything looks right.

Click Install when you are ready.

Looks good to me. :sunglasses:


Thanks BluishHumility,

That’s exactly what i did.
On sdb i did a manual partitioning with sdb8 select for / in btrfs and sdb6 for /boot/efi in fat32, and asking to format both of them.

After that i choosed sda for the storage device and there, in manual partitioning, i have nothing.
Just this : unpartitioned space or unknown partition table

So i cant choose the mounting point /datalinux and “Content Keep”.

But, as filo said, i can just install Garuda this way anf trying to mount /datalinux afterwards…
I was just afraid that after installing i cant see sda…

If you can see /dev/sda from Gparted in the live USB, I’m confident that everything will be available after reinstallation.
Unfortunately, I don’t know Calamares in its technical details. There might be some technical limitation or maybe a strange small bug in what you see in that step.
But if data is there in the live USB, it is… there!
It will just be a matter of mounting it e.g. via fstab in the new system.


This is kind of an old answer, but seems like it might be worth a look:

If the issue is a bogus partition table, that may help straighten it out for you.

It is curious that Calamares would be more sensitive about that than Parted or Gparted. :thinking:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.