rEFInd cannot detect my kernel images

The default boot loader is GRUB, but I want to install rEFInd because it can detect bootable usbs without me going to the bios and change anything. But when I install rEFInd, It cannot detect my kernel images, instead it just list out the grub.efi which I want to delete and uninstall grub since it is useless to me. I tried the solution to edit the /boot/efi/EFI/refind/refind.conf to add a kernel image entry, but that fails with "invalid boot loader" or something. I know this is a lot of words, and if you read till here, thanks for your patient, and thank you for your help.

In short, grub-btrfs is needed in Garuda restore timeshift-autosnap Universum. :slight_smile:

Refind dosnt find this snapshots. A new app in git use different path to find them but the app use snapper for backup.
In very short, you are on your own with refind.

2 Likes

You may use this for a personal workaround, if you don't delete grub

because it is not useless to your case.
Choose your poison.

3 Likes

OK, now I understands... But how can I make rEFInd to detect the kernel image? I think I will only boot into grub if something horrible happens. Before that, I think I will just use rEFInd to boot kernel image.

As far as I know, there is no EFI driver for btrfs available - I boot with rEFInd to grub just for Garuda. All the other distros I pick up vmlinuz-linux as appropriate (and mostly automatically with running refind-install once in one of them). I see the same thing with f2fs as well - so the alternative work-around for me is a separate /boot partition that can be read - but for Garuda it is worth keeping grub around for access to timeshift snaps. Disable os-prober, (enter GRUB_DISABLE_OS_PROBER=true in /etc/default/grub) though - if you don't want to waste the time looking through the system for other bootables! rEFInd already has them, and boots them correctly :grin:

2 Likes

Ok thanks that is helpful. Thanks you all for your help. I will close this Issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.