Recommended Package Manager for Garuda

Just wondering what the recommended package manager for Garuda is?

Is there a package manager for Garuda that handles Community, AUR, Chaotic, Snap, AppImage, etc all in one?

EDIT: Sorry, I'm looking for a GUI Interface for PACMAN

It is pacman. Pacman will handle the regular repos and thanks to Chaotic, a significant part of AUR.

4 Likes

I'm so sorry. I should have been more clear, a GUI interface for Pacman

None. Garuda shipped with Pamac in the past but doesn't anymore. The only frontend I can recommend is pacseek which has a TUI instead of GUI. Keep in mind that this is my recommendation, not Garuda's.
For managing Flatpaks you can use Discover or GNOME Software with only flatpak backend installed.

7 Likes

Lets try that again it ships with Octopi, but Octopi doesn't handle Snap or Appimage. To be honest I would suggest the OP forget about Snaps. If you want a good GUI try Pamac-all. I also suggest to never reinstall discover, and one doesn't need Gnome Software in Plasma.

1 Like

tried installing pamac-all and got this error. Documenting here because I'm going to bed and will fix it tomorrow.

Summary
Package databases already synchronized
git clone https://aur.archlinux.org/pamac-all.git --depth=1 /tmp/[email protected]/arch/build_1669975596/pamac-all

Cloning into '/tmp/[email protected]/arch/build_1669975596/pamac-all'...
git clone https://aur.archlinux.org/libpamac-full.git --depth=1 /tmp/[email protected]/arch/build_1669975603/libpamac-full

Cloning into '/tmp/[email protected]/arch/build_1669975603/libpamac-full'...
Using custom makepkg.conf -> /home/mdoverl/.config/bauh/arch/makepkg.conf
makepkg -ALcfm --check --noarchive --nobuild --noprepare --nodeps --config=/home/mdoverl/.config/bauh/arch/makepkg.conf

==> Making package: libpamac-full 1:11.3.1-1 (Fri 02 Dec 2022 04:06:45 AM CST)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
-> Downloading libpamac-11.3.1.tar.bz2...
% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Dload  Upload   Total   Spent    Left  Speed
0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  1  416k    1  7455    0     0  15580      0  0:00:27 --:--:--  0:00:27 15563
100  416k  100  416k    0     0   423k      0 --:--:-- --:--:-- --:--:--  423k
==> Validating source files with sha256sums...
libpamac-11.3.1.tar.bz2 ... Passed
==> Extracting sources...
-> Extracting libpamac-11.3.1.tar.bz2 with bsdtar
==> Sources are ready.
Using custom makepkg.conf -> /home/mdoverl/.config/bauh/arch/makepkg.conf
makepkg -ALcsmf --skipchecksums --nodeps --config=/home/mdoverl/.config/bauh/arch/makepkg.conf

==> Making package: libpamac-full 1:11.3.1-1 (Fri 02 Dec 2022 04:06:48 AM CST)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
-> Found libpamac-11.3.1.tar.bz2
==> WARNING: Skipping verification of source file checksums.
==> Extracting sources...
-> Extracting libpamac-11.3.1.tar.bz2 with bsdtar
==> Starting build()...
The Meson build system
Version: 0.64.1
Source dir: /tmp/[email protected]/arch/build_1669975603/libpamac-full/src/libpamac-11.3.1
Build dir: /tmp/[email protected]/arch/build_1669975603/libpamac-full/src/libpamac-11.3.1/builddir
Build type: native build
Project name: libpamac
Project version: 11.3.1
C compiler for the host machine: cc (gcc 12.2.0 "cc (GCC) 12.2.0")
C linker for the host machine: cc ld.bfd 2.39.0
Vala compiler for the host machine: valac (valac 0.56.3)
Host machine cpu family: x86_64
Host machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (1.8.0)
Run-time dependency gobject-2.0 found: YES 2.74.2
Run-time dependency gio-2.0 found: YES 2.74.2
Run-time dependency gthread-2.0 found: YES 2.74.2
Run-time dependency libalpm found: YES 13.0.2
Run-time dependency json-glib-1.0 found: YES 1.6.6
Run-time dependency libsoup-2.4 found: YES 2.74.3
Run-time dependency polkit-gobject-1 found: YES 122
Run-time dependency appstream-glib found: YES 0.8.2
Run-time dependency gmodule-2.0 found: YES 2.74.2
Library posix found: YES
Library m found: YES
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency snapd-glib found: NO (tried pkgconfig)
../src/meson.build:33:1: ERROR: Dependency "snapd-glib" not found, tried pkgconfig
A full log can be found at /tmp/[email protected]/arch/build_1669975603/libpamac-full/src/libpamac-11.3.1/builddir/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
Aborting...
rm -rf /tmp/[email protected]/arch/build_1669975603

rm -rf /tmp/[email protected]/arch/build_1669975596


* The operation logs can be found at "/tmp/[email protected]/logs/install/aur/pamac-all/1669975608.log"

Hi!
I am using pamac-nosnap as a GUI. Pamac-all will try to install snap. This is really not good for arch based distros and in my opinion snaps are not good at all... But I only use it for searching as it is more comfortable than using pacman -Ss if you don't know the name of a package. It also gives flatpaks as results if you have enabled flatpak in the pamac options. It also gives some more information for some packages by clicking them, especially for flatpaks. You always get at least a link to the package but often a link to GitHub or a homepage where you can get more information about a package. This is way more comfortable than looking the further information up with pacman/yay/paru or the flatpak command.

Installing and uninstalling with pamac works fine (except for AUR), although it is not recommended. My way is typically to search in pamac and then install with pacman -S ... or flatpak install ...

To uninstall flatpaks I use Discover, as it gives an option to delete all user data as well. This way flatpaks will not flood your system up with orphaned user data if you uninstall them.

I know that flatpak is not officially supported, but I have some flatpaks installed and they all work with no issues.

5 Likes

Thanks everyone. I've been using Bauh as my frontend GUI for PACMAN.

I recommend bauh, it does everything. Regardless of whatever package manager you choose, just don't use them to update, best to use the recommended 'garuda-update' in terminal for that.

7 Likes

I have been using the Garuda update in terminal. I honestly hadn't realized that was recommended. But I thought, "If the Devs created that script/program, they must want me to use it." So I just use it.

5 Likes

Yes, that is the official way to update. Plus, you will need a Harry Potter wand. I think that is also recommended, at least on my system. :wink:

5 Likes

isn't this what your backup software of choice is? :rofl: :rofl: :rofl:

3 Likes

Amazon.com: The Noble Collection NN1910 Harry Potter Illuminating Wand, 14-Inch : Toys & Games

3 Likes

... thought I had the only one.

3 Likes

Yes, and if you don't say the proper words, you could end up with Ubuntu on your system. You might as well join sides with Lord Voldemort at that point. :grin:

5 Likes

I'm afraid you spell UBlunder wrong.

3 Likes