Recent Update (Today) breaks Login from SDDM

A recent update (Today) breaks my ability to login at SDDM. Immediately prior to update all is OK, after update, logout and login, SDDM tries but returns to the SDDM screen. Snapshots work to revert and all OK again.

These are the updates

Packages (74) acl-2.3.2-1  alsa-card-profiles-1:1.0.1-2  brave-nightly-bin-1.64.22-1  btrfs-progs-6.7-1
ca-certificates-mozilla-3.97-1  colord-1.4.7-1  colord-sane-1.4.7-1  cryptsetup-2.7.0-1
ddcutil-2.1.0-4  doublecmd-qt5-1.1.9-1  eza-0.17.3-1  fakeroot-1.33-1  ffmpeg-2:6.1.1-3
ffmpeg4.4-4.4.4-4  floorp-bin-11.8.2-1  fwupd-1.9.12-1  glib2-2.78.4-1  glm-1.0.0-1
gst-libav-1.22.9-1  gst-plugin-pipewire-1:1.0.1-2  gst-plugins-bad-1.22.9-1
gst-plugins-bad-libs-1.22.9-1  gst-plugins-base-1.22.9-1  gst-plugins-base-libs-1.22.9-1
gst-plugins-good-1.22.9-1  gst-plugins-ugly-1.22.9-1  gstreamer-1.22.9-1
gstreamer-vaapi-1.22.9-1  gtk3-1:3.24.41-1  lib32-glib2-2.78.4-1  lib32-gtk3-1:3.24.41-1
lib32-libpng-1.6.41-1  lib32-systemd-255.3-1  lib32-zlib-1.3.1-1  libavif-1.0.3-2
libcamera-0.2.0-1  libcamera-ipa-0.2.0-1  libcolord-1.4.7-1  libheif-1.17.6-3
libpipewire-1:1.0.1-2  libpng-1.6.41-1  libvpx-1.14.0-1  lilv-0.24.24-1  linux-zen-6.7.1.zen1-1
linux-zen-headers-6.7.1.zen1-1  minizip-1:1.3.1-1  nodejs-21.6.1-1  npm-10.4.0-1  nss-3.97-1
openmpi-4.1.6-3  orc-0.4.35-1  pipewire-1:1.0.1-2  pipewire-alsa-1:1.0.1-2
pipewire-audio-1:1.0.1-2  pipewire-jack-1:1.0.1-2  pipewire-pulse-1:1.0.1-2
pipewire-v4l2-1:1.0.1-2  pipewire-x11-bell-1:1.0.1-2  pipewire-zeroconf-1:1.0.1-2
qt5-webengine-5.15.16-3  qt5pas-1:1.2.15-1  rate-mirrors-0.17.1-1  rav1e-0.7.1-1
resvg-0.38.0-1  sdl2_mixer-2.8.0-1  serd-0.32.2-1  systemd-255.3-1  systemd-libs-255.3-1
systemd-sysvcompat-255.3-1  thunderbird-115.7.0-2  topgrade-14.0.1-1  vlc-3.0.20-6
xdg-utils-1.2.0r28+g9b7d253-1  zlib-1:1.3.1-1

Total Installed Size:  1790.32 MiB
Net Upgrade Size:         8.03 MiB

:: Proceed with installation? [Y/n]

There are a couple of errors on update about file permissions for share/polkit-1 Polkit-1 has incidentally moved from etc/pam.d to usr/lib/pam.d. This was a couple of days ago

I’m also getting ‘db’ errors for the ‘Extra’ Repository but i don’t think this connected.

Which of the updates do you think is causing problems so i can ignore it in pacman?

In general, I should say there are a lot of errors about right now.

Thanks in advance.

Here is my inixi

Kernel: 6.7.0-zen3-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: MSI model: A68HM-E33 V2 (MS-7721) v: 9.0 serial: N/A
UEFI: American Megatrends v: 8.5 date: 11/01/2018
Info: model: AMD Athlon X4 860K socket: FM2 (P0) note: check bits: 64
type: MT MCP arch: Steamroller level: v2 built: 2014 process: GF 28nm
family: 0x15 (21) model-id: 0x30 (48) stepping: 1 microcode: 0x6003106
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 3700 min/max: 1700/3700 boost: enabled
base/boost: 3700/3700 scaling: driver: acpi-cpufreq governor: performance
volts: 1.3 V ext-clock: 100 MHz cores: 1: 3700 2: 3700 3: 3700 4: 3700
bogomips: 29546
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X] vendor: PC Partner / Sapphire
driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
active: DP-1,HDMI-A-1 empty: DVI-D-1 bus-ID: 01:00.0 chip-ID: 1002:67ef
class-ID: 0300 temp: 52.0 C
Device-2: Logitech BRIO Ultra HD Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:2
chip-ID: 046d:085e class-ID: 0102 serial: <filter>
Display: server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,left model: Dell S2721H
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Dell S2721H
serial: <filter> built: 2022 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 460 Graphics
(radeonsi polaris11 LLVM 16.0.6 DRM 3.56 6.7.0-zen3-1-zen)
device-ID: 1002:67ef memory: 1.95 GiB unified: no
API: Vulkan v: 1.3.274 layers: 3 device: 0 type: discrete-gpu name: AMD
Radeon RX 460 Graphics (RADV POLARIS11) driver: mesa radv
v: 23.3.3-arch1.1 device-ID: 1002:67ef surfaces: xcb,xlib device: 1
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.3.3-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD FCH Azalia vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 1002:aae0 class-ID: 0403
Device-3: Logitech BRIO Ultra HD Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:2
chip-ID: 046d:085e class-ID: 0102 serial: <filter>
API: ALSA v: k6.7.0-zen3-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.1 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A
Local Storage: total: 1.35 TiB used: 530 GiB (38.4%)
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240M500SSD1
family: Micron Client SSDs size: 223.57 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: MU05 temp: 36 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 5y 89d 1h cycles: 1545
written: 23.93 TiB
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT240M500SSD1
family: Micron Client SSDs size: 223.57 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: MU05 temp: 38 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 5y 309d 19h cycles: 852
written: 38.5 TiB
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10EALX-009BA0 family: Blue size: 931.51 GiB block-size:
physical: 512 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s tech: N/A
serial: <filter> fw-rev: 1H15 temp: 35 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 6y 217d 21h cycles: 2043
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 51.44 GiB (23.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 27.2 MiB (9.1%) fs: vfat block-size: 512 B dev: /dev/sdb1
maj-min: 8:17
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 51.44 GiB (23.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 51.44 GiB (23.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 51.44 GiB (23.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.58 GiB used: 3.8 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 33.2 C mobo: N/A gpu: amdgpu temp: 50.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1038
Processes: 270 Uptime: 29m wakeups: 0 Memory: total: 16 GiB
available: 15.58 GiB used: 5.19 GiB (33.3%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1538 libs: 436 tools: octopi,paru
Shell: garuda-inxi (sudo) default: Bash v: 5.2.26 running-in: konsole
inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2024-01-08
Last full system update: 2024-01-23
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:

Please, how do i enclose the to quote things, I’ve forgotten.
Its OK now. :grinning:

1 Like

This could be causing the issue actually if the extra repo is not syncing.
This occurred to many users recently, but I think they were not able to finish the update.
Try anyway an

update remote fix

And post the output in case of errors.
Like this


Regarding the extra db errors I have recently seen TNE on telegram asking a few people for

head /etc/pacman.d/mirrorlist

it contains a command for rate-mirrors running which fixes the issue for some I believe. Anyway I tried a one liner for this and tested it on my system, can you check if you still get the extra db errors after this,

bash -c $(grep ARGS /etc/pacman.d/mirrorlist | cut -d: -f2)

Thanks for the replies. I tried your one-liner NaN, it ran, came up with a single 404 error for the Chaotic-Aur but wouldn’t login afterwards.
I also tried update remote fix which ran without errors but i couldn’t login afterwards.
Thank God for a manual snapshot.

Can you look into your journal for any errors? Don’t worry journal logs are not affected by snapshots. Do a,

journalctl --list-boots

It will list all the boot ups it remembers with timestamps and their index on left most column should be smth like 0 for current boot, -1 for the one before and so on.

Once you find the bootup which had your black screening issue can you do a

jctl <boot-idx>

Where you replace <boot-idx> with the index we found above.

jctl is an alias in garuda fish config. If it’s not there for you, you can also try

journalctl -b <boot-idx>

Let’s see if there is anything in the logs.


Thanks, All the usual failures which we are advised to ignore but maybe two new ones.

The job identifier is 199 and the job result is failed.
Jan 25 19:32:30 kevin-ms7721 systemd-remount-fs[542]: /usr/bin/mount for / exited with exit status 32.
Jan 25 19:32:30 kevin-ms7721 systemd[1]: Failed to start Remount Root and Kernel File Systems.
░░ Subject: A start job for unit systemd-remount-fs.service has failed
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit systemd-remount-fs.service has finished with a failure.
░░ The job identifier is 405 and the job result is failed.
Jan 25 19:32:43 kevin-ms7721 systemd[6741]: Failed to start Profile-sync-daemon.
░░ Subject: A start job for unit UNIT has failed
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit UNIT has finished with a failure.
░░ The job identifier is 29 and the job result is failed.

I don’t remember seeing these before.

Just a little point. It doesn’t black screen, it try’s to login and flashes text up but then returns to the SDDM login screen.

I usually update every day. Maybe i should just wait a few days . These things tend to get fixed buy someone else.

Hmm :thinking: that’s definately the cause of our issue. But it doesn’t contain why it couldn’t mount root. Can you try,

journalctl -S "2024-01-25 19:32" | tb

this will put all your logs from the given timestamp to now on termbin and give you a link that you can paste here. Maybe the complete log has more to offer about why this failure happened.

Thanks, Don’t think it did it.

╭─kevin@kevin in ~ took 2ms
╰─λ journalctl -S "2024-01-25 19:32" | tb
read(net): Connection reset by peer

╭─kevin@kevin in ~ took 1s
[[⚡]|[🔴]] => 🔴ERROR ×

Dracut and Systemd form part of the updates. Is it possible to list each update with pacman and ‘Enter’ to accept individual updates to single out the problem one?

It did catch everything around the error message you sent before it hit the read/write limit set by server.

Reading from the logs I still couldn’t find anything worthy of making you stop mounting. Then I started searching for your error number and it seems you might have some invalid options in your fstab. Can you share your

cat /etc/fstab

Hopefully this is easy fix other wise the only other option would be booting up to the sddm screen changing TTY and then look at dmesg errors to understand why mount fails.

Sadly no, you can certainly write your own custom script for this but by default pacman doesn’t have any such features that I am aware of. You would have to do it manually.

Here you go

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=390B-FB09                            /boot/efi      vfat    defaults,noatime 0 2
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/sdc2 /mnt/Data ntfs defaults,uid=999,gid=1000 0 0

I inderstand how important fstab is but remember, this only happens after the update and a previoiusly saved manual snapshop reverts it back to normal and I’m using it now.

I completely agree with you. But I just wanted to make sure since almost every search for this

suggested wrong fstab options.
Take this for example.

However from what I see there doesn’t appear to be anything wrong. It seems the only way to solve this is the hard way.

Can you update your system either all at once or one at a time using the package list you originally provided till it reaches your problematic state. Then change TTY


  1. Turn on network manager,
sudo systemctl start NetworkManager.service

remember the name of service file is case sensitive.

  1. connect to the internet

this will provide you with a tui interface to connect to wifi then,

  1. upload your dmesg logs
sudo dmesg | tb

dmesg should contain a lot more about mount problems the only issue is it’s not saved anywhere unlike journal logs.

The reason why I asked updating system packages either one at a time or all at once. Both have their upsides and downsides.
On the flip side updating your system all at once and directly jumping to error message would be easier and hopefully dmesg contains something useful for resolving this with ease. On the other hand if you update one at a time you will be able to single out the problematic package as well and if dmesg on the offchance doesn’t contain anything useful you can still look at the package’s bug reports to see if anything has changed.

If you are confused about how to update package one at a time,

  1. sync your repos with remote, this is a dangerous state and its usually advised to immediately update all system packages to prevent getting into a partially updated state.
sudo pacman -Sy
  1. update a package with
sudo pacman -S pkgname

Before doing this though I will suggest create a manual snapshot with a meanigful name and keep track of it since pacman hooks are going to create new snapshots each package update, you don’t wanna lose this working snapshot. I believe the default limit of snapshots is 10 (configurable) before they are deleted starting from the oldest first.

OK, thanks. Might be some time as I got to work today as well. I’ve increased the Snapper save count to 50. Plus I don’t think that Manual Snapshots are deleted in the clean up.

One time it did fault I did manage to get into a tty3 i think, but startx didn’t work. Now we know i could try mounting ./ and see if there are error messages?

Just bit of extra info.

After the problem update, I have x11 errors as well.
Although i did get Wayland to login a couple of times from the tty3.

No update today, my system still works fine.

Well here is a thing, Wayland works.

  1. Log out of X11, choose Wayland from selection bottom left.
  2. Log in again. Clear Cache, Clear Package Cache, Remove Orphans, Update Mirrors.
  3. Run Garuda Update in the usual way.
  4. Restart and lo & behold, logs into Wayland perfectly.

I suspect a Kernel issue with X11.

In that case can you switch to x11 perform the login loop and then,

Dmesg contains messages from kernel so maybe if we get a look at it then maybe we can find what’s the cause of issue.

╭─kevin@kevin in ~
╰─λ sudo dmesg | tb

╭─kevin@kevin in ~ as 🧙 took 5s

I do keep trying Wayland, and it works when X11 won’t
I may as well stick with it for now. Need a working PC.

If you are interested. This is the Dmesg from my working system. Trying to login to X11, it fails at

6.503370] systemd[1]: Stopped Plymouth switch root service.

But its working now so I’m happy to leave it.

dmesg from a working system is not really helpful since it won’t contain the messages that tell us why the kernel couldn’t mount the file system. However your desire to have a working PC is understandable. I understand if you want to stick with wayland since it works for you.

Completely understandable. However if you try to revisit this in future do try to change TTY at that error message see if can even run any commands?


I thought i’d give it a go :grinning:

Log out of Wayland, into X11 and it works!!
It survived a reboot as well.
So we might never know the answer
Back to X11 or Wayland, which do you suggest?