Rebooting Linux into Windows

I found this guide on how to boot from Linux into Windows without interacing with grub and have followed it but the custom command “wreboot” does nothing and the command it runs “sudo grub-reboot 2 && reboot” when it tries to boot windows from the grub gives me this message.
Booting 'windows boot manager (on /dev/sdd1)' error: no such device: 11EA-2C1F. error: disk 'hd3,gpt' not found.
which is the same message grub gave me when i tried to boot windows from it without enabling secure boot in the bios.

EDIT: accidentally left out "Booting ‘windows boot manager (on /dev/sdd1)’ "

the ‘2’ is wrong and it is selecting a device with no bootable efi partition.

you’ll need to count the items inside the advanced options list as well in order to determine the correct numeric designator for your Windows bootloader.

1 Like

I’m pretty sere it’s 2 i accidentally left out from the error message ’ Booting 'windows boot manager (on /dev/sdd1)’ and following your suggestion and entering 10 just booted Linux as normal

#2 on the list will be the top item inside the advanced options.

with only one Linux kernel installed, the windows install drive should be ‘5’.
with 3 kernels windows should be ‘11’.

i just launched the first option of advanced options and it launched Linux as normal and the message i get from “sudo grub-reboot 2 && reboot” “no such device: 11EA-2C1F” is the UUID of the EFI partition of the windows drive.

i think you misunderstand.

the advanced list itself is not counted - the items inside the list are counted, starting with #2.
for every Linux kernel installed there are 3 items listed inside the advanced options, which makes the next item outside and below this list #5 with only -one- kernel installed.

get it?
with 2 kernels installed there are 6 advanced options listed which would make the next item outside the list #8.

so… count the top item, open the advanced list and continue counting until the last item is counted and then close that list and continue counting to get the numeric designator for your windows bootloader.

I appreciate that you are trying to help but you are clearly wrong entering “sudo grub-reboot 11 && reboot” which by your opinion should launch windows instead launches Linux and the command “sudo grub-reboot 2 && reboot” gives the error " Booting 'windows boot manager (on /dev/sdd1)' error: no such device: 11EA-2C1F. error: disk 'hd3,gpt' not found"
the same error that i would get when i tried launching windows without enabling secure boot the number is correct, it’s trying to launch windows and failing that is the problem not the the wrong number.

lmfao don’t use MY numbers, you’ll need to count your own.


i didn’t i followed your advice and counted the entries and have tried both 10 and 11 it did nothing.

It sounds like you have so far not been able to boot Windows with secure boot disabled. Is that right? If so, it seems likely that is your problem.

Check in your BIOS settings that CSM/legacy mode are disabled, or that it is explicitly set to “UEFI only” mode. linux - How do I boot Windows 10 without Secure Boot (but with UEFI enabled) if it was preinstalled with Secure Boot? - Super User

1 Like

nah i have secure boot enabled and if i do it straight from grub or the bios it’s fine but if i launch it with the command sudo grub-reboot 2 && reboot i get the error. Booting 'windows boot manager (on /dev/sdd1)' error: no such device: 11EA-2C1F. error: disk 'hd3,gpt' not found.

Answer: in the Bios for my pc i had to change the setting SATA support from “Last Boot SATA Devices Only” to" All SATA Devices" and then the command sudo grub-reboot 2 && reboot worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.