Realtek RTL8811AU Wifi not working (TP-Link AC600)

Hi, I am a very new user to both arch linux as well as Garuda KDE I have switched from windows to here hence have zero knowledge about how things work around here. As the title suggest i have been trying to make my Wi-Fi adapter (Archer T2U Nano) getting run on the system but have been unable to do so after trying most of the top solutions over the web such as installing Realtek wifi adapters and downgrading my kernel but i run into some problem no matter what i try. Without this driver i wont be able to update the system through the assistant so if you can please help me out ASAP , really grateful to you for having read this and please forgive any of my mistake done unintentionally.
Thank you.

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3b68888c-6e15-481b-8cb8-2ea96d278e2e rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Intel model: H61S serial: <superuser required>
BIOS: American Megatrends v: 4.6.5 date: 11/01/2022
Info: model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3416 high: 3600 min/max: 1600/3600 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2866 2: 3600 3: 3600
4: 3600 bogomips: 25544
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915
v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: VGA-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0152
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: VGA-1 model: Acer V193HQV serial: <filter> built: 2010
res: 1366x768 hz: 60 dpi: 85 gamma: 1.2 size: 410x230mm (16.14x9.06")
diag: 470mm (18.5") ratio: 16:9 modes: max: 1366x768 min: 720x400
API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
device: 1 drv: swrast surfaceless: drv: crocus x11: drv: crocus
inactive: gbm,wayland
API: OpenGL v: 4.5 compat-v: 4.2 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 2500 (IVB
GT1) device-ID: 8086:0152 memory: 1.46 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
HD Graphics 2500 (IVB GT1) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:0152 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: TP-Link AC600 wireless Realtek RTL8811AU [Archer T2U Nano]
driver: N/A type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-1.1:3 chip-ID: 2357:011e class-ID: 0000 serial: <filter>
IF-ID-1: enp0s29u1u1 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: OPPO [] driver: rndis_host v: kernel type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.1:30 chip-ID: 22d9:276a
class-ID: 0a00 serial: <filter>
Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode)
driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
bus-ID: 2-1.2:4 chip-ID: 0a12:0001 class-ID: e001
Report: ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0 lmp-v: 6
status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 1.03 TiB used: 7.97 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SSD 128GB size: 119.24 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: SSD serial: <filter>
fw-rev: XKR scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: Expansion HDD
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 1901 scheme: MBR
ID-1: / raw-size: 115.24 GiB size: 115.24 GiB (100.00%)
used: 7.97 GiB (6.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 115.24 GiB size: 115.24 GiB (100.00%)
used: 7.97 GiB (6.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 115.24 GiB size: 115.24 GiB (100.00%)
used: 7.97 GiB (6.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 115.24 GiB size: 115.24 GiB (100.00%)
used: 7.97 GiB (6.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.65 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 213 Uptime: 41m wakeups: 0 Memory: total: 8 GiB
available: 7.65 GiB used: 4.32 GiB (56.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1772 libs: 522 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2024-01-08
Last full system update: 2024-01-08
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

Welcome to the Garuda community @misky500.

There is a post on our forum dealing with your WiFi chip. Install the driver suggested in this link:


I hope this is help full even a little bit even though might not concern what you are specifically looking for

I find using nmcli to play around with this wifi/network stuff more effective and easy e.g

nmcli device connect <adapter>

nmcli -h

Thanks for trying to assist @Yada.

Unfortunately, this user appears to be using a Realtek WiFi chip with an out-of-kernel driver. Until the user installs the correct driver they will likely not be able to connect to WiFi no matter which method they use.


Thanks a lot to help me out, but it is not a realtek wifi chio its a tp link wifi adapter

rreally thankful for the help but it returned this error,

find-the-command: "rtl88xxau-aircrack-dkms-git" is not found locally, searching in repositories...
find-the-command: /var/cache/pkgfile/*.files are out of date, update? [Y/n]
[sudo] password for yuvraj:
:: Updating 5 repos...
download complete: multilib             [   208.9 KiB   136K/s  4 remaining]
download complete: core                 [  1046.0 KiB   543K/s  3 remaining]
garuda is up to date
download complete: chaotic-aur          [    53.0 MiB  2.32M/s  1 remaining]
download complete: extra                [    38.9 MiB  1389K/s  0 remaining]
:: download complete in 28.68s            <    93.1 MiB  3.25M/s  4 files    >
:: waiting for 1 process to finish repacking repos...
find-the-command: command not found: "rtl88xxau-aircrack-dkms-git"

pacman -S rtl88xxau-aircrack-dkms-git
it’s a package, not a command.


Thanks a lot it surely worked!!! Sorry for my utmost stupidity and before this command worked i had to use the following command to get rid of the key issues i was facing since last night

update remote keyring
1 Like

The brand of the USB WiFi stick (TP Link)is irrelevant. It is 100% about which manufacturer produced the actual wifi chip inside.

WiFi manufacturers often change the WiFi chips they use inside the WiFi devices they produce. The model number TP-Link AC600 is not the deciding factor in which driver you may need to install. This is because the WiFi chips inside are often changed over time if the model is sold for a fair number of years. The relevant information from your inxi output is Realtek RTL8811AU, as this is the actual WiFi chip inside the USB WiFi dongle you purchased. The chip determines the driver you require. This is why I recommended you install the rtl88xxau-aircrack-dkms-git driver as it covers your Realtek wifi chip, (as well as other similar Realtek chips). You never want to install the driver from the TP Link website. You should always attempt to locate your WiFi chip’s driver at the AUR or Chaotic AUR repositories first.

I hope you don’t mind, I am going to amend your thread title and location to make it easier for others using your WiFi chip to find a solution.

Glad I could help you locate the correct driver to get your wifi up and running. :+1:


Sorry, the solution was to install the driver and not how to do this correctly in the terminal.
So I refer to the correct post and have marked it.


Thanks a lot sir my most humble respect to you for helping such a trashbag dumbo like me, I am loving Garuda linux because of all you guys really appreciate the support :))

LOL no need for self deprecation, no one was born learned.
Would you believe, the first time I read that shift left would multiply by two, I thought my keyboard was broken?

Again, welcome to the Garuda community @misky500. I’m sure you’ll enjoy your time here.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.