Realtek rtl8188eu - Tp-link wifi adaptor TL-WN725N goes to 0% signal after working fine for few minutes everytime

Hello,
I Just install Garuda Linux and through out the installation and after install my WiFi adapter which is Tp-link TL-WN725N was working fine, however after few minutes it start loosing signal and every time after pc start it works fine and then signal goes to 0% for every nearby wifi. here is inxi -Faz

System:
Kernel: 5.19.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/vmlinuz-linux-zen
root=UUID=8aa43813-96df-49df-a22f-0994b48419c0 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=083fba5b-8fba-4d3e-9858-3cda312585b3 loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: A68HM-K v: Rev X.0x serial: <filter>
UEFI-[Legacy]: American Megatrends v: 1503 date: 03/10/2016
CPU:
Info: model: AMD A4-6300 APU with Radeon HD Graphics socket: FM2 (FM2+)
note: check bits: 64 type: MT MCP arch: Piledriver level: v3 built: 2012-13
process: GF 32nm family: 0x15 (21) model-id: 0x13 (19) stepping: 1
microcode: 0x6001119
Topology: cpus: 1x cores: 2 smt: enabled cache: L1: 96 KiB desc: d-2x16
KiB; i-1x64 KiB L2: 1024 KiB desc: 1x1024 KiB
Speed (MHz): avg: 1800 min/max: 1800/3700 boost: enabled
base/boost: 3700/3700 scaling: driver: acpi-cpufreq governor: schedutil
volts: 1.3 V ext-clock: 100 MHz cores: 1: 1800 2: 1800 bogomips: 14763
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Richland [Radeon HD 8370D] vendor: ASUSTeK driver: radeon
v: kernel alternate: amdgpu arch: TeraScale-3 code: Northern Islands
process: TSMC 32nm built: 2010-13 ports: active: VGA-1 empty: DVI-D-1
bus-ID: 00:01.0 chip-ID: 1002:9998 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: VGA-1 mapped: VGA-0 model: Acer P166HQL serial: <filter>
built: 2015 res: 1366x768 hz: 60 dpi: 101 gamma: 1.2
size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
max: 1366x768 min: 640x480
OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.19.9-zen1-1-zen LLVM 14.0.6)
v: 4.3 Mesa 22.1.7 compat-v: 3.1 direct render: Yes
Audio:
Device-1: AMD FCH Azalia vendor: ASUSTeK AM1I-A driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.19.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK AM1I-A driver: N/A modules: r8169 pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: r8188eu bus-ID: 2-1:2 chip-ID: 0bda:8179 class-ID: 0000
serial: <filter>
IF: wlp0s19f2u1 state: down mac: <filter>
IF-ID-1: enp0s18f2u5 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: OPPO SDM712-MTP _SN:CBE5A43D type: USB driver: rndis_host
v: kernel bus-ID: 1-5:5 chip-ID: 22d9:2766 class-ID: 0a00 serial: <filter>
Report: bt-service: disabled note: tool can't run
Drives:
Local Storage: total: 931.51 GiB used: 7.53 GiB (0.8%)
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-08WN4A0 family: Blue size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: 1A02 temp: 38 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 4d 23h cycles: 103
Partition:
ID-1: / raw-size: 457.4 GiB size: 457.4 GiB (100.00%) used: 7.29 GiB (1.6%)
fs: btrfs block-size: 4096 B dev: /dev/sda5 maj-min: 8:5
ID-2: /boot raw-size: 350 MiB size: 349.3 MiB (99.79%) used: 248.1 MiB
(71.0%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 457.4 GiB size: 457.4 GiB (100.00%) used: 7.29 GiB
(1.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 457.4 GiB size: 457.4 GiB (100.00%) used: 7.29
GiB (1.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 457.4 GiB size: 457.4 GiB (100.00%) used: 7.29
GiB (1.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5 maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.04 GiB used: 258.8 MiB (8.3%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 24.0 C mobo: N/A gpu: radeon temp: 9.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 177 Uptime: 24m wakeups: 0 Memory: 3.04 GiB used: 1.39 GiB
(45.8%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1148 libs: 302
tools: octopi,paru Shell: Bash (su) v: 5.1.16 running-in: konsole
inxi: 3.3.21

I am new to Arch linux so sorry in advanced if i messed something up and didnt know about it and thanks for helping and for your time.

Hi there, welcome to the forum.
As a first test, I think you could try disabling WiFi powersave option (and maybe also mac address randomization) from Garuda Network Assistant.
It could also be that this kernel bug is still open. The status Is such, but they seem to say that the patch was merged long ago.
https://bugzilla.kernel.org/show_bug.cgi?id=215201
So, you could try installing the package referenced there, or the proprietary driver, that you can find in the AUR repository
https://aur.archlinux.org/packages/8188eu-dkms
For which you will need a

paru 8188eu-dkms
4 Likes

Hi thank you your reply

  1. WIFI power save option is disabled already.
  2. bugzilla patch did not work tried git clone then reboot everything is still the same.
  3. AUR repository installation with
paru 8188eu-dkms

can you please show me how I am completely new here, sorry :pensive:

The command above, launched from terminal, should install the proprietary drivers and blacklist the current kernel driver.
Just launch it, you'll be shown the "pkgbuild", exit from that preview pressing q, confirm installation with Y and when finished reboot.

3 Likes

It seems working fine now your solution works, Thanks a lot :slightly_smiling_face:

1 Like

hi again,
It turn out that after shut down and whole thing start again,but this time it has signal and still having connecting issue tried several time. Only after rebooting my router it connects with no issues so what now

Disable MAC Address randomization.

If you are dual booting with Windows, be sure to disable wifi power saving in the Windows device manager.

3 Likes

hi
actually after rebooting router its working fine again, after booting system several times I find out some times it needed to reboot router other wise it working fine. My router is also new just brought it last week and was working fine with previous Debian distro.
also no dual boot only Garuda linux.
so its working fine for now then I guess thanks a lot for help

1 Like

Check your lease time in your router's settings, and be sure it is set to at least 24 hours, ( or longer).

Welcome to Garuda.

1 Like

Done set for 24 hour (1440 minutes) but still working fine for now lets see

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.