Random freezes with XFCE lite edition and Zen Kernel

Hello there,

I just installed the latest Garuda XFCE edition and I quite like it, specially for it's speed and responsiveness.
Nevertheless I get random freezes when using Zen Kernel.
This is quite annoying as data might be lost (my browser profile data especially, which I store in memory with the help of profile-sync-daemon) if I have to switch power off in order to reboot.

LTS works fine most of the time, although I had one freeze as well.

Could anyone give me a hint on how to debug this?

Here is some system information (inxi output):

inxi --full
System:    Host: connzens-desktop Kernel: 5.4.74-1-lts x86_64 bits: 64 Desktop: Xfce 4.14.3 Distro: Garuda Linux 
Machine:   Type: Mini-pc System: Intel Client Systems product: NUC10i7FNH v: K61081-302 serial: <superuser/root required> 
           Mobo: Intel model: NUC10i7FNB v: K61360-302 serial: <superuser/root required> UEFI: Intel 
           v: FNCML357.0046.2020.0928.1457 date: 09/28/2020 
CPU:       Info: 6-Core model: Intel Core i7-10710U bits: 64 type: MT MCP L2 cache: 12.0 MiB 
           Speed: 802 MHz min/max: 400/1100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting resolution: 3840x2160~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
[ ... ]
Drives:    Local Storage: total: 1.70 TiB used: 529.45 GiB (30.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB size: 232.89 GiB 
           ID-2: /dev/sda vendor: Western Digital model: WDS500G2B0A-00SM50 size: 465.76 GiB 
           ID-3: /dev/sdb type: USB vendor: Seagate model: ST1000LM 048-2E7172 size: 931.51 GiB 
           ID-4: /dev/sdc type: USB vendor: Sabrent model: SABRENT size: 111.79 GiB 
           ID-5: /dev/sdd type: USB vendor: Generic model: Flash Disk size: 3.75 GiB 
Partition: ID-1: / size: 202.80 GiB used: 25.82 GiB (12.7%) fs: btrfs dev: /dev/nvme0n1p1 
           ID-2: /home size: 457.40 GiB used: 258.02 GiB (56.4%) fs: ext4 dev: /dev/sda1 
           ID-3: /var/log size: 202.80 GiB used: 25.82 GiB (12.7%) fs: btrfs dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 29.80 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p2 
           ID-2: swap-2 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram3 
           ID-6: swap-6 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram4 
           ID-7: swap-7 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram5 
           ID-8: swap-8 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram6 
           ID-9: swap-9 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram7 
           ID-10: swap-10 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram8 
           ID-11: swap-11 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram9 
           ID-12: swap-12 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram10 
           ID-13: swap-13 type: zram size: 663.0 MiB used: 0 KiB (0.0%) dev: /dev/zram11 

Help is greatly appreciated, as I'd really like to continue using Garuda Linux.

Best regards,
Constnatin

Have you thought of running the current Arch kernel? Meaning the mainline, rather than the -zen or -lts?

I know nothing about NUCs.

regards

1 Like

Hi,

thanks for the quick reply. Are you referring to linux package, containing 5.9.4.arch1-1 or linux-mainline which is version 5.10rc2-1 (even more experimental I guess)?

I haven't tried either of them, but I suppose Garuda is somehow optimized for Zen kernel, correct?

Yup. Just install it and the header packages...

pacman -S linux linux-headers

Reboot, and it should show up as an option in GRUB.

1 Like

Even after moving to the tkg kernels, I was having similar issues until I changed the cpu profile to performance and forced compositing in the video card.

Okay, the reponses so far suggest avoiding Zen kernel. Does anyone have advice on how to actually debug the problem in order to use Zen kernel?

I don't think this is strictly related to the Zen kernel. Try the fallback image when booting on all the different kernels you have installed. I'm betting the fallback image on the Zen kernel won't give you problems.

2 Likes

Recompile with flags for your hardware. Or, if one Zen kernel works and another fails, then you can bisect to find the possible problem(s).

The first isn't very difficult, but is rarely necessary nowadays. The second takes some amount of time and all your processing power. You can find plenty of written instructions around the 'net.

But, personally, it's probably not necessary to do either. It's most probably one piece of problem-hardware and there should be a fairly simple solution after we narrow the problem further. That takes intimacy with your computer hardware, log keeping, and bug tracking. It sounds hard but it is not. It may be a little time consuming.

regards

7 Likes

I know it's been a while :smile: That's because I opted for linux-xanmod which works pretty well so far.
Thanks for all your advice.

2 Likes

Yeah, we have been pondering to switching to Linux-xanmod since 2 weeks.

It is under testing right now.

1 Like

Didn't the mainline Arch linux kernel adopt BFQ awhile back? Or am I dis-remembering stuff again? I generally see little performance gain from the zen kernel. Not on modern hardware, anyway. Just saying.

regards

1 Like

we are currently planning to moving to linux-tkg-bmq kernel
instead of linux-zen

in next release

4 Likes

I was also experiencing the same random freezing issues. I think something messed up with Zen kernel. Linux-tkg-bmq kernel fixed up all freezing issue and solved my problem. Since then no issues of system freeze.

1 Like

Welcome to the forum and thanks for your feedback!
Anyway, I think we'd better close this old topic, related to a specific and solved issue.
In general, we ask to open new topics in case of similar issues, since things change quickly.
In this case, this was just a reinforcing statement, so no problem :+1:

2 Likes