Random freeze

I have some random freeze on my computer since long time, sometimes it make black screen sometimes gray sometimes just freeze sometimes make a loop on sound. I change almost everything on my computer except the power supply and i will try tomorrow, i try the different kernel zen lts and hard and i don't really know what to do

Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=143e1267-dee4-439e-863e-8de817d215dd rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.24.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: H170-D3HP v: N/A
serial: <superuser required>
Mobo: Gigabyte model: H170-D3HP-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F20g date: 03/09/2018
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: Discharging
Info: model: Intel Core i5-6500 bits: 64 type: MCP arch: Skylake-S
family: 6 model-id: 0x5E (94) stepping: 3 microcode: 0xEC
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3446 high: 3486 min/max: 800/3600 scaling:
driver: intel_pstate governor: performance cores: 1: 3486 2: 3424 3: 3426
4: 3451 bogomips: 25599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Device-1: AMD Juniper PRO [Radeon HD 5750] vendor: PC Partner Limited
driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0
chip-ID: 1002:68be class-ID: 0300
Display: x11 server: X.Org compositor: kwin_x11 driver:
loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82
size: 598x336mm (23.5x13.2") diag: 686mm (27")
renderer: AMD JUNIPER (DRM 2.50.0 / 5.16.8-zen1-1-zen LLVM 13.0.0)
v: 3.3 Mesa 21.3.5 compat-v: 3.1 direct render: Yes
Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
class-ID: 0403
Device-2: AMD Juniper HDMI Audio [Radeon HD 5700 Series]
vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 1002:aa58 class-ID: 0403
Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
IF-ID-1: enp0s20f0u14 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: Qualcomm SAMSUNG_Android type: USB driver: rndis_host v: kernel
bus-ID: 1-14:3 chip-ID: 05c6:f00e class-ID: 0a00 serial: <filter>
Report: bt-service: disabled note: tool can't run
Local Storage: total: 931.51 GiB used: 259.44 GiB (27.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: GPT
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 259.44 GiB (27.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 259.44 GiB (27.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 259.44 GiB (27.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 259.44 GiB (27.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 512 KiB (0.0%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 30.0 C
Fan Speeds (RPM): N/A
Processes: 215 Uptime: 4m wakeups: 3 Memory: 15.58 GiB
used: 1.94 GiB (12.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1482 lib: 390 Shell: fish
v: 3.3.1 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-02-08
Last full system update: 2022-02-08
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Not sure what’s causing it but some people have solved freeze’s and stutters by following the attached. Maybe give it a go and see?

I try this thanks

It might be worth checking if your BIOS has an update. You will need a USB drive (and you’ll have to format it to FAT32).

1 Like

First thing I checked when I saw this post. That is the latest BIOS version. I hope they try the LTS kernel to see if that helps (and maybe enabling and trying REISUB to see if low level kernel commands can safely restart the computer if they encounter the error again)


This is the last update of the bios i already changed it, I tried aswell the magic key syst but i don't have the keyboard anymore.

The causes of system freezes is an almost endless list of possibilities. The causes can range from faulty hardware to any of a thousand software/firmware/bios//kernel possibilities. It is usually best to eliminate bios/kernel possibilities first, as those are the least time consuming leads to pursue. Be sure to test out at least 3 or 4 of the most recommended kernels. Also ensure your bios (and your system) is fully up to date.

It is incumbent upon you to make the process as painless as possible for everyone trying to assist you. You need to start by searching the forum first, and then the internet, for possible causes/fixes to your issue.

Start by running a forum search on variations of the following terms:

system freeze
lock up
locked up
hard lock
hard lock up
hard power down
hard power off
force power down
system unresponsive
computer unresponsive

Any variations of those terms should return tons of hits to comb through.

Here are some further tips to aid with your search efforts:

How to search for solutions the right way

Next, start writing a list of all suggestions for fixes you uncover and record all your efforts. Record all inputs and outputs of any commands run and any fixes you've attempted. Post regularly the results of your progress. There have been tons of suggestions already given on the forum to fix freezing issues. It is your job to sift through all the possible fixes already suggested on this topic to increase your probability of finding a solution.

If you are thorough and precise about reporting all your troubleshooting efforts, there is a good chance a solution will be found to your issue. The more proactive you are in this respect, the more likely you are to receive assistance from forum experts. The less information and documentation you provide on your efforts, the less likely you will ever find a resolution to your issue. Optics are important if you desire assistance, the more of an effort you make, the more others will come to your assistance.

Good luck on your search for a solution.


I have tried the Cachyos kernel and change the power supply, stop the module of the video card of the motherboard and deactivated it in the bios (intel), change the plug in the house (i'm in a new house) and still have the freeze sometimes none in a day sometimes 3-4 in the days. Now i have only the minimum in my computer (one disk one video card, mouse, keyboard), before i tried to install manjaro and have the same freeze problem. I don't see nothing strange in the journalctl change the log to 5 in the grub. Next step will be to try a inverter.

I would also be sure to test the kernels, linux and linux-mainline as well.

I would also investigate kernel parameters used to correct issues with skylake motherboards.

1 Like

To finish there were 2 thinks that were wrong my firefox and one plug for the graphic card on my PSU. I correct my firefox applying https://wiki.archlinux.org/title/firefox#Hardware_video_acceleration for Radeon. I'm back on Zen kernel. Thanks for your answed ! ]

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.