Random crash in Steam games

  Kernel: 5.17.7-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: root=LABEL=linux rootflags=subvol=/@ rw add_efi_memmap quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 mitigations=off
    sysrq_always_enabled=1 intel_iommu=on i915.enable_guc=0 i915.enable_gvt=1
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: MONSTER product: ABRA A7 V13.1 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V13.1 serial: <superuser required> UEFI: INSYDE v: 1.07.02TFB2
    date: 05/11/2021
  ID-1: BAT0 charge: 38.5 Wh (100.0%) condition: 38.5/40.1 Wh (95.8%) volts: 16.2 min: 14.6
    model: Notebook BAT type: Li-ion serial: <filter> status: full
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake family: 6
    model-id: 0x8D (141) stepping: 1 microcode: 0x2C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB
    desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1054 high: 1458 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 801 2: 1134 3: 801 4: 1458 5: 1164 6: 1301 7: 912 8: 809 9: 1188
    10: 940 11: 801 12: 1342 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: CLEVO/KAPOK driver: nvidia
    v: 515.43.04 alternate: nouveau,nvidia_drm pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max:
    lanes: 16 ports: active: none empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:25a2 class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:3 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x978f built: 2020 res: 1920x1080 hz: 144 dpi: 128
    gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.0.3 direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.7-zen1-2-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 476.94 GiB used: 417.72 GiB (87.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL2512HCJQ-00B00 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: GXA7301Q temp: 41.9 C scheme: GPT
  ID-1: / raw-size: 149 GiB size: 149 GiB (100.00%) used: 133.01 GiB (89.3%) fs: btrfs
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 174.8 MiB (17.1%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 149 GiB size: 149 GiB (100.00%) used: 133.01 GiB (89.3%) fs: btrfs
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 149 GiB size: 149 GiB (100.00%) used: 133.01 GiB (89.3%) fs: btrfs
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 149 GiB size: 149 GiB (100.00%) used: 133.01 GiB (89.3%) fs: btrfs
    dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 1024 MiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: swap-2 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 75.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 321 Uptime: 30m wakeups: 2 Memory: 15.41 GiB used: 4.69 GiB (30.5%) Init: systemd
  v: 250 tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1773 lib: 510
  flatpak: 0 Client: shell wrapper v: 5.1.16-release inxi: 3.3.15
Garuda (2.6.3-2):
  System install date:     2022-01-25
  Last full system update: 2022-05-17
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

When I write a game crashes this is what happens:

  • The game is frozen but I can move the mouse, clicking won't result in anything
  • Desktop shortcuts like Alt+Tab, Super+D don't work
  • Switching TTYs with Ctrl+Alt+F1-6 doesn't work
  • Game sound keeps playing
  • I can only recover system with Alt+SysRq+E, which takes immediate effect and brings me back to login screen
  • Fan sound decreases after a few moments, as if I have closed the game

I downloaded CS:GO and launched the game. Whn I clicked the ingame "play" (not the play button in Steam) button, which is supposed to show map selection screen, I got a crash. I recovered with Alt+SysRq+E and launched CS:GO again. This time I opened the Settings page of the game and got another crash. I launched CS:GO again, joined a match and managed to finish one, but the game crashed on the second match. Now, if I try to play CS:GO I will usually get a crash in less than 2 hours. I tried these to remedy the CS:GO crash:

  • Launching with and without -vulkan launch parameters
  • Launching with and without -nojoy launch parameters
  • Using Steam flatpak
  • Using Steam with native runtime
  • Launching both in Optimus Hybrid modes and NVIDIA-only mode
  • Using a different DE (Enlightenment)
  • Launching with and without Mangohud
  • Dumbing down game settings so CPU and GPU are below 80 C, otherwise CPU is between 85-95 C and GPU is 80-90 C and I am GPU bottlenecked
  • Trying Arch Linux instead of Garuda Linux
  • Disabling Steam Overlay
  • Using 510, 515-closed and 515-open NVIDIA drivers

and all of these failed. I got frustrated and decided to install Apex Legends. The game used Steam Overlay to show me a login screen and I got another crash. I switched Steam account and Apex started playing its intro video and I got another crash in the middle of the video. The sound kept playing until the video finished and silence. Then I tried a match and got another crash.
Desperately I installed Nobara Linux (Fedora 36 based, KDE edition) alongside Garuda. Nobara didn't have a single crash in both CS:GO and Apex Legends, with Mangohud enabled but Nobara has its own issues which I don't want to deal with :cry:
Here is a log file of Apex Legends crashing. At 22:31:36 I do Alt+Sysrq+S and Apex Legends has already crashed, then I do Alt+Sysrq+E to get the system back. I have examined the file beforehand and haven't found anything suspicious.

I just didn't try using an older kernel but Nobara doesn't either (it has 5.17.6 at the moment) and I don't know what to do next. Any ideas?

I had a similar issue, actually. No amount of reverting Garuda Linux updates would do anything after this issue first occurred, so I suspect it's not really an issue on our end.

What I did to fix it was run CS:GO/TF2 in windowed mode while also making sure KDE's default like start menu bar is visible at all times, just small. I don't use Latte Dock so idk what it's like there. I made the CS:GO window borderless though, but didn't do it via CS:GO's settings, I used KDE's method of doing that. After that, all crashes were completely gone. A week later I tried running it with the start menu set to auto disappear, but that just crashed my game again.

Hint: If you want to access a tty, you can still do so by doing Alt+SysRq+R and then alt+F1-6


That helped a lot. I had yet another crash in Apex Legends, I switched TTYs to a terminal and back to KDE, the game had thrown an error message link to picture and I could use rest of the desktop again.
EDIT: The reason of the error message is unrelated to crashes, Apex seems to throw that error if I switch TTYs even if the game is healthy.

I might have found a solution. I switched to Wayland and I didn't have a crash for ~2 hours.

Edit: I am on Plasma Wayland and haven't had any crashes for ~4 hours of gaming. I am concluding Wayland is the solution now.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.