Radeon rx 580 driver problams please help

Radeon rx 580 wrong drivers maybe.
so I installed drivers according to Wiki and tried different mesa versions
https://wiki.archlinux.org/title/AMDGPU

when I run RPCS3 I get this

  • RSX: Found Vulkan-compatible GPU: ‘AMD Radeon RX 480 Graphics (RADV POLARIS10)’ running on driver 24.0.3
    E RSX: Your GPU does not support alpha-to-one for multisampling. Graphics may be inaccurate when MSAA is enabled.
    E RSX: AMDGPU kernel driver on Linux and INTEL driver on some platforms cannot support passthrough DMA buffers.

alpha-to-one for multisampling and passthrough DMA buffers work fine in windows

lspci -k | grep -A 3 -E “(VGA|3D)”
07:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev c7)
Subsystem: Dell Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
Kernel driver in use: amdgpu
Kernel modules: amdgpu

some sites I was looking at saying Kernel modules should be Radeon
not sure how to change that.
any help would be greatly appreciated

System:
Kernel: 6.8.2-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1d4a54c1-18da-4489-9dca-1711fda4fd49 rw rootflags=subvol=@
quiet resume=UUID=021293bc-c39f-4ed9-9c47-bc29b9877de7 loglevel=3
GRUB_CMDLINE_LINUX_DEFAULT=quiet ibt=off
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: B450M DS3H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <superuser required>
uuid: <superuser required> UEFI-[Legacy]: American Megatrends v: F52
date: 01/05/2021
CPU:
Info: model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3806 high: 4267 min/max: 2200/4672 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3590 2: 3800
3: 3800 4: 3800 5: 3800 6: 3800 7: 4263 8: 3800 9: 3800 10: 3800 11: 3800
12: 3573 13: 3800 14: 3800 15: 3800 16: 3800 17: 3800 18: 3800 19: 4267
20: 3800 21: 3771 22: 3800 23: 3589 24: 3696 bogomips: 182051
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Dell driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 07:00.0
chip-ID: 1002:67df class-ID: 0300 temp: 67.0 C
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu d-rect: 3456x1944
display-ID: 0
Monitor-1: DP-3 pos: bottom-l res: 1536x864 size: N/A modes: N/A
Monitor-2: HDMI-A-1 pos: top-right res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.4-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 480 Graphics
(radeonsi polaris10 LLVM 17.0.6 DRM 3.57 6.8.2-zen2-1-zen)
device-ID: 1002:67df memory: 7.81 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: discrete-gpu name: AMD
Radeon RX 480 Graphics (RADV POLARIS10) driver: mesa radv
v: 24.0.4-arch1.1 device-ID: 1002:67df surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Dell driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 07:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.8.2-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager,systemd-timesyncd
Drives:
Local Storage: total: 1.61 TiB used: 127.11 GiB (7.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
model: SPCC M.2 PCIe SSD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: S1111j0L temp: 36.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Hitachi model: HDS721010CLA332
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3MA scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Silicon Power
model: SPCC Solid State Disk size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 61.3
scheme: MBR
Partition:
ID-1: / raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 127.11 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 127.11 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 127.11 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 127.11 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.12 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
Sensors:
System Temperatures: cpu: 59.0 C mobo: 34.0 C gpu: amdgpu temp: 67.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 584
Info:
Memory: total: 16 GiB available: 15.56 GiB used: 4.41 GiB (28.3%)
Processes: 451 Power: uptime: 48m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.21 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1610 libs: 489 tools: octopi,pamac,paru
Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish
v: 3.7.1 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-03-10
Last full system update: 2024-04-01
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

Please use the correct formatting on garuda-inxi = </>
I am not sure what the minimal specs of a graphics card are for the PS3 emulator - did it work previously?
You can also try to switch to X11 (lower left corner on the login screen), as I have read there are some Wayland issues.

My roommates vid card is the RX 580 and when I did his install using the previous ISO to the 10292023 release the drivers were auto installed without issue. As for the Wayland issue they have to do with nVidia.

same on x11 emulator still works fine just the card is not able to use the feature it is suppose to have

I really did not want to reinstall I did have Nvidia in PC before swap it out removed Nvidia stuff its not that the card is not working actually working well but alpha-to-one for multisampling and passthrough DMA buffers not working if passthrough not working could be a problem to use virtualization

1 Like

The actual drivers for the AMD graphics card are in the Kernel.
I would highly recommend checking in the Forum of the PS3 emulator, they might tell you what minimal configuration/drivers they need for the emulator to keep running properly.

1 Like

the emulator plays fine but the card is supposed to support passthrough and it does not. It works in Windows been doing lots of reading and was hoping to avoid reinstall but am going to install Garuda in
UEFI mode I guess passthrough works better that way lets hope

so I reinstalled as UFFI sadly same driver and the same problem

I ended up fixing it just kept replacing driver components last one I installed
lib32-vkd3d-proton-tkg-git it fixes the passthrough error and the game loads really fast
thanks for your help

Thank you for letting us know. Please mark your post as Solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.