Qtile: unable to start jgmenu on click

Jgmenu works, but I need to call it from dmenu or other start menu. It is probably not related to my hardware, as I changed my graphics card and cpu recently, but the issue persists. I tried reinstalling it and my graphics drivers, still nothing.
My inxi -Fxxxza output

yeah it's upstream issue. Qtile developers have made this change.

Solution: Do this changes in your qtile config file


I did it, and it still doesn't work

make sure you made correct changes and reboot system also remove import albattery


I am sure that I made correct changes, I downloaded the file and replaced contents of my config.py with this. I removed "import albattery" as well as another place where albattery was mentioned, a function which defines how it works, as it seems. I rebooted several times after every change, updated my system, and still nothing.

Also, another weird issue: even though I deleted "import albattery" it also persists, maybe, there is another config.py other then /etc/skel/.config/qtile/config.py

:man_facepalming:t2:you have edited wrong config file. You have to edit config file in your home directory ~/.config/qtile/config.py


I assumed that the path used on this page is the needed one. The more you learn :sweat_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.