Qtile Edition

Hi there, I really liked Garuda and i just downloaded and installed Garuda LInux Qtile edition. Everything is great but its a bit slow when starting up. When i power up my laptop garuda takes a minute to just show the systemd starting services and then even more time when it shows the bootloader. and also I cannot login as Qtile(Wayland) session. I can login to Qtile(Default) with a bit slow performance. Please help me to fix it.
SYSTEM SPECS:
Dell precision m4700
16GB RAM
M.2 SSD 256GB SanDisk
core i7-3840 @ 2.8Ghz processor
GPU : nvidia Quadro k2000m
GPU: intel 3rd Generation Grahics controller

Also when open up alacritty the neofetch or whatever system utility takes 5 Secs to load. Please help im using 1266M/15902M and 6.1% of CPU

You’re missing your garuda-inxi. Please read the template before just deleting it

2 Likes

where is that?

I think the template you deleted made it clear enough…but basically open your terminal and type garuda-inxi and post the output of that command as pre-formatted text using the toolbar above where you type your message

3 Likes

garuda inxi is installed and i just updated the system.

Reread what I just said then post the output

2 Likes
System:
  Kernel: 5.19.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=2be97131-b17c-4273-915d-65e53c6d6be2 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Qtile v: 0.21.0 wm: LG3D vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Precision M4700 v: 01
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 0DK7DT v: A00 serial: <superuser required> UEFI: Dell
    v: A19 date: 11/30/2018
Battery:
  ID-1: BAT0 charge: 12.4 Wh (23.3%) condition: 53.3/53.3 Wh (100.0%)
    volts: 11.4 min: 11.1 model: SMP DELL 4DMNG31 type: Li-ion
    serial: <filter> status: charging
CPU:
  Info: model: Intel Core i7-3840QM bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1658 high: 2800 min/max: 1200/2800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1951 2: 1200 3: 2800
    4: 1196 5: 1200 6: 1200 7: 2524 8: 1200 bogomips: 44654
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes,
    SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled
    via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166
    class-ID: 0300
  Device-2: NVIDIA GK107GLM [Quadro K2000M] vendor: Dell driver: nouveau
    v: kernel non-free: series: 470.xx+ status: legacy-active (EOL~2023/24)
    arch: Kepler code: GKxxx process: TSMC 28nm built: 2012-18 pcie: gen: 1
    speed: 2.5 GT/s lanes: 2 link-max: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: none empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0 chip-ID: 10de:0ffb
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: Picom v: git-c4107
    driver: X: loaded: modesetting,nouveau alternate: fbdev,intel,nv,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: LVDS-1 model: ChiMei InnoLux 0x15b1 built: 2012
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Dell driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 2 link-max: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b
    class-ID: 0403
  Sound Server-1: ALSA v: k5.19.2-zen1-2-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
    v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:422b
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 704.24 GiB used: 7.44 GiB (1.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: ST500LM012 HN-M500MBB
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0001
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SD7SFAT-256G-1122
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 3.0 Gb/s type: SSD serial: <filter> rev: 4A0 scheme: GPT
Partition:
  ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 7.44 GiB
    (3.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 7.44
    GiB (3.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 7.44
    GiB (3.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 7.44
    GiB (3.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 57.0 C mobo: 48.0 C sodimm: SODIMM C
    gpu: nouveau temp: 37.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 255 Uptime: 16m wakeups: 2 Memory: 15.53 GiB used: 1.73 GiB
  (11.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pacman: 1099 lib: 299 Shell: fish
  v: 3.5.1 default: Bash v: 5.1.16 running-in: alacritty inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-08-28
  Last full system update: 2022-08-28 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

This is way you cannot use Wayland and why alacritty takes some time (alacritty uses hardware render).

For this kind of older hardware your options on what you can do is pretty limited. Using a Garuda version with a DE like Xfce might be a better choice, and even then you are going to be limited on what you can do with it.

3 Likes

i have intel also

Yes, I have read your Inxi. older iGPU isn't going to be much better.

2 Likes

you are wrong. yes my system is old but thats not the problem. i have ran Qubes-os for a week on this system which is much more havier than garuda. also i have used other garuda editions like KDE.. and all went smooth without errors. This only occured in this qtile edition.

and that is why I am suggesting you to try a different DE....

3 Likes

i have used qtile before in other distros. and I like Qtile... so this is a problem in the config or whatever. Qtile is not the problem.

and i think i solved the problem by changing config... thank you for saying this about the hardware without knowing anything...

Might want to take a look at the Garuda Assistant's Settings tab.

1 Like

This kind of rude behavior will get you nowhere on these forums. I nor anybody else gets paid for troubleshooting here.

IF you would have stated that you had Qtile working in other distros, maybe i wouldn't have tried troubleshooting down that road.

2 Likes

thats what im telling you to first get some info and then try to solve the problems. im sorry if this felt bad to you.

If anything, people need to read the template first and maybe the forums rules.

3 Likes

can you tell me how to disable find-the-command feature in alacritty?

If you haven't found the answer via a forum search, please put a different thread with your question there.

2 Likes