Qt6 default qtquick project with qtcreator

Hello Garuda users.

I installed all qt6 devel packages and I receive error when create pure qt6 “Qt Quick Application” (not compat) with qtcreator template:

/usr/include/c++/13.2.1/cmath:47:15: fatal error: math.h: No such file or directory
   47 | #include_next <math.h>
      |               ^~~~~~~~
compilation terminated.

If it is connected somehow - the same error occurs on Garuda from January. But in next major release the error was resolved. Now it is reproducible again.
Using same project template with cmake and build from console compiles without problems. It looks like qtcreator problem.

Anyone other experience same troubles?
What other info can I provide ?

garuda-inxi, if useful:

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: kvm-clock,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1c9ee7f6-2d25-4899-a153-18c65f74cef8 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Virtualbox System: innotek GmbH product: VirtualBox v: 1.2
serial: <superuser required> Chassis: Oracle Corporation type: 1
serial: <superuser required>
Mobo: Oracle model: VirtualBox v: 1.2 serial: <superuser required>
BIOS: innotek GmbH v: VirtualBox date: 12/01/2006
Info: model: AMD Ryzen 5 3600X bits: 64 type: MCP arch: Zen 2 gen: 3
level: v2 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x6000626
Topology: cpus: 1x cores: 3 smt: <unsupported> cache: L1: 192 KiB
desc: d-3x32 KiB; i-3x32 KiB L2: 1.5 MiB desc: 3x512 KiB L3: 32 MiB
desc: 1x32 MiB
Speed (MHz): avg: 3800 min/max: N/A cores: 1: 3800 2: 3800 3: 3800
bogomips: 22799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Vulnerabilities: <filter>
Device-1: VMware SVGA II Adapter driver: vmwgfx v: ports:
active: Virtual-1 empty: Virtual-2, Virtual-3, Virtual-4, Virtual-5,
Virtual-6, Virtual-7, Virtual-8 bus-ID: 00:02.0 chip-ID: 15ad:0405
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: vmware unloaded: modesetting
alternate: fbdev,vesa dri: vmwgfx gpu: vmwgfx display-ID: :0 screens: 1
Screen-1: 0 s-res: 1229x904 s-dpi: 96 s-size: 325x239mm (12.80x9.41")
s-diag: 403mm (15.88")
Monitor-1: Virtual-1 mapped: Virtual1 res: 1229x904 hz: 60 size: N/A
modes: max: 1229x904 min: 640x480
API: EGL v: 1.5 platforms: device: 0 egl: 1.4 drv: vmwgfx device: 1
drv: swrast gbm: egl: 1.4 drv: vmwgfx surfaceless: egl: 1.4 drv: vmwgfx x11:
egl: 1.4 drv: vmwgfx inactive: wayland
API: OpenGL v: 4.5 compat-v: 2.1 vendor: vmware mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: SVGA3D; build: RELEASE; LLVM;
device-ID: 15ad:0405 memory: 1000 KiB unified: no
API: Vulkan Message: No Vulkan data available.
Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0
v: kernel bus-ID: 00:05.0 chip-ID: 8086:2415 class-ID: 0401
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: kernel port: d020
bus-ID: 00:03.0 chip-ID: 8086:100e class-ID: 0200
IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
driver: piix4_smbus v: N/A modules: i2c_piix4 port: N/A bus-ID: 00:07.0
chip-ID: 8086:7113 class-ID: 0680
Local Storage: total: 48 GiB used: 1.93 TiB (4116.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: VirtualBox model: VBOX HARDDISK
size: 48 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: N/A serial: <filter> fw-rev: 1.0 scheme: MBR
ID-1: / raw-size: 48 GiB size: 48 GiB (100.00%) used: 6.73 GiB (14.0%)
fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 48 GiB size: 48 GiB (100.00%) used: 6.73 GiB (14.0%)
fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 48 GiB size: 48 GiB (100.00%)
used: 6.73 GiB (14.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 48 GiB size: 48 GiB (100.00%)
used: 6.73 GiB (14.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 5.89 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 3 dev: /dev/zram0
Src: lm-sensors+/sys Message: No sensor data found using /sys/class/hwmon
or lm-sensors.
Processes: 175 Uptime: 1h 56m wakeups: 498 Memory: total: 6.12 GiB
available: 5.89 GiB used: 2.86 GiB (48.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1262 libs: 348 tools: octopi,paru Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-30
Last full system update: 2023-11-02 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut

If you’re going to run a bug-ridden development branch, at least learn to reboot, which is what the ‘swish’ indicates.

Many woes might be solved (or not) by doing that one simple thing. The thing is, neither you nor we will know until you do so. :slight_smile:


Thanks @Bro ! The bug stays the same after rebooting.

Cool (or not so), but at least that’s no longer an item to check off the list. Thank you. :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.