Qgnomeplatform and Adwaita-qt are no longer maintained

Are there other alternatives to switch to?

Kvantum seems to be the best supported alternative at this point. We switched the Gnome spin to using Kvantum a couple months ago when Qgnomeplatform and Adwaita-qt stopped being maintained. Currently we are shipping with this theme by default:

To use Kvantum you will need to set the QT_STYLE_OVERRIDE=kvantum environment variable somewhere. The way we are doing it on Gnome now is with a script in /etc/profile.d/environment.sh.


# If it's a Wayland session, set some environment variables.

if [ "$XDG_SESSION_TYPE" = "wayland" ]; then
	export QT_QPA_PLATFORM=wayland

# Set some other environment variables

export QT_STYLE_OVERRIDE=kvantum

The script checks if you are running a Wayland session and sets a couple environment variables if you are, but then also sets the QT_STYLE_OVERRIDE environment variable for either session.

Additionally you may wish to add QT_STYLE_OVERRIDE to a Defaults env_keep += line in /etc/sudoers so when you run apps as root they will use your Kvantum theme. You could do this with a drop-in file like so:

sudo micro /etc/sudoers.d/envkeep
Defaults env_keep += "QT_STYLE_OVERRIDE"

On the more recent Gnome ISOs all this stuff is already set up; you must be using an older installation (no garuda-inxi posted so we do not know) so you’ll have to set it up for yourself.

1 Like

yeah i have an old install .
Should i follow these instructions to setup the theme ?

  Kernel: 6.6.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b6b92ddd-1165-4684-927f-b9ae66d45eff rw rootflags=subvol=@ systemd.show_status=auto
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 mitigations=off
    sysrq_always_enabled=1 ibt=off
  Desktop: GNOME v: 45.2 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 45.0.1
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: X540LA v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X540LA v: 1.0 serial: <superuser required> UEFI: American Megatrends
    v: X540LA.303 date: 08/31/2018
  ID-1: BAT0 charge: 26.2 Wh (101.6%) condition: 25.8/33.2 Wh (77.8%) volts: 10.8 min: 10.8
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: not charging cycles: 717
  Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell gen: core 5 level: v3
    note: check built: 2015-18 process: Intel 14nm family: 6 model-id: 0x3D (61) stepping: 4
    microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1895 high: 1896 min/max: 500/1900 scaling: driver: intel_cpufreq
    governor: performance cores: 1: 1896 2: 1895 3: 1895 4: 1895 bogomips: 15961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel arch: Gen-8
    process: Intel 14nm built: 2014-15 ports: active: DP-1 off: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:1616 class-ID: 0300
  Device-2: IMC Networks USB2.0 VGA UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:4 chip-ID: 13d3:5a11 class-ID: 0e02
  Display: wayland server: X.org v: with: Xwayland v: 23.2.2 compositor: gnome-shell
    driver: X: loaded: intel unloaded: modesetting alternate: fbdev,vesa dri: i965 gpu: i915
    display-ID: 0
  Monitor-1: DP-1 model: Samsung SyncMaster serial: <filter> built: 2009 res: 1600x900 dpi: 92
    gamma: 1.2 size: 443x249mm (17.44x9.8") diag: 508mm (20") ratio: 16:9 modes: max: 1600x900
    min: 720x400
  Monitor-2: eDP-1 model: ChiMei InnoLux 0x15dc built: 2015 res: 1366x768 dpi: 101 gamma: 1.2
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris device: 1 drv: swrast
    surfaceless: drv: iris wayland: drv: iris x11: drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel HD Graphics 5500 (BDW GT2) device-ID: 8086:1616
    memory: 7.47 GiB unified: yes display-ID: :0.0
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: Intel HD Graphics 5500
    (BDW GT2) driver: mesa intel v: 23.2.1-arch1.2 device-ID: 8086:1616 surfaces: xcb,xlib,wayland
    device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
  API: ALSA v: k6.6.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 02:00.2 chip-ID: 10ec:8136
    class-ID: 0200
enp2s0f2 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On driver: rtl8723be
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 2.1 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-4:3 chip-ID: 0bda:b721 class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0 lmp-v: 6 status:
    discoverable: no pairing: no class-ID: c010c
  Local Storage: total: 704.24 GiB used: 620.88 GiB (88.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: TeamGroup model: T253256GB size: 238.47 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 227N
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD5000LPCX-80VHAT1 size: 465.76 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A02 scheme: GPT
  ID-1: / raw-size: 24.91 GiB size: 24.91 GiB (100.00%) used: 10.99 GiB (44.1%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
    dev: /dev/sda4 maj-min: 8:4
  ID-3: /home raw-size: 9.8 GiB size: 9.8 GiB (100.00%) used: 2.87 GiB (29.3%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 24.91 GiB size: 24.91 GiB (100.00%) used: 10.99 GiB (44.1%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 24.91 GiB size: 24.91 GiB (100.00%) used: 10.99 GiB (44.1%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.65 GiB used: 555.8 MiB (7.1%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  System Temperatures: cpu: 49.0 C pch: 41.5 C mobo: N/A
  Fan Speeds (rpm): cpu: 2000
  Processes: 288 Uptime: 1h 49m wakeups: 0 Memory: total: 8 GiB available: 7.65 GiB
  used: 3.32 GiB (43.4%) Init: systemd v: 255 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: 1159 pm: pacman pkgs: 1141 libs: 344 tools: pamac,paru pm: flatpak pkgs: 18
  Client: shell wrapper v: 5.2.21-release inxi: 3.3.31
Garuda (2.6.19-2):
  System install date:     2023-11-27
  Last full system update: 2023-12-08 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            

i applied the theme , but there are no icons in garuda-assistant now

Yes, you can install Kvantum with Pacman if you do not have it. If you want to use that theme linked above, you can follow the instructions in the repo or you can just copy and paste the configs out of ours: etc/skel/.config/Kvantum · master · Garuda Linux 🦅 / Themes and Settings / Settings / Garuda GNOME settings · GitLab

It’s not actually the theme that provides those icons. If you set it up right, those icons should not change. Let’s take a look:

eza --tree ~/.config/Kvantum
cat ~/.config/Kvantum/kvantum.kvconfig
░▒▓    ~ ▓▒░ eza --tree ~/.config/Kvantum                                                                        ░▒▓ ✔ ▓▒░
├── kvantum.kvconfig
├── KvLibadwaita
│  ├── KvLibadwaita.kvconfig
│  ├── KvLibadwaita.svg
│  ├── KvLibadwaitaDark.kvconfig
│  └── KvLibadwaitaDark.svg
└── WhiteSur
   ├── WhiteSur.kvconfig
   ├── WhiteSur.svg
   ├── WhiteSurDark.kvconfig
   └── WhiteSurDark.svg
░▒▓    ~ ▓▒░ cat ~/.config/Kvantum/kvantum.kvconfig                                                              ░▒▓ ✔ ▓▒░


Can you post a screenshot of what you are seeing in Garuda Assistant?

Hmm, that application uses embedded icons so this is kind of a weird issue.

Can you try this please:

  1. Open Kvantum Manager
  2. Click “Configure Active Theme”
  3. Open the “Miscellaneous” tab
  4. Uncheck the box that says “Respect current DE if possible”
  5. Save

Then relaunch Garuda Assistant and let me know if the icons show up.

they didn’t.

Let’s try setting the QT_QPA_PLATFORMTHEME environment variable. If you added the /etc/profile.d/environment.sh script you can just add it in there.

micro /etc/profile.d/environment.sh

Add in a line like this at the bottom:

export QT_QPA_PLATFORMTHEME="kvantum"

Then log out and log back in.

The 'swoosh" indicates a reboot is needed. After you reboot does the problem still exist?

i restarted , and no it’s not fixed yet.

it didn’t help.


Test if this is an issue with that theme by using a different theme from the Kvantum drop down, for example KvGnomeDark. Don’t forget to go back into the “Miscellaneous” tab and uncheck “Respect current DE if possible”.

that did it.

but i like the libadwaita theme

it was the iconless option in kvantum , i unchecked it and it’s fixed

1 Like

You chose to run GNOME, a platform that seemingly despises its users.