Protonvpn or openvpn or mulvadvpn ARE'NT WORKING on Garuda Linux

] × protonvpn-cli c
Connecting to Proton VPN on US-FREE#540003 with UDP.

Setting up Proton VPN.
Connecting to Proton VPN on US-FREE#540003 with UDP.
^CTraceback (most recent call last):
  File "/usr/bin/protonvpn-cli", line 33, in <module>
    sys.exit(load_entry_point('protonvpn-cli==3.13.0', 'console_scripts', 'protonvpn-cli')())
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 21, in main
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 65, in __init__
    res = getattr(self, args.command)()
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 71, in c
    return self.connect()
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 133, in connect
    return self.cli_wrapper.connect(args)
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 391, in connect
    return self._connect(args, only_free)
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 452, in _connect
    connect_response = self.protonvpn.connect()
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/", line 53, in connect
    connect_result = self._env.connection_backend.connect()
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/connection_backend/nm_client/", line 103, in connect
  File "/usr/lib/python3.11/site-packages/gi/overrides/", line 495, in run
    with register_sigint_fallback(self.quit):
  File "/usr/lib/python3.11/", line 144, in __exit__
  File "/usr/lib/python3.11/site-packages/gi/", line 237, in register_sigint_fallback
    signal.default_int_handler(signal.SIGINT, None)

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:


Refusing to post the output of the required “garuda-inxi” on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki’s, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum’s search engine and on the web. For in depth information on how to search for answers to Linux issues effectively read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.


Have you tried googling up python error?
I see that its sig int, with keyboard so you have ctrl c from script
Any other error?

Any more details can you provide? How is vpn not working for you?
Are you starting for example openvpn with any config file?

If so, do you know how to check if you are connected to vpn?
Not familliar with protonvpn have you tried openvpn?

Btw, proton works fine here

Setting up Proton VPN.
Connecting to Proton VPN on NL-FREE#258001 with UDP.

Successfully connected to Proton VPN.

After protonvpn-cli c


Wow that’s the solution, just adding c flag to command, o man he didnt even replied anything…
It seems that he didnt even used help or manual for command

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.