Proton not working Garuda Gaming

I use Garuda gaming version with the preinstalled things like steam/proton/protonGE
But no game is launching i tried different proton versions including the preinstalled GE version. I tried to reinstall steam and some games but its still not working. Help please.

Dont think it matters, but im using a AMD GPU not Nvidia
And the games are on a fuseblk file system
OS: Garuda KDE Dr460nized Gaming version

my inxi-Faz PrivateBin
Steam console log PrivateBin

Why haven't you read the template and therefore don't post your

inxi -Faz


I updated my post with the inxi -Faz and the steam log (i just remembered that i get console output when i run steam from the console XD

I think this Steam won't start, NO error message in terminal :: Steam for Linux General Discussions is best place to ask.

But steams starts.. Proton doesnt.. Steam works normally as far as i can see

Yeah, sorry, I saw same X error
X Error of failed request: BadAtom (invalid Atom parameter)

but reading X errors are not relevant :slight_smile:

Did you search about?

of course, im doing that since hours, but nothing that helps me.. Only problems since i installed Garuda i choose garuda gaming cause i thought then i dont have the problems with installing proton wine and such...

Some people have problems, other not.

I am not a gamer, so try this one, some are solved.

PLEASE JUST HELP ME! dont post random images of google searches...

I never use g00gle search :slight_smile:
That is the forum search function.

1 Like

I "solved" it. Since i got no solution i just reinstalled Garuda and now it works.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.