Problems with latte-docks?

Hey, first of all i'm not sure if it's latte-dock's problem, if i press the windows-key the menu to search apps etc opens, which is good, but i can't search in it, first of all the search bar isn't selected by default (which means every god damn time i need to use it i need to click on it with the mouse, tab won't work either) and on top of that everything stays gray-ish if i search something, as if it does not exist but it does, if i "search manually" aka. go to "all applications" and scroll down i find it... i'll attach pictures of it below

if that helps i'm using garuda kde dragonized

Are all themes set to Sweet? It looks different for me :eyes:

1 Like

Global: Sweetified Plasma
Application Style: kvantum-dark
Plasma Style: Sweet
Colors: Sweet
Window Decorations: Sweet-Dark-transparent
Icons: BeautyLine
Cursors: Adwaita

There was an update of latte-dock-git for me earlier today.
I think I saw the same issue, but unfortunately I had only to do a few things very quickly and didn't pay much attention.
Now, rechecking, everything is working fine.
Maybe just a reboot?

1 Like

no, just rebooted and still the same issue, i noticed if i do it a couple of times manually it will eventually work, but if this won't work on the first time per session i will have to downgrade latte-docks to the point of a couple months earlier, that's around the time my laptop should be - on which it works just like i would expect it

I rebooted and logout/in a few times and the search in the application launcher worked always from the first time. So I cannot reproduce anymore.
If you have latte-dock maybe you could try installing latte-dock-git, but I understand it looks like chasing ghosts...
I have no idea, sorry. Maybe a side effect of KDE Plasma 5.23? But if so, it would have been a common issue.

1 Like

i tried upgrading but already up to date:

[[email protected] ~]$ paru -Syu
#[sudo] password for ash:
:: Synchronizing package databases...
core is up to date
extra                                                                                            1568,9 KiB  3,11 MiB/s 00:00 [-----------------------------------------------------------------------------] 100%
community                                                                                           5,8 MiB  4,75 MiB/s 00:01 [-----------------------------------------------------------------------------] 100%
multilib is up to date
chaotic-aur                                                                                      1549,0 KiB  1102 KiB/s 00:01 [-----------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
there is nothing to do
:: Looking for AUR upgrades
:: Looking for devel upgrades
there is nothing to do

i'll try the git version in a moment

i just noticed i am already running on the git-version of latte-dock... then i'll try the "normal" version i guess?

installed the "normal" version, rebooted, some problems were fixed, others not... now the search bar works again, but i still have to click on it with the cursor... is there anything i could do to prevent having to do that every time?

sorry, does not work again, there's literally everything apart from the app i searched in there... and last time i checked steam was still steam and not discord...

also why is there stuff in german behind of the "reboot to uefi" point? i mean i haven't changed my language to german nor do i even have a uefi... plus it's a normal desktop pc with a bios pre-os...

back to the issue with nothing... also if i replace the dock via the terminal i get a warning:

[[email protected] ~]$ latte-dock --replace
Icon theme "gnome" not found.

I don't know for the language, but for the search results it could be a problem with baloo like here?

i recall deleting some index crap of baloo due to it taking literally hundreds of gigabyte... anyways i found r42 in my cache (newest is r50) and downgraded it, both of the issues are fixed for now

Please do not post like in a chat, edit last post until someone answer to your post.


Since the moderators here read everything, you do not need @ filo to draw attention to you, or it is considered intrusive.


i never @ someone, not my fault if someone thinks it's okay to just edit and remove messages and then puts stuff in between that without me knowing

You're right, I take back the @.
We will definitely become best friends.

anyways, do you recommend me putting patte-dock-git to the held back packages within /etc/pacman.conf? I would like to update sometimes without having to worry about stuff not working afterwards anymore
also, is there something to mute those warnings if i'm upgrading regarding "held back package"? i would like to be as red-free during upgrades as possible

Whether to ignore the upgrades for that package should be your decision.
You have to balance the annoyance of clicking into the search field with the risk of staying with a non-updated package.
As regards the warnings, I don't think they could be removed (but it would be necessary to read the pacman man and wiki in details), but I think they are very imporant, since ignoring upgrades should be a temporary exception and should not be forgotten.

1 Like

i don't know whether it's still like this or if it got changed, but i recall the first time i opened the pacman.conf and i found multiple entries on the ignorepkg line... something along the lines of garuda, pacman and a couple other things... that makes me wonder why that is like this... anyways i'd let it in the ignorepkg for now, because of if it's not in there it's gonna upgrade and then it's literally useless, a search bar which you can't search stuff with... thanks, i'd consider this done for now

Fine with the decision to ignore latte, of course, but I suggest rechecking this.
This is really weird, and could create problems...

1 Like

In such cases that users do not remember what they have seen or done, it is very important that they post actual information, as requested from the initial post template (they usually delete it without reading).
Are you one of those users? :slightly_smiling_face:

Is there any chance you run on Wayland?

1 Like

i do not record everything i do nor what i see, i thought it was odd so i put it in there too, what do you mean by wayland?

In this context, the request was to provide (as usual as text, formatted with ~~~ before and after the text block):

  • the outcome of inxi -Faz (according to the template shown when you create a topic)
  • the /etc/pacman.conf, or at least the HoldPkg, IgnorePkg, etc.

Wayland is a display server protocol. It is aimed to become the successor of theX Window System.
I don't think you are using it, but it could be confirmed with echo $XDG_SESSION_TYPE resulting in x11.


the echo does indeed exit with x11, but as i said, i changed it because of i thought why would that be the standard, therefore i don't have the "unchanged" file... anyways what do you need me to do with wayland?

both of those outputs:

[[email protected] ~]$ inxi -Faz && cat /etc/pacman.conf
System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c004acea-73f0-4fe1-9afc-7ab18ce1c3d0 rw
[email protected]
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop Mobo: MSI model: MSI X58 Pro-E (MS-7522) v: 3.0 serial: <filter> BIOS: American Megatrends v: 8.14B8
date: 11/09/2012
CPU:       Info: Quad Core model: Intel Core i7 930 bits: 64 type: MT MCP arch: Nehalem family: 6 model-id: 1A (26)
stepping: 5 microcode: 1D cache: L2: 8 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44911
Speed: 2031 MHz min/max: 1600/2800 MHz boost: enabled Core speeds (MHz): 1: 2031 2: 1684 3: 1857 4: 1935 5: 1912
6: 1660 7: 2583 8: 1618
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] driver: nvidia v: 470.74 alternate: nouveau,nvidia_drm bus-ID: 03:00.0
chip-ID: 10de:13c2 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 101 s-size: 966x272mm (38.0x10.7") s-diag: 1004mm (39.5")
Monitor-1: HDMI-0 res: 1920x1080 dpi: 94 size: 520x290mm (20.5x11.4") diag: 595mm (23.4")
Monitor-2: DP-5 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes
Audio:     Device-1: Intel 82801JI HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:3a3e class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 03:00.1 chip-ID: 10de:0fbb
class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 4-1:2
chip-ID: 0c76:161e class-ID: 0300
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:095a class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: e800 bus-ID: 06:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 6-1:2 chip-ID: 8087:0a2a
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Drives:    Local Storage: total: 2.27 TiB used: 793.74 GiB (34.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-00WN4A0 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Silicon Power model: SPCC Solid State Disk size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 9A0 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 041 scheme: MBR
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Toshiba model: MQ01ABD050 size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: MBR
ID-5: /dev/sdf maj-min: 8:80 type: USB vendor: Seagate model: ST500LX005-1CW162 size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: GPT
Partition: ID-1: / raw-size: 206.39 GiB size: 206.39 GiB (100.00%) used: 82.17 GiB (39.8%) fs: btrfs dev: /dev/sdc1
maj-min: 8:33
ID-2: /home raw-size: 206.39 GiB size: 206.39 GiB (100.00%) used: 82.17 GiB (39.8%) fs: btrfs dev: /dev/sdc1
maj-min: 8:33
ID-3: /var/log raw-size: 206.39 GiB size: 206.39 GiB (100.00%) used: 82.17 GiB (39.8%) fs: btrfs dev: /dev/sdc1
maj-min: 8:33
ID-4: /var/tmp raw-size: 206.39 GiB size: 206.39 GiB (100.00%) used: 82.17 GiB (39.8%) fs: btrfs dev: /dev/sdc1
maj-min: 8:33
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdc2 maj-min: 8:34
ID-2: swap-2 type: zram size: 15.62 GiB used: 4.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 53 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
Info:      Processes: 280 Uptime: 17m wakeups: 0 Memory: 15.62 GiB used: 5.04 GiB (32.3%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1592 pacman: 1587 lib: 381 flatpak: 5 Shell: Bash v: 5.1.8
running-in: konsole inxi: 3.3.07
# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc garuda-system
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = latte-dock-git
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
ParallelDownloads = 10

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

#SigLevel = Never
Include = /etc/pacman.d/chaotic-mirrorlist