Problem with installing Garuda Dragonized

Hello to all!

Today i try to install Garuda but have some problem with it ( see picture)

Trying both of Dragonized Edition but same result… :frowning:

Currently running win11 on Lenovo IdeapadGaming 3 with 32GB of RAM and +2TB SSD on top of 500GB main one
Processor: AMD Ryzen 5 5600H with Radeon Graphics 3.30 GHz

Thanks for Your time!
Kind Regards

Have you installed any linux os previously as ntfs label on top is kind of different in bios… :thinking:

Ok. You used rufus… :no_mouth: as stated in

Nop, not have been or in laptop (that I know about )
The Bios is some kind on “New one”. I have never seen it before …

and Yes, i used rufus because previously not showing me USB … to boot from it

I tried universal usb installer 1st time… If you are confident to try linux… and responsible than link:
Universal USB Installer - Boot from USB ▷ Bootable Maker will help you instead rufus… You should think twice. any watch some videos for its use…

And yes universal usb installer removed my Graphical-uefi forever… now i run always bios mode … Read article :- UEFI vs BIOS: What's the Difference?

OK, Thanks a lot TRAVEL

I will try it after couple of days (25-30) when i come back at home and let anyone know whats up with it.
At main time if anyone else have any suggestion about please leave a comment below.

First of all, disable secure boot and if possible fast boot in your BIOS. Then, if still not working, use Ventoy to create your live USB.


Hi @Mr.Pchih , Please disable secure boot , fast boot , and switch in to using AHCI , and try to use BalenaEtcher or Ventoy as USB burners .

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.