Problem with cgroup on docker

Hello guys.
So I have docker installed and running on my pc, but I have this error where it tells me "your kernel does not support cgroup rt runtime".

I need to use codeclimate, and every time I try to use it, this message shows up:
"docker: Error response from daemon: cgroups: cgroup mountpoint does not exist: unknown"

Please, I need help.

Garuda uses cgroups v2 by default

While docker has just added support for it recently
I think two days ago


Ok, so what do I need to do in order to use it?

This thread has it all I guess :wink:


Install docker-git from pacman, works with cgroups2

1 Like

Tried that, but got this error:

fish: /usr/share/fish/completions/ exists in filesystem

How do I fix this?


--overwrite "*"
1 Like

Where do I use that line?

sudo pacman --overwrite "*" -S docker-git

As paman option :slight_smile:

1 Like

Got this error:

sudo pacman -Syu docker-git --overwrite "*"

add :wink: , I mean at the end.

Hope it help.

Same error. I'll have to find another way because docker-git is not in the repository.
Thank you very much.

Deleted wrong post sorry