Problem with a Yandex-browser update

It seems this issue is resolved now, however just to clarify for future readers: installing debugedit is not necessary, and is in fact most likely not what most users will want.

The cause of this issue is a change was made upstream which has enabled debugging in /etc/makepkg.conf by default. I guess these will be some relevant threads if anyone is curious about this:

It seems the discussion is ongoing; I’m not sure if it will stay like this or not.


To get the behavior back to “normal”, the debugging option must be disabled. To do this, open /etc/makepkg.conf in an editor, for example Micro:

sudo micro /etc/makepkg.conf

Navigate down to the line that starts with OPTIONS= and put an exclamation mark in front of debug so it looks like this: “!debug” The whole line will be something like this:

OPTIONS=( ... blah blah blah blah ... !debug ...)
6 Likes