Problem updating system packages

Hi I have been expiriancing a lot of problems regarding some of the libraries and I cannot understand what is happening:

  • Problem 1 EMACS

  • So when I try to run emacs after installing it using pacman I get the error
    emacs: error while loading shared libraries: libicui18n.so.68: cannot open shared object file: No such file or directory
    IDK whats the problem with that

  • Problem 2 R

  • I am using R markdown as a replacement for LaTeX but when I run sudo R I get
    /usr/lib64/R/bin/exec/R: error while loading shared libraries: libicuuc.so.68: cannot open shared object file: No such file or directory

WHAT ARE THESE PROBLEMS AND WHAT CAN BE DONE

Also I do have many problems regarding mirrors for pacman as I have to see large ammounts of warning failed receiving ...
Can someone help

It looks like you have a partial update.
Re-create your mirrorlist with Garuda utility, or reflector and do a proper update.
Check about icu package

bash -c 'grep icu /var/log/pacman.log'
1 Like

Don't care, for your tone.

Unless you just started using the internet yesterday, you should know writing in all uppercase is rude and will get you little assistance.

2 Likes

Sorry I did not in any way want to be rude I just wanted the last statement to standout from the rest of the text but I am sorry if it did hurt somebody

2 Likes

I did use the arch mirrorlist to change the mirrors as for the other one this is my output

[2020-12-22T16:17:56+0530] [ALPM-SCRIPTLET] harfbuzz-icu 2.7.2-1 [2020-12-22T16:17:56+0530] [ALPM-SCRIPTLET] icu 67.1-1 [2020-12-22T16:17:56+0530] [ALPM-SCRIPTLET] lib32-icu 67.1-1 [2020-12-22T16:20:17+0530] [ALPM-SCRIPTLET] harfbuzz-icu 2.7.2-1 [2020-12-22T16:20:17+0530] [ALPM-SCRIPTLET] icu 67.1-1 [2020-12-22T16:20:17+0530] [ALPM-SCRIPTLET] lib32-icu 67.1-1 [2020-12-22T16:22:07+0530] [ALPM-SCRIPTLET] harfbuzz-icu 2.7.2-1 [2020-12-22T16:22:07+0530] [ALPM-SCRIPTLET] icu 67.1-1 [2020-12-22T16:22:07+0530] [ALPM-SCRIPTLET] lib32-icu 67.1-1 [2020-12-24T17:08:32+0530] [PACMAN] Running 'pacman -S icu'

I don't know what you mean with "arch mirrorlist".
Anyway, you have to update your system packages. It seems some packages were not upgraded.
Run this terminal command, until there are no error messages on installations.

sudo pacman -Syyu
4 Likes

You have a "partial upgrade" state, your package versions are not aligned.

Refresh your mirror list and make sure your packages are fully up-to-date.

4 Likes

hi -

for some reason, cannot update my system due to conflicts - it appears to be broken...

any thoughts?


❯ time yay -Syu                                                                99%   702 Mbps  ─╯
[sudo] password for XXXX           
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                          5.3 MiB  15.4 MiB/s 00:00 [----------------------------------] 100%
 multilib is up to date
 chaotic-aur                      370.6 KiB  7.24 MiB/s 00:00 [----------------------------------] 100%
:: Starting full system upgrade...
warning: libldac: local (2.0.2.3-3) is newer than extra (2.0.2.3-1)
resolving dependencies...
looking for conflicting packages...

Packages (48) autoconf-2.70-1  bbswitch-dkms-0.8-373  chaotic-keyring-20201229-1  darktable-2:3.4.0-2
              dxvk-mingw-git-1.7.3.r10.gea13a686-1  firefox-ublock-origin-1.32.4-1
              garuda-common-settings-r88.9fed725-1  garuda-gamer-git-r14.3d7e697-1
              garuda-wallpapers-r43.3b3cd86-1  garuda-wallpapers-extra-r4.ed392ef-1
              garuda-welcome-git-r86.882bf75-1  garuda-zsh-config-r23.41e56eb-1  git-2.30.0-1
              gmp-6.2.1-1  grub-btrfs-4.7.2-1  harfbuzz-2.7.4-1  harfbuzz-icu-2.7.4-1
              intel-gmmlib-20.4.1-1  intel-media-driver-20.4.5-1  iproute2-5.10.0-2  joplin-1.5.14-1
              lib32-harfbuzz-2.7.4-1  lib32-mpg123-1.26.4-1  libarchive-3.5.1-1  libavif-0.8.4-1
              libmicrohttpd-0.9.72-1  libmpc-1.2.1-1  libproxy-0.4.17-1  linux-zen-5.10.3.zen1-1
              linux-zen-headers-5.10.3.zen1-1  mhwd-db-garuda-git-r44.0fee18d-1  oath-toolkit-2.6.5-1
              openexr-2.5.3-6  openjpeg2-2.4.0-1  perl-libwww-6.51-1  python-pip-20.2.4-1
              python-reportlab-3.5.57-1  python-resolvelib-0.5.4-1  python-setuptools-1:51.1.1-1
              python-urllib3-1.26.1-1  rsync-3.2.3-3  sof-firmware-1.6.1-1  terminus-font-4.49.1-1
              tzdata-2020f-1  udftools-2.2-2  whitesur-gtk-theme-git-2020.12.27.r0.g1c26ca6-1
              xf86-video-intel-1:2.99.917+914+ga511f22c-1  youtube-dl-2020.12.31-1

Total Installed Size:   794.22 MiB
Net Upgrade Size:      -538.97 MiB

:: Proceed with installation? [Y/n] 
(48/48) checking keys in keyring                              [----------------------------------] 100%
(48/48) checking package integrity                            [----------------------------------] 100%
(48/48) loading package files                                 [----------------------------------] 100%
(48/48) checking for file conflicts                           [----------------------------------] 100%
error: failed to commit transaction (conflicting files)
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/cli-32.exe exists in filesystem
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/cli-64.exe exists in filesystem
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/cli.exe exists in filesystem
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/command/launcher manifest.xml exists in filesystem
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/gui-32.exe exists in filesystem
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/gui-64.exe exists in filesystem
python-setuptools: /usr/lib/python3.9/site-packages/setuptools/gui.exe exists in filesystem
python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/__pycache__/proxy.cpython-39.pyc exists in filesystem
python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/__pycache__/ssltransport.cpython-39.pyc exists in filesystem
python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/proxy.py exists in filesystem
python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/ssltransport.py exists in filesystem
Errors occurred, no packages were upgraded.
error installing repo packages
yay -Syu  1.39s user 0.57s system 15% cpu 12.875 total

use

sudo pacman -Syu --overwrite "*"

or search in

man yay

that does something like this.

2 Likes

WTF :rofl:
Did you install something via pip (namely setuptools & urllib3)?

4 Likes

OMG I read only the last "ssltransport.cpython-39.pyc exists in filesystem"

I am too old for this sh!t :smiley:

2 Likes