Problem second screen | libGL error: failed to load driver: nouveau | libGL error: glx: failed to create dri3 screen

Hello! I'm trying to use my Samsung TV as a second screen in Garuda KDE, but it's not working. I put the HDMI and the image is not transmitted to the TV (as if I didn't have the cable connected), but in Windows11 it works normally.

I tested it on another monitor and the same thing. If I force it with Super + P. The notebook screen goes black and the TV remains the same as described above. Then I need to remove the HDMI from the laptop to get the image back.

Does anyone know a solution!?

Hi there, welcome back.
Please provide your garuda-inxi as requested in the template.
In addition to that, if the issue is recent (e.g. after last update), it might be useful to provide the relevant part of your /var/log/pacman.log.

3 Likes

Hi, I don't know where to find this information "garuda-inxi", sorry, but I'm a bit of a newbie despite having the account here for a long time.

I can't say about the update issue, as I installed the system again last week.

Open a terminal, type garuda-inxi and hit enter
Copy the output text (ctrl+shift+c), and paste it in the forum formatted like this
~~~
text from garuda-inxi
~~~
The same info can be retrieved from the Garuda Assistant tool / systems specs.

1 Like

So?


╭─[email protected] in ~ 
╰─λ garuda-inxi
System:
Kernel: 5.18.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ebb7494c-a4c3-4425-81de-4f080463c397 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04
serial: <superuser required>
Mobo: RO model: Stonic_RNS v: V1.04 serial: <superuser required>
UEFI: Insyde v: 1.04 date: 02/04/2021
Battery:
ID-1: BAT1 charge: 56.4 Wh (100.0%) condition: 56.4/58.8 Wh (95.9%)
volts: 17.2 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full
CPU:
Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x60 (96) stepping: 1 microcode: 0x8600103
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1449 high: 1663 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1426 2: 1568
3: 1397 4: 1397 5: 1565 6: 1663 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397
12: 1395 bogomips: 71864
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia
v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu
v: kernel arch: GCN 5.1 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: none bus-ID: 06:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x1521 built: 2020
res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.10-zen1-1-zen)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: Acer Incorporated ALI driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.18.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.54 running: yes
Network:
Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 04:00.0
chip-ID: 10ec:2600 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 4 state: up address: <filter>
Drives:
Local Storage: total: 1.49 TiB used: 14.52 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 SDBPNPZ-512G-1014 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 21103900 temp: 31.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Gigabyte
model: GP-GSM2NE3128GNTD size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EDFM00.5 temp: 16.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-21Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A02 scheme: GPT
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.52 GiB (12.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:6
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.52 GiB (12.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.52 GiB (12.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 14.52 GiB (12.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.14 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 320 Uptime: 35m wakeups: 2 Memory: 7.14 GiB
used: 3.23 GiB (45.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1230 lib: 309
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-07-08
Last full system update: 2022-07-08
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

1 Like

Sorry, I'll leave it to someone else since I don't use multi-monitors (nor Nvidia).
Actually there is no external monitor listed in the garuda-inxi, so I really don't think there is any point in looking in KDE system settings -> display nor in nvidia-settings (which would have been my first check).
The only thing I can think of is if maybe you can try using a displayport?
Maybe another one :slight_smile: : you could set in the BIOS to use only your discrete card and see how it goes...

1 Like

Well... funny that I installed it with the Nvidia settings, but it didn't come right!? Maybe that's the problem, is there a way to install it now or do I need to reinstall the system?

You do have the correct proprietary nvidia drivers installed.
If I remember correctly, the system uses by default the integrated driver. You can use the discrete one with prime-run when launching applications and you should be able to use only the nvidia card with a BIOS setting.

1 Like

In a previous version that I used I had the option to choose which one I wanted to use, hybrid, integrated and Nvidea. But in this new update it doesn't appear and I didn't find it, so I thought I hadn't installed it. Got a black screen bug here, I'm going to reinstall the system...

Let's see if the problem of the two screens will solve, solving it or not I'll post it here!

I think this was optimus-manager, which is probably not included in the newer builds anymore, in favour of Nvidia PRIME. See also:

3 Likes

I couldn't use that link you sent. I tried to do it and it didn't work...

Sorry, what did you try and what didn't work?

1 Like

Work fine here,

Try also

2 Likes

I still believe that checking in the BIOS if you can use only the dGPU could be beneficial. Maybe your cable is connected directly to the dGPU and this could help the detection

Please, no pictures from terminal, post as text.

1 Like

ok, sorry...

╭─[email protected] in ~
╰─λ DRI_PRIME=1 glxgears
libGL error: glx: failed to create dri3 screen
libGL error: failed to load driver: nouveau
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
31592 frames in 5.0 seconds = 6318.363 FPS
33463 frames in 5.0 seconds = 6692.537 FPS
33170 frames in 5.0 seconds = 6633.946 FPS
32318 frames in 5.0 seconds = 6463.532 FPS
X connection to :0 broken (explicit kill or server shutdown).

╭─[email protected] in ~ took 22s
[🔴] × DRI_PRIME=1 glxinfo -B | grep "OpenGL vendor string"
libGL error: glx: failed to create dri3 screen
libGL error: failed to load driver: nouveau
OpenGL vendor string: AMD

╭─[email protected] in ~ took 63ms
╰─λ
1 Like

But how do I solve the problem? I still don't know how to do it. I'm a newbie and I don't know how to solve it...

Did you search for the errors?

All Images Maps Videos News Books

[

libGL error: failed to load driver: i915 - Arch Linux Forums
bbs.archlinux.org › Newbie Corner
](libGL error: failed to load driver: i915 / Newbie Corner / Arch Linux Forums)

Hello, with the new mesa 22 my retroarch shows this error in terminal: ... libGL error: failed to create dri screen libGL error: failed to ...

[SOLVED]NV18: nouveau_dri.so is opened instead of ...

libGL errors when running glxgears / Newbie Corner / Arch Linux ...

[Solved]Steam OpenGL GLX context is not using direct rendering ...

Some games crassh at startup. / Newbie Corner / Arch Linux Forums

Weitere Ergebnisse von bbs.archlinux.org

1 Like