Problem fan speed AMD

Hello Garuda users.

I have installed recently Garuda on my computer to test it out and I found a problem with the fan speed while gaming. I have a laptop with an AMD A10 and after install Garuda been using a while windows for long time and I never found a problem with, except with the driver graphics that can be annoying. When I'm playing in windows the fan start to move faster to keep the computer and processor a bit fresh, I'm using an external cooler to help with, while in Linux does not work, the fan speed while playing games just keep as normal, it does not increase the speed of the fan. Tried to install the Radeon profile gui to see All graphs temperatures, frequenciesand fan control but don't work with my AMD Model the interface show up in blank and cannot do nothing, obviously there's not a properly old AMD driver because its a property software, there's a solution for this or should move to windows to avoid this problem if don't works :frowning:.

Hi there, welcome to the community.

Please share output of garuda-inxi as text enclosed in ~~~
Like

~~~
garuda-inxi
~~~

3 Likes

There you go :slight_smile:

System:
Kernel: 5.17.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=60a1e894-b763-4e81-b830-2c29c4e847e4 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=f777119a-19c8-415f-853b-a53b74fefd64 loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 80EC v: Lenovo Z50-75
serial: <superuser required> Chassis: type: 10 v: Lenovo Z50-75
serial: <superuser required>
Mobo: LENOVO model: Lancer 5B3 v: 31900059WIN
serial: <superuser required> UEFI: LENOVO v: A4CN43WW (V 2.12)
date: 01/18/2018
Battery:
ID-1: BAT0 charge: 6.8 Wh (66.0%) condition: 10.3/28.5 Wh (36.1%)
volts: 13.1 min: 14.4 model: LENOVO PABAS0241231 type: Li-ion
serial: <filter> status: discharging
CPU:
Info: model: AMD A10-7300 Radeon R6 10 Compute Cores 4C+6G bits: 64
type: MT MCP arch: Steamroller family: 0x15 (21) model-id: 0x30 (48)
stepping: 1 microcode: 0x6003106
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 1098 min/max: 1100/1900 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 1098 2: 1098 3: 1098
4: 1098 bogomips: 15170
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Kaveri [Radeon R6 Graphics] vendor: Lenovo driver: radeon
v: kernel alternate: amdgpu ports: active: eDP-1 empty: HDMI-A-1,VGA-1
bus-ID: 00:01.0 chip-ID: 1002:130a class-ID: 0300
Device-2: AMD Jet PRO [Radeon R5 M230 / R7 M260DX Radeon 520 Mobile]
vendor: Lenovo driver: radeon v: kernel alternate: amdgpu pcie: gen: 1
speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
chip-ID: 1002:6665 class-ID: 0380
Device-3: Syntek Lenovo EasyCamera type: USB driver: uvcvideo
bus-ID: 2-1:2 chip-ID: 174f:14be class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0610 built: 2014
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD KAVERI (LLVM 13.0.1 DRM 2.50 5.17.7-zen1-1-zen)
v: 4.5 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: AMD Kaveri HDMI/DP Audio vendor: Lenovo Z50-75
driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:1308
class-ID: 0403
Device-2: AMD FCH Azalia vendor: Lenovo Z50-75 driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.17.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo Z50-75 driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Lenovo Z50-75 driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Realtek RTL8723B Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 4-2:2 chip-ID: 0bda:b728 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 6 state: up address: <filter>
Drives:
Local Storage: total: 1.02 TiB used: 35.48 GiB (3.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: A-Data model: SU650 size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 024F scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10JPCX-24UE4T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 99.79 GiB size: 99.79 GiB (100.00%)
used: 35.39 GiB (35.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 99.79 GiB size: 99.79 GiB (100.00%)
used: 35.39 GiB (35.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 99.79 GiB size: 99.79 GiB (100.00%)
used: 35.39 GiB (35.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 99.79 GiB size: 99.79 GiB (100.00%)
used: 35.39 GiB (35.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 11.7 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 10.63 GiB used: 943.3 MiB (8.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.2 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: radeon temp: 47.0 C device: radeon temp: 51.0 C
Info:
Processes: 342 Uptime: 12h 42m wakeups: 14 Memory: 10.64 GiB
used: 3.17 GiB (29.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1332 lib: 345 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.3-2):
System install date:     2022-05-14
Last full system update: 2022-05-15
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

I have edited your post to use the ~~~ as Naman mentioned in order to have proper formating.

2 Likes

On my system I have to run radeon-profile as root to get any output from it (i.e. type sudo radeon-profile in a terminal).

Windows is very heavy and would turn on fans even in normal usage.

Linux, on the other hand, is much more optimized and requires less fan.

You should run sensors command in your terminal, whenever you feel that your cpu / gpu is overheated, to check cpu and gpu temperature as well as fan speeds, and report if temperature is too high (90°C +) without fan turning on.

Also, a side note, you should turn on charging while playing games or while doing other heavy stuff. This will increase performance as well as reduce pressure on battery, hence improving battery life.

5 Likes

Definitely I agree with you with the function while gaming in windows, almost all time the speed of the fan increase even when I'm changing between apps, I have installed the libraries of lm sensor and pwmconfig to set up, by looking the information provided, have an automatic configuration with increase the fan speed when the temperature reaches the normal level, can I set up myself the fan speed in case don't help too much, i have a little difference when opened a game and the fan velocity increased a bit but not enough to blow off the hot air inside, I'm playing with a charger connected, as I know the graphics card work, it boost the performance when the charger is plugged in. I'm considering playing in windows to avoid this problem if keeps hot all time my laptop with Linux in games.

Specifically about controling the fan speed, there are other methods for controling your AMD GPU fan speed. Fan speed control - ArchWiki

Maybe some might be better suited for you and your use cases, but at least give it a read so you can make yourself an opinion. :slight_smile:

2 Likes

I would say, don't mess up with default values. They would turn on automatically when needed.

Also, you should check temperature with sensors command instead of relying on your instinct. If that's too high and fans don't kick in, then it is a matter of concern only.

3 Likes

I ran as sudo radeon-profile and the default configuration looks to have selected the performance settings also in the dropdown box shows up as low, I think it's the graphics mode when playing games, could probably work with the fan speed. Is it safety to change the value low to high option in performance mode.

There is the picture:
https://imgur.com/a/y6vKCHg

If that's a question, I played with radeon-profile quite a bit before I decided to use the systemd version of amdgpu fan speed control and you can change anything in there cuz you can always put back the original values. Remember what those values are and you can experiment by changing them afterwards.

As mentioned by Naman, have something implemented to monitor your GPU temperature, there are many ways for that too.

Tip: If you want to keep your user's theme when running radeon-profile, run it as such:

sudo -E radeon-profile

The -E option will keep user Environment variables as much as the option allows it too.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.