Power management configuration module could not be loaded

I just encountered this error and wanted to a put a record up in case it affects anyone else. The symptom for me was that I could not make changes to the Power Management panel in the KDE System Settings. There were quite a lot of ‘solutions’ in regards to powerd upgrades, timeout changes, etc. that didn’t seem to apply. What actually fixed it was:

  1. Open a terminal and go to etc/xdg/autostart/
  2. Look for powerdevil.desktop and open it.
  3. Edit powerdevil.desktop and look for X-systemd-skip
  4. This is probably set to true. Change it to false.
  5. Reboot

After the reboot power management was back although the user login seems to have been slowed down by a few seconds. I’m not exactly sure what started this but the only recent change I recall making is switching to Wayland.

These are the commands for anyone that might be a newbie and doesn’t want the slight bit of Linux usage practice above:

In your terminal:

cd /etc/xdg/autostart
kate powerdevil.desktop
   change X-systemd-skip=true to X-systemd-skip=false

All respect where it’s due: One of the random posts on the issue pointed me to this guy’s video which details the fix. https://www.youtube.com/watch?v=bFSd6QYerRM&t=80s

This is meant purely to help someone else that might run into it in the future. So Mods, if it needs to be moved/deleted/whatever, do what you must.


That’s basically the same process I use on a fresh Arch install. It doesn’t affect everyone, and it is fixed in Plasma 6, but it is a PIA nonetheless. Other than downgrading powerdevil & ddcutil (a bad practice), your fix was the only one I found that worked & survived a reboot.

Thanks for the post. :slight_smile:


Here, I had similar issue. : Powerdevil error & Plasma desktop freeze

Possibly related to oldskool monitors like my Dell Ultrasharp.

Anyhow, I don’t have any boot delays on my system.


Yeah, there just seems to be a wide range of causes for this issue which makes it a crapshoot whenever you try to find a solution.

Both of my monitors are fairly new and I didn’t have any issues with freezing or restarts. I just couldn’t get in to the power settings control panel.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.