Possible invisible updates / nvidia proprietary driver security exploit / update error

Possible issue with updates not showing up

NVIDIA driver not performing well with twitter tabs in Librewolf & general system stability proprietary

update error “Warning: Program ‘/tmp/tmp.oOioutmAaX’ crashed.”

:: Synchronizing package databases...
garuda is up to date
core is up to date
extra                                   8.3 MiB  14.5 MiB/s 00:01 [------------------------------------] 100%
multilib                              140.3 KiB   453 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur                             2.5 MiB  2.61 MiB/s 00:01 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵

:: Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
multilib downloading...
chaotic-aur downloading...
:: Starting full system upgrade...
there is nothing to do

System updated! 🐧

Press enter to exit^C

Warning: Program '/tmp/tmp.oOioutmAaX' crashed.
Kernel: 6.7.3-hardened1-3-hardened arch: x86_64 bits: 64 compiler: gcc
v: 13.2.1 clocksource: tsc avail: hpet,acpi_pm parameters: pti=on
page_alloc.shuffle=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
root=UUID=fb43e97c-1c95-43a6-9b71-d8cab7643f3d rw rootflags=subvol=@
quiet rd.luks.uuid=c8705c43-0d63-4823-a778-b7a9496c2a7a quiet
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ZenBook UX425UG_Q408UG v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: UX425UG v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: UX425UG.301
date: 12/05/2021
Battery:
ID-1: BATT charge: 9.0 Wh (20.0%) condition: 45.0/63.1 Wh (71.3%)
volts: 12.0 min: 12.0 model: ASUSTeK UX425 type: Li-ion serial: <filter>
status: charging cycles: 124
CPU:
Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
microcode: 0x8608103
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 1341 high: 2171 min/max: 400/4056 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 1803 2: 1397 3: 1399
4: 400 5: 400 6: 400 7: 1498 8: 1525 9: 2171 10: 1744 11: 1914 12: 1441
bogomips: 50328
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA TU117M [GeForce MX450] vendor: ASUSTeK driver: nvidia
v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2024-02; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 4 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 02:00.0
chip-ID: 10de:1f9c class-ID: 0302
Device-2: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel
arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:164c
class-ID: 0300 temp: 52.0 C
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: Najing CEC Panda 0x0035 built: 2021
res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: radeonsi inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
renoir LLVM 16.0.6 DRM 3.57 6.7.3-hardened1-3-hardened)
device-ID: 1002:164c memory: 500 MiB unified: no
API: Vulkan v: 1.3.276 layers: 8 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.3.5-arch1.1
device-ID: 1002:164c surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce MX450 driver: nvidia v: 545.29.06
device-ID: 10de:1f9c surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.5-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.7.3-hardened1-3-hardened status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Message: No PCI device data found.
Device-1: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1.1:3
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
IF: enp4s0f3u1u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Drives:
Local Storage: total: 1.03 TiB used: 19.37 GiB (1.8%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: AFGCF size: 119.08 GiB
block-size: physical: 512 B logical: 512 B type: Removable tech: SSD
serial: <filter> scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1B4QFXO7 temp: 51.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Transcend model: N/A size: 1.87 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s
lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: TS37
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 97.54 GiB size: 97.54 GiB (100.00%)
used: 19.34 GiB (19.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c8705c43-0d63-4823-a778-b7a9496c2a7a
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 26 MiB (27.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 97.54 GiB size: 97.54 GiB (100.00%)
used: 19.34 GiB (19.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c8705c43-0d63-4823-a778-b7a9496c2a7a
ID-4: /var/log raw-size: 97.54 GiB size: 97.54 GiB (100.00%)
used: 19.34 GiB (19.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c8705c43-0d63-4823-a778-b7a9496c2a7a
ID-5: /var/tmp raw-size: 97.54 GiB size: 97.54 GiB (100.00%)
used: 19.34 GiB (19.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c8705c43-0d63-4823-a778-b7a9496c2a7a
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.17 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 57.8 C mobo: N/A gpu: amdgpu temp: 52.0 C
Fan Speeds (rpm): N/A
Info:
Memory: total: 8 GiB note: est. available: 7.17 GiB used: 2.69 GiB (37.5%)
Processes: 354 Power: uptime: 11m states: freeze,mem suspend: s2idle
wakeups: 0 services: org_kde_powerdevil, power-profiles-daemon, upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1547 libs: 512 tools: octopi,paru Compilers:
gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26 running-in: konsole
inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-09-20
Last full system update: 2024-02-10
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hmm, that’s weird. Try commenting out the first mirror in the list in /etc/pacman.d/mirrorlist, and then run the update without refreshing the mirrors.

garuda-update --skip-mirrorlist
1 Like

There was an issue with the nvidia graphics drivers that fixed itself.

Was able to fix this issue by running an earlier snapshot and then updating.

Something to do with the nvidia driver update that was glitching. Much appreciated.