Plz Help failed to start remount root and file file system

Firstly 1, the system crashed, or more precisely, the screen flashed, and then it restarted, but this time the audio wasn’t working (don’t worry, my speakers are good). therefore I decided to restart.
2. I booted to many snapshots, and each one displayed the same error message: “failed to start remount root and file system.”
3. I tried to use the terminal, but nothing happened. Do I need to perform some magic to make it function? I mean, there’s a lot of long-winded gibberish on the Arch Wiki that I don’t understand.

Please take note that I am an absolute newbie who doesn’t know anything about Linux at all. I spend most of my time browsing the web and even i haven’t worked out how to play games on Linux the mean reason i choose garuda .

I believe it might have something to do with this issue from my search. 1. The other day, after updating, I received a prompt to “grub-install,” which I followed. Next, I received a command to update Grub 2. Some people claim that it’s UUIDs with the same value or output, which is, I believe, the bootloader for the posts with the dragon theme rather is grub than the login screen. I have no idea what the hell UUID is.

Clever choice, for both GNU/Linux and Garuda Linux.

First thing, you can always try to Google(or GPT) first. Here’s what I found in a manjaro forum.[1]
If you’ve partitioned your disk after installation, this might be the cause.

I myself is just a Garuda user, not from the official team. So, no warranty.

  • I wonder whether you can normally boot and enter the GUI.
  • What do you mean by use the terminal? Do you mean Ctrl+Alt+t to open konsole? (Maybe you can use Ctrl+Alt+F4 to a tty, a real terminal)
  • If you can open any term, plz contain the FULL output of garuda-inxi as instructed in the template which you are supposed to read before posting. (If you cannot open a term in GUI you can run something like garuda-inxi > ~/garuda-inxi.txt, then open dolphin(win+e) to open that file.)
  • What trouble are you trying to solve? I actually don’t quite get it. And I guess we are supposed to focus on one problem per thread?

  1. You’ll be more expertise in searching such info with more experience, and you’ll one day understand those gibberish. But you have to always try searching on your own first to gain exp, keep going. ↩︎

1 Like
  1. i can’t boot to anything
  2. the trouble i face is failed to start remount root and file system i can’t boot to my system
  3. when the msg [FAILED] failed to start remount root and file system the line under it sames like i have the power to write in it but nothing happens i can’t write any command so yeah my mean trouble is 2
  4. i can’t give the FULL output of garuda-inxi because i can’t use the terminal like i expland in 3 (sorry for the bad english i’m trying my best)
  5. i see the manjaro one but to be honest i don’t really know what to do or i don’t understand blkid or fstab i follow the steps but i still don’t gat it

That’s the way we can help, each thing you do not know, you can whoogle.

1 Like

thx i’m reading about what is fstab and blkid and of course uuid (i will do some troubleshooting i found an youtube vid i will follow it’s step then i will see what will happen )

I see, I see. I don’t know if it’s okay if you write in your own language, as we all can translate, and that might make things clearer
E.g, I don’t understand what you mean by saying

So, possibly I guess that’s caused by a disk partition after installation. Did you do that, like deleting any partition to make the root partition bigger? Did you?

If you don’t have any data in the partition, maybe a re-installation is the quickest solution?
If you want to preserve some data, you can boot into the livecd you used to install garuda and copy them to somewhere, a net drive or another usb. You can even run cmds like garuda-inxi or fdisk -l and cat /etc/fstab and post their output here. Or, you can even chroot into it if you later know how repair~ Seems worth a try.

1 Like

hello for some reason a now option showed in the bootmenu it’s called garuda (The name of my ssd) and i mange to boot to it but my old one is UFEI OS (The name of my ssd) can’t boot to it but the OS still is broking like the last one the audio won’t work and my desktop task menu ii rest for some reason i will try to boot to an older sanpshot

i can only boot to my broking OS can’t boot to an old snapshots and the old error msg [FAILED] failed to start remount root and file system the line under it sames like i
and a new one [FAILED] failed to unmount /tmp
and here is my garuda-inxi:

Kernel: 6.8.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dde5ba1f-815f-4286-8d4e-ac4c0e2b643b rw rootflags=subvol=@
quiet resume=UUID=346d7540-8b18-4d9e-8e67-9fb344482555 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop Mobo: ASRock model: B450M-HDV R4.0
serial: <superuser required> uuid: <superuser required>
UEFI: American Megatrends v: P2.30 date: 05/08/2019
Info: model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64
type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108102
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 1854 high: 3072 min/max: 1400/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1303 2: 1226
3: 1400 4: 3004 5: 2029 6: 1400 7: 1400 8: 3072 bogomips: 59086
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm
built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: HDMI-A-2 empty: DP-1,HDMI-A-1,HDMI-A-3 bus-ID: 09:00.0
chip-ID: 1002:15d8 class-ID: 0300 temp: 56.0 C
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-2 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Vega 11 Graphics
(radeonsi raven LLVM 17.0.6 DRM 3.57 6.8.1-zen1-1-zen)
device-ID: 1002:15d8 memory: 1.95 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: AMD
Radeon Vega 11 Graphics (RADV RAVEN) driver: mesa radv v: 24.0.3-arch1.1
device-ID: 1002:15d8 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.3-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.8.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: f000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter
driver: rtl8xxxu type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-8:4 chip-ID: 0bda:8179 class-ID: 0000 serial: <filter>
IF: wlp1s0f0u8 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:5
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 1.94 TiB used: 55.06 GiB (2.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte model: GP-AG70S1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EIFM31.3 temp: 26.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Lexar model: SSD size: 119.24 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
serial: <filter> fw-rev: 1A scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000VM002-1CT162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5900 serial: <filter> fw-rev: SC23 scheme: MBR
ID-1: / raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
used: 48.45 GiB (82.7%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 584 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 39.06 GiB size: 39.06 GiB (100.00%)
used: 6.61 GiB (16.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
used: 48.45 GiB (82.7%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
used: 48.45 GiB (82.7%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 13.57 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
ID-2: swap-2 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
System Temperatures: cpu: 56.2 C mobo: N/A gpu: amdgpu temp: 56.0 C
Fan Speeds (rpm): N/A
Memory: total: 16 GiB note: est. available: 13.57 GiB used: 2.79 GiB (20.6%)
Processes: 303 Power: uptime: 1m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 5.42 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1677 libs: 520 tools: octopi,paru,yay
Compilers: gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-02-27
Last full system update: 2024-03-20
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Put the output of commands in something like

cmd generated output go here


1 Like

sorry bro i was doing but when i finish some one arleady did it

Yes, sorry :slight_smile:

garuda maintenance telling me that an old sanpshots/backups found in infinity number of windows keep opening this my OS is dommed
old restore subvolumes
@_backup(the data and some random numbers)
what to do 1. ignore permanent 2. delete 3. cancel
and maintenance recommend hotfix it’s doesn’t do anything when i click it and help button show the goal of the hotfix which is this Linux 5.16's autodefrag BTRFS regression

hh the hotfix applied and i rebooted the OS the sound issue has been fixd but it shows five of the same sonud output

is it a save solution to go to .sanpshot and copy all the root files form an older sanpshot to my curren broken system and overwrite everything like windows?

You can use the Snapper tools to do that
I’ll never recommend you to do that manually

i know about the snapper but i fugared maybe it will fix the plm and i can finally be able to boot back to an old snapshot because this broken one i can boot to it for some reason an like the sanpshots

Use your own language plz. It must be easier for me to read the translation to understand.
I don’t understand what you want. You wanna be able to boot into both snapshots?

1 Like

thx bro trust me the translation will be worst then me but for now i’m gonna go get some sleep i have a university to go to goodnight thx for the hard work i hope i figured this out when i wake up good luck guys

  • Let’s both compromise. If you ever wanna anybody understand what you say, write in your own language, TRANSLATE it, and modify it if you like, finally put that text here.
  • Snapper tools is a perfect tool to switch between snapshots. Newer snapshots won’t be deleted if you use snapper tool in kde instead of in the grub
  • As for the sound thing. How are they look like, the configs of your sound? And the window pop out upon clicking this?

Maybe this is will help to solve something ??

1 Like