Plymouth problem

I installed the latest update yesterday, and after doing so I rebooted. I noticed a brief error message regarding Plymouth as the desktop cleared and the reboot started. I used snapper to restore the system to its previous config, and when I rebooted the error was gone.

I noticed this post a few minutes ago Distro Review - #13 by K1LL3RPUNCH

Here is what is in the update:

Packages (8) blueprint-compiler-0.6.0-1  btrfs-progs-6.0.2-1  iputils-20221126-1  linux-zen-6.0.10.zen2-1
             linux-zen-headers-6.0.10.zen2-1  plymouth-git-22.02.122.r117.gca15d30c-1
             python-setuptools-1:65.6.2-1  xterm-377-1

I searched for plymouth-git-22.02.122.r117.gca15d30c-1, and I found this page - please have a look at the comments:

https://aur.archlinux.org/packages/plymouth-git

```text
System:
  Kernel: 6.0.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e0aa6bf1-e32d-48b2-a659-01e4322f83f8
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=31f5f81c-4fb3-4a39-893a-3e7c25a0feb6 loglevel=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.35 wm: gnome-shell dm: GDM v: 43.0 Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513UA_M513UA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X513UA v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC.
    v: X513UA.312 date: 04/26/2022
Battery:
  ID-1: BAT0 charge: 33.1 Wh (79.8%) condition: 41.5/42.1 Wh (98.6%) volts: 11.8 min: 11.8
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: discharging cycles: 39
CPU:
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x68 (104) stepping: 1 microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1475 high: 2081 min/max: 1400/4056 boost: enabled scaling:
    driver: acpi-cpufreq governor: powersave cores: 1: 2081 2: 1436 3: 1497 4: 1406 5: 1398 6: 1502
    7: 1397 8: 1400 9: 1397 10: 1396 11: 1397 12: 1400 bogomips: 50309
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP: always-on, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2
    process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300 temp: 42.0 C
  Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-3:3
    chip-ID: 0408:30d4 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5 compositor: gnome-shell driver:
    X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: Samsung 0x4161 built: 2020 res: 1920x1080 hz: 60 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080
    min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
    snd_rpl_pci_acp6x, snd_sof_amd_renoir pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.0.9-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp1s0 state: down mac: <filter>
  Device-2: ZTE WCDMA MSM DEMO Mobile Boardband type: USB driver: cdc_ether,usb-storage
    bus-ID: 1-3:2 chip-ID: 19d2:1405 class-ID: 0806 serial: <filter>
  IF: enp3s0f3u3 state: up speed: 150 Mbps duplex: half mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-2:2 chip-ID: 8087:0032
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 10.73 GiB (2.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ512HALU-00000 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: FXV7101Q temp: 30.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 8.04 GiB (5.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 608 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 321.45 GiB size: 321.45 GiB (100.00%) used: 2.69 GiB (0.8%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 8.04 GiB (5.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 8.04 GiB (5.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.15 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
    maj-min: 259:3
Sensors:
  System Temperatures: cpu: 45.1 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 368 Uptime: 12h 42m wakeups: 2 Memory: 7.15 GiB used: 3.56 GiB (49.8%) Init: systemd
  v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1193
  libs: 330 tools: pamac,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-12
  Last full system update: 2022-11-27
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            
```
1 Like

What is the error message?

Was the system unable to boot?

2 Likes

I don't know - I saw it for about 3 seconds, all I remember seeing is 'warning' and 'Plymouth'.

Here is the comment from AUR (en) - plymouth-git, I've got no idea if it will be of help:

brody commented on 2022-11-27 10:58 (UTC) (edited on 2022-11-27 11:00 (UTC) by brody)

The package is not buildable in a clean chroot environment (22.02.122.r117.gca15d30c) Meson is missing the runtime dependencies of libevdev and libxkbcommon.

Run-time dependency libevdev found: NO (tried pkgconfig)

plymouth/meson.build:46:0: ERROR: Dependency "libevdev" not found, tried pkgconfig

Run-time dependency xkbcommon found: NO (tried pkgconfig)

plymouth/meson.build:47:0: ERROR: Dependency "xkbcommon" not found, tried pkgconfig

The error message in the AUR comment is not relevant for you: that user is not able to build from source, it's not an error at booting time.
If your system was bootable, update again and reboot.
It could even be that it was a spot error: sometimes I get an error like Terminate Plymouth boot screen, which is only a service failing (probably plymouth-deactivate.service) and it never appears again at the next boot.
Of course, if the error appears again for you, copy and paste it here.

1 Like

There is an issue since last update on every boot with plymouth-git. Not with plymouth. It fails to start and fails to deactivate its service. Does that on my 7 installations, including VMs.

Installing plymouth instead of plymouth-git fixes it.

7 Likes

Unfortunately I can't do this as the message appears for a couple of seconds after the desktop has closed.

Here's a screenshot of Pamac.

Will it be OK for me to uninstall plymouth-git and install plymouth?

It was for me. Unless you use some other git packages that REQUIRE plymouth-git.

You will see it in the installation window and if that happens, do NOT install/remove anything, post the output so we can see what other packages would be dependent on your plymouth-git.

I'm thinking, maybe you could open KONSOLE and issue the following

sudo pacman -Qi plymouth-git

This would show some dependencies. There is certainly a better command for that but I usually find my way around with this one. It will not break anything if you issue the above command.

Then plz post the output of course.

Here's the info:

Name            : plymouth-git
Version         : 22.02.122.r113.g1812e55a-1
Description     : A graphical boot splash screen with kernel mode-setting support (Development version)
Architecture    : x86_64
URL             : https://www.freedesktop.org/wiki/Software/Plymouth/
Licenses        : GPL
Groups          : None
Provides        : plymouth
Depends On      : libdrm  systemd  pango  cantarell-fonts  ttf-dejavu
Optional Deps   : xf86-video-fbdev: Support special graphic cards on early startup
Required By     : None
Optional For    : garuda-boot-options
Conflicts With  : plymouth
Replaces        : None
Installed Size  : 1939.14 KiB
Packager        : Nico Jensch <[email protected]>
Build Date      : Mon 21 Nov 2022 01:51:27 GMT
Install Date    : Wed 23 Nov 2022 17:07:29 GMT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature 

Sounds like me. Not too surprised though.

First of all, I would take a SNAPSHOT of your installation, I believe you use Snapper?

Second, I would do a

garuda-update

if you haven't today already.

Third, I would do the plymouth switch from the Konsole and not Pamac GUI.

sudo pacman -S plymouth

It should tell you it conflicts with plymouth-git and asks to remove plymouth-git.
Up to that point, leave it there and plz post all you see on the terminal.

3 Likes

Actually hold on, I am unsure of something. I did the switch on only 1 installation, maybe it won't work well on some of my other installs and would break the boot. I would prefer to test it tonight before you do anything.

Unless someone else is 100% sure of the switch.

OK - thanks for the heads up I was within seconds of stating the update.

I am a bit curious as to why the development version of plymouth-git is being used - won't this be more prone to problems?

Well I asked myself the same question when I started hitting the issue Saturday. I'm not sure it's still the git version provided by default in the current ISO. But in the past, there were some git packages provided by default, this changed over time to make the ISOs more stable. But I don't know what happened with plymouth-git on this.

I have done the switch on Xfce and booted many times without warnings or errors.

5 Likes

From AUR (en) - plymouth-git

eternalfloof commented on 2022-11-28 15:00 (UTC)

The latest upstream plymouth-git segfaults when running on my machine, so I would avoid upgrading at this point in time:

                Stack trace of thread 868:
                #0  0x00007efe86b4fcf4 ply_terminal_get_name (libply-splash-core.so.5 + 0x18cf4)
                #1  0x00007efe86b498d1 n/a (libply-splash-core.so.5 + 0x128d1)
                #2  0x00007efe86b4c130 ply_device_manager_watch_devices (libply-splash-core.so.5 + 0x15130)
                #3  0x000055d749e44aa5 n/a (plymouthd + 0x4aa5)
                #4  0x00007efe86973290 n/a (libc.so.6 + 0x23290)
                #5  0x00007efe8697334a __libc_start_main (libc.so.6 + 0x2334a)
                #6  0x000055d749e466a5 n/a (plymouthd + 0x66a5)
                ELF object binary architecture: AMD x86-64

Note that this does NOT appear to be the fault of the latest PKGBUILD revision. I can repro the bug on the previous November 14 PKGBUILD as well. Instead, the issue appears to be due to the latest commits checked into plymouth. Git bisect points to a few possible commits (some intermediate commits weren't bootable)

only skipped commits left to test
possible first bad commit: [8b1669acb200c487f9205ed93ffe3da744946d97] device-manager: Support kernels with CONFIG_VT=n
possible first bad commit: [2165fe4f3b50cd9b452023e857e7bf277ca82001] Merge branch 'dev_input' into 'main'
possible first bad commit: [dacfb36b5714cd34791ab85d72629886075ff492] Add input device support

It's not clear to me if this is a packaging bug or an upstream bug. I tried creating an account on gitlab.freedesktop.org to report but their email validation appears to be down :frowning:

1 Like

Did you read the above post at all?
Check out my axe in my avatar. :wink:

1 Like

I apologize I should have paid more attention.

1 Like

I'm sorry, but I'm at a loss because I rarely use the terminal - garuda-update sums up my knowledge of it.

Is the above the solution to the problem, and if so am I presented with a 'remove plymouth-git y/n' prompt, and if this is the case do I simply choose 'y', or is there more to it?

I am not using Gnome but it worked on Xfce, post number 7 shows plymouth and plymouth-git. Delete the one and add the other.

Follow this:

ā•°ā”€Ī» paru -S plymouth
resolving dependencies...
looking for conflicting packages...
:: plymouth and plymouth-git are in conflict. Remove plymouth-git? [y/N] y

Package (2) Old Version New Version Net Change

plymouth-git 22.02.122.r117.gca15d30c-1 -2.03 MiB
chaotic-aur/plymouth 22.02.122-4.1 1.89 MiB

Total Installed Size: 1.89 MiB
Net Upgrade Size: -0.15 MiB

:: Proceed with installation? [Y/n]

If you see only those 2 packages above, then hit ENTER to proceed.

I tested it, works perfect, no issues.
You will need to go back to Garuda Boot Options and set your preferred splash screen if it's not SPINNER, cuz it will reset to SPINNER.

EDIT: You can replace paru with pacman, in case you don't have paru on your system.

8 Likes