Please share your experience on daily driving garuda linux on baremetal. Is it worth the migration?

Hello Garuda users,

I am a new linux user and have been using windows for my life. I have mainly been using linux on virtualbox and fell in love with it (I am a CSE student) and finally found garuda ran it for about a year in virtualbox and have been deliberating on running it baremetal and getting rid of windows.

I know of all the kinks a rolling release can throw at you, faced them myself by losing my audio controls once and having my terminal acting up on me another or the time I had duplicate entries on grub to boot on same OS after the snapper snapshot restore (os-prober reading some partition never created).

What I wanna know is were those who switched to garuda or arch linux in general satisfied with it?


My use case: of computer is writing code (I am a CSE student, 3rd year) and binge watching anime, reading manga, light novels and also some P*ahem **ahem * research stuff. Also my laptop never shuts down it's always on sleep or hibernate. Plus, I am planning to game a little bit in the future.

Would Garuda KDE Dr460nized be a good distro for my use case?

I have a intel i7 10th gen processor, 16GB RAM, nvidia GeForce MX330 graphics card laptop.

Would Garuda KDE Dr460nized run without hitch on this config or should I expect some bugs, laggyness, screen tearing or something, anything actually?


BTW, here is my garuda-inxi

System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d0b273b9-bad0-4070-a06d-ba2f92804236 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Virtualbox System: innotek GmbH product: VirtualBox v: 1.2
    serial: N/A Chassis: Oracle Corporation type: 1 serial: N/A
  Mobo: Oracle model: VirtualBox v: 1.2 serial: N/A BIOS: innotek GmbH
    v: VirtualBox date: 12/01/2006
Battery:
  ID-1: BAT0 charge: 32.0 Wh (64.0%) condition: 50.0/50.0 Wh (100.0%)
    volts: 10.0 min: 10.0 model: innotek 1 type: Unknown serial: N/A
    status: discharging
CPU:
  Info: model: Intel Core i7-1065G7 bits: 64 type: MCP arch: Ice Lake
    gen: core 10 level: v2 built: 2019-21 process: Intel 10nm family: 6
    model-id: 0x7E (126) stepping: 5 microcode: N/A
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 320 KiB
    desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 32 MiB
    desc: 4x8 MiB
  Speed (MHz): avg: 1498 min/max: N/A cores: 1: 1498 2: 1498 3: 1498
    4: 1498 bogomips: 11980
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT Host state
    unknown
  Type: retbleed status: Vulnerable
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Unknown: Dependent on hypervisor status
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.20.0.0 ports:
    active: Virtual-1 empty: Virtual-2, Virtual-3, Virtual-4, Virtual-5,
    Virtual-6, Virtual-7, Virtual-8 bus-ID: 00:02.0 chip-ID: 15ad:0405
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: vmware unloaded: modesetting
    alternate: fbdev,vesa gpu: vmwgfx display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: Virtual-1 mapped: Virtual1 res: 1920x1080 hz: 60 size: N/A
    modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: llvmpipe (LLVM 14.0.6 256 bits) v: 4.5 Mesa 22.2.1
    direct render: Yes
Audio:
  Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0
    v: kernel bus-ID: 00:05.0 chip-ID: 8086:2415 class-ID: 0401
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: kernel port: d020
    bus-ID: 00:03.0 chip-ID: 8086:100e class-ID: 0200
  IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
    driver: piix4_smbus v: N/A modules: i2c_piix4 port: N/A bus-ID: 00:07.0
    chip-ID: 8086:7113 class-ID: 0680
Drives:
  Local Storage: total: 30 GiB used: 212.86 GiB (709.5%)
  ID-1: /dev/sda maj-min: 8:0 vendor: VirtualBox model: VBOX HARDDISK
    size: 30 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: 1.0 scheme: MBR
  SMART: no SMART Message: A mandatory SMART command failed. Various
    possible causes.
Partition:
  ID-1: / raw-size: 30 GiB size: 30 GiB (100.00%) used: 15.11 GiB (50.4%)
    fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 30 GiB size: 30 GiB (100.00%) used: 15.11 GiB
    (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 30 GiB size: 30 GiB (100.00%) used: 15.11 GiB
    (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 30 GiB size: 30 GiB (100.00%) used: 15.11 GiB
    (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 6.61 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  Src: lm-sensors+/sys Message: No sensor data found using /sys/class/hwmon
    or lm-sensors.
Info:
  Processes: 201 Uptime: 1m wakeups: 125 Memory: 6.61 GiB used: 1.42 GiB
  (21.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1188 libs: 316
  tools: octopi,pamac,paru Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.22
e[1;34mGaruda (2.6.8-1):e[0m
e[1;34m  System install date:e[0m     2022-05-20
e[1;34m  Last full system update:e[0m 2022-10-17
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m No/Undetected
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m

Running on baremetal is completely difference experience.
If you want to run it on bare metal, then you should just try it out.

2 Likes

I see then could you tell me if garuda/arch linux supports trackpad gestures out of the box or is there some workaround for it? If yes how good is this support.

I can't, I use mouse.

Wow, you had it on a VM for about a year? I'm sure you will love it even better on baremetal. Most people can't even run it well on a VM (or at all, because it is made for baremetal in mind).

I'll have to echo that you should try it out for yourself, but I'm pretty sure it would be fine for your use case. For the games, you can check protondb.com to see what windows games you can run (that would normally run given the hardware specs). For online games with anti-cheat, check out https://areweanticheatyet.com/ too. I do a ton of gaming on my Garuda machines. two towers with Garuda Dragonized Gaming Edition and one mini PC that I mess with the Wayfire version on.

5 Likes

Yes it's true it barely works with more than one app in background while in VM. Since I mostly use VM for coding so most of the stuff I do are inside terminal in VM so I barely get by. Could you tell me if you are facing any issues with garuda dailydriving except the ones rolling distros throw at you?

Nothing more than what would be the usual I think. I've been using it for over a year, and for big issues I've had one audio issue on one of my machines that I had to fix (ending up comparing the packages to the latest ISO package list to fix it). Other than that, just the somewhat recent Grub issue that effected a lot of arch based distros, that the team dealt with pretty well considering how nasty it was.

Garuda's tools, Snapper snapshots, and having an install media handy will help you in lot of cases. Our update command, garuda-update paired with the addition of the Chaotic-AUR, makes updates far less painful.

I can only really speak for myself, but I like Garuda more that the static distros I've tried over the years since the early 2000s. Most recently I've tried PopOS before coming here. Static distros don't really do it for me and my use case after I've seen what Garuda can do. I mostly game on it, and it keeping current and the ease of getting new versions of GE version of Proton really helps out. Not to mention security updates are usually super quick too.

2 Likes

Can you describe how you did this? Bcoz I ended up going back a snapshot with VM.

Sure. I actually found a handy command on these forums some time ago.

curl https://iso.builds.garudalinux.org/iso/garuda/dr460nized/xxxxxx/garuda-dr460nized-linux-zen-xxxxxx.pkgs.txt | grep -Eo '^[^ ]+' | paru -Syu --needed -

replace txt with the package list for your flavor of garuda from the downloads page. This command will grab new packages from the latest ISO to "upgrade". Conflicts are very likely to happen; uninstall ones that conflict to resolve and try command again. (and yes, you need that "-" at the end too)

1 Like

Well, we're all Garuda users here so we are all happy!

Your PC should be more than enough. And Garuda works better on hardware than virtual machine.

It will probably Just Work, but in case you have problems with the nvidia card or the wireless search around here and the Arch wiki, some models need a little persuasion.

As for replacing Windows, it's surely up to task and better, both for day-to-day use and especially to learn coding. It's Linux and it's all about coding.

Gestures, I bet there's some KDE plugin for that, if it doesn't do it out of the box (I don't know, I use Sway not KDE).

3 Likes

Sure.

After doing a lot of distro-hopping for quite some time, involving a lot of different distros I finally settled down on Garuda as it does everything I want from a distro. Guess that's no surprise :stuck_out_tongue: jokes aside,

This insanity prepares well for actual desktop usage lol. I'm doing it the other way around, Windows in a VM for the shitty Office stuff I absolutely require for my school <.< If you are interested in using Linux and learning how to work with it, I guess there shouldn't be anything holding you back.

8 Likes

MSI GE72VR 6RF Apache Pro Laptop.

I've been running Dragonized Gaming on it for months now (Arch before that), as the only OS.

I love it! Looks amazing out of the box, and has so many useful goodies. The only downsides, for me, are the lack of incentive to try any other distro, because nothing else comes close, and there's hardly anything left to tweak and tinker with lol

3 Likes

no problems to be mentioned, I have Garuda on the notebook used in my work as
IT customer support. All works perfectly.

1 Like

Touchpad gestures work fine if you choose Wayland instead of Xorg (the default) but then you hit this bug:
https://bugs.kde.org/show_bug.cgi?id=459755

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.