Play audio on both front and back port issue

Hi everyone I could use some help, I have an audio device plugged into my front and back port and i like them to be linked together and play the same audio, usually i go into alsamixer on ubuntu and mint, and disable the auto mute and the issue is solved but when i do that on garuda all it does is allow me to switch between front and back port but it doesn't play audio on both at the same time

If you select the "Pro Audio" profile then PipeWire will output to all jacks.

For example, using pavucontrol:

2 Likes

doesnt seem to work it just forces the audio to the back port

Well switch to pulseaudio and use paprefs it has option to simultaneously play from all devices

sudo Pacman -S pulseaudio-support pulseaudio-bluetooth paprefs

Then Open paprefs

2 Likes

There will be a way of doing it with PipeWire, e.g. PipeWire/Examples - ArchWiki shows how to split jacks into separate output sinks.

1 Like

well i tried that and went to simultaneous output and enabled it, and that still didnt work, i did see a virtual output in pavucontrol but selecting that didnt work this is the second garuda installation that does it so id assume this issue is built into garuda somehow.

and i have no clue what im supposed to use from that, im not a coder, im a bit of a newb

Don't make it a bigger deal than it warrants. It's not magic. All you are doing is altering/creating a text file. The Arch Wiki link is just a guide with suggestions. Play around with them. See what you can achieve. You can always revert changes.

2 Likes

Read more here:

https://gitlab.freedesktop.org/pipewire/pipewire/-/wikis/Virtual-Devices#create-a-combined-sinksource

This isn't "easy" yet, but that's what you get for having an operating system that exposes everything to the user.

This is a good opportunity to learn.

1 Like