Plasma no longer starts after the update, help please

Good morning everyone, I hope someone can help me.
I can no longer update the system because plasma no longer starts after the update.
When I update the system (using garuda-update) I get no errors but a few seconds after finishing plasma becomes unresponsive.
So I restart the system, the SDDM screen appears, I enter the username and password, a black screen appears, a few seconds later the mouse cursor appears in the center of the screen… it stays like this for about 5 minutes and finally the screen below appears , saying that plasma closed unexpectedly.
The details of the error are shown in the screenshots but it’s hard for me to decipher… probably something to do with the kde cache?

I don’t know what to do, I can just restore the pre-update snapshot and everything works again.
I googled the problem and tried (without success):

  1. delete ~/.Xauthority as mentioned here SDDM - ArchWiki
  2. delete ksycoca5_it*.lock file in ./cache

Screenshots of Plasma error

garuda-update of the problematic update
(does it have anything to do with garuda-video-linux-config-2:1.1.5-2?)

:: Starting full system upgrade...
:: Replace appstream-qt with extra/appstream-qt5? [Y/n] y
warning: kde-servicemenus-pdf-encrypt-decrypt: local (1-1.4) is newer than chaotic-aur (1-1)
:: Replace libkdcraw with extra/libkdcraw5? [Y/n] y
:: Replace mhwd-db-garuda-git with garuda/mhwd-db-garuda? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (202) alsa-card-profiles-1:0.3.85-1  appstream-1.0.0-4  appstream-qt-0.16.3-1 [removal]
appstream-qt5-1.0.0-4  attica5-5.112.0-1  baloo5-5.112.0-1  bind-9.18.20-1
bluez-qt5-5.112.0-1  box2d-2.4.1-2  brave-bin-1:1.60.118-1  breeze-icons-5.112.0-1
btrfs-progs-6.6.2-1  c-ares-1.22.0-1  cmake-3.27.8-1  containerd-1.7.9-1  discover-5.27.9-3
docker-compose-2.23.1-1  dolphin-plugins-23.08.3-2  eza-0.16.0-1  ffmpeg-2:6.1-1
frameworkintegration5-5.112.0-2  fwupd-1.9.9-1  gamescope-git-3.13.7.r0.gf1646ee-1
garuda-common-settings-2.6.19-2  garuda-icons-r40.a0891d2-1  garuda-libs-1.4.5-1
garuda-video-linux-config-2:1.1.5-2  garuda-welcome-1.2.10-1  gimp-plugin-gmic-3.3.2-1
gmic-3.3.2-1  gnutls-3.8.2-1  goverlay-git-0.9.1.r60.gd8e8e9e-1
grub-theme-garuda-dr460nized-r4.61172c5-1  gst-libav-1.22.7-1  gst-plugin-pipewire-1:0.3.85-1
gst-plugins-bad-1.22.7-1  gst-plugins-bad-libs-1.22.7-1  gst-plugins-base-1.22.7-1
gst-plugins-base-libs-1.22.7-1  gst-plugins-good-1.22.7-1  gst-plugins-ugly-1.22.7-1
gstreamer-1.22.7-1  gstreamer-vaapi-1.22.7-1  gtk-update-icon-cache-1:4.12.4-1
gtk4-1:4.12.4-1  gvim-9.0.2112-1  gwenview-23.08.3-2  harfbuzz-8.3.0-1  harfbuzz-icu-8.3.0-1
iana-etc-20231117-1  inkscape-1.3.1-1  intel-ucode-20231114-1  kactivities-stats5-5.112.0-1
kactivities5-5.112.0-1  karchive5-5.112.0-1  kauth5-5.112.0-1  kbookmarks5-5.112.0-1
kcalendarcore5-5.112.0-1  kcmutils5-5.112.0-1  kcodecs5-5.112.0-1  kcompletion5-5.112.0-1
kconfig5-5.112.0-1  kconfigwidgets5-5.112.0-1  kcontacts5-5.112.0-1  kcoreaddons5-5.112.0-1
kcrash5-5.112.0-1  kdbusaddons5-5.112.0-1  kdeclarative5-5.112.0-1  kded5-5.112.0-1
kdegraphics-thumbnailers-23.08.3-2  kdelibs4support-5.112.0-1  kdesu5-5.112.0-1
kdnssd5-5.112.0-1  kdoctools5-5.112.0-1  kemoticons-5.112.0-1  kfilemetadata5-5.112.0-1
kglobalaccel5-5.112.0-1  kguiaddons5-5.112.0-1  kholidays5-1:5.112.0-1  khtml-5.112.0-1
ki18n5-5.112.0-1  kiconthemes5-5.112.0-1  kidletime5-5.112.0-1  kimageformats5-5.112.0-1
kinit-5.112.0-1  kio5-5.112.0-1  kirigami2-5.112.0-1  kitemmodels5-5.112.0-1
kitemviews5-5.112.0-1  kjobwidgets5-5.112.0-1  kjs-5.112.0-1  knewstuff5-5.112.0-1
knotifications5-5.112.0-1  knotifyconfig5-5.112.0-1  kpackage5-5.112.0-1  kparts5-5.112.0-1
kpeople5-5.112.0-1  kpty5-5.112.0-1  kquickcharts5-5.112.0-1  krunner5-5.112.0-1
kservice5-5.112.0-1  ktexteditor5-5.112.0-1  ktextwidgets5-5.112.0-1
kunitconversion5-5.112.0-1  kwallet5-5.112.0-1  kwayland5-5.112.0-1  kwidgetsaddons5-5.112.0-1
kwindowsystem5-5.112.0-1  kxmlgui5-5.112.0-1  lib32-gnutls-3.8.2-1
lib32-gst-plugins-base-libs-1.22.7-1  lib32-gstreamer-1.22.7-1  lib32-harfbuzz-8.3.0-1
lib32-libgcrypt-1.10.3-1  lib32-libpipewire-1:0.3.85-1  lib32-libxml2-2.12.0-1
lib32-libxslt-1.1.39-1  lib32-p11-kit-0.25.3-1  lib32-pipewire-1:0.3.85-1
lib32-pipewire-jack-1:0.3.85-1  libadwaita-1:1.4.0-2  libass-0.17.1-2  libavif-1.0.2-1
libcap-2.69-2  libde265-1.0.13-1  libdrm-2.4.118-1  libgcrypt-1.10.3-1  libgusb-0.4.8-1
libkdcraw-23.08.3-1 [removal]  libkdcraw5-23.08.3-3  libp11-kit-0.25.3-1
libpipewire-1:0.3.85-1  libunibreak-5.1-1  libxml2-2.12.0-1  libxslt-1.1.39-1
linux-lts-headers-6.1.63-1  linux-wifi-hotspot-4.6.0-1  luajit-2.1.1700008891-1
mhwd-db-garuda-2:1.1.5-2  mhwd-db-garuda-git-2:1.1.4-5 [removal]
mhwd-garuda-git-r25.3a28734-1  mkinitcpio-37-1  modemmanager-qt5-5.112.0-1
networkmanager-qt5-5.112.0-1  nodejs-21.2.0-1  noto-fonts-emoji-1:2.040-1  npm-10.2.4-1
obs-studio-30.0.0-1  opencv-4.8.1-4  openvpn-2.6.8-1  p11-kit-0.25.3-1  patool-2.0.0-1
perl-io-socket-ssl-2.084-1  pipewire-1:0.3.85-1  pipewire-alsa-1:0.3.85-1
pipewire-audio-1:0.3.85-1  pipewire-jack-1:0.3.85-1  pipewire-pulse-1:0.3.85-1
pipewire-v4l2-1:0.3.85-1  pipewire-x11-bell-1:0.3.85-1  pipewire-zeroconf-1:0.3.85-1
plasma-framework5-5.112.0-1  plasma-wayland-protocols-1.11.1-1  plasma-workspace-
plasma5-themes-sweet-full-git-r346.6df2606-1  prison5-5.112.0-1  protobuf-25.1-1
proton-ge-custom-2:GE.Proton8.24-1  protontricks-git-1.10.5.r11.g68f965f-1  purpose5-5.112.0-1
python-fonttools-4.44.3-1  python-packaging-23.2-1  python-platformdirs-4.0.0-1
python-trove-classifiers-2023.11.13-1  qbittorrent-4.6.1-1  qqc2-desktop-style5-5.112.0-1
qt5-base-5.15.11+kde+r146-1  qt5-declarative-5.15.11+kde+r32-1  qt5-tools-5.15.11+kde+r4-1
scrcpy-2.2-1  serf-1.3.10-1  shaderc-2023.5-1  shared-mime-info-2.4-1
sof-firmware-2023.09.2-1  solid5-5.112.0-1  sonnet5-5.112.0-1  syndication5-5.112.0-1
syntax-highlighting5-5.112.0-1  systemd-254.6-2  systemd-libs-254.6-2
systemd-sysvcompat-254.6-2  texinfo-7.1-2  threadweaver5-5.112.0-1  ugrep-4.3.3-1
vde2-2.3.3-4  verdict-1.4.1-1  vim-runtime-9.0.2112-1  wine-8.20-1  wolfssl-5.6.4-1
wxwidgets-common-3.2.4-1  wxwidgets-gtk3-3.2.4-1  xdg-desktop-portal-1.18.1-1

Total Download Size:      7.25 MiB
Total Installed Size:  3666.03 MiB
Net Upgrade Size:        -0.02 MiB

:: Proceed with installation? [Y/n]


Kernel: 6.6.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6ca35f86-1497-467e-86b4-3527e048d859 rw rootflags=subvol=@
quiet radeon.cik_support=0 amdgpu.cik_support=1 rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=e10f4452-aa85-4278-b678-3c435a95f1cb loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: H510M-A PRO (MS-7D22) v: 1.0
serial: <superuser required> UEFI: American Megatrends LLC. v: 3.B0
date: 10/21/2022
Info: model: 11th Gen Intel Core i5-11600 bits: 64 type: MT MCP
arch: Rocket Lake gen: core 11 level: v4 note: check built: 2021+
process: Intel 14nm family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x59
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4800 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 801 10: 800 11: 800 12: 800 bogomips: 67392
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: none empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3
bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0380
Device-2: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: ASRock
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-4 empty: DP-3,DP-4,DP-5 bus-ID: 03:00.0 chip-ID: 1002:73ff
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting unloaded: radeon
alternate: fbdev,intel,vesa dri: radeonsi,iris gpu: amdgpu display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-4 mapped: HDMI-A-3 model: Samsung C27F390
serial: <filter> built: 2019 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: EGL v: 1.5 hw: drv: intel iris drv: amd radeonsi platforms: device: 0
drv: radeonsi device: 1 drv: iris device: 2 drv: swrast surfaceless:
drv: iris x11: drv: radeonsi inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6600 (navi23 LLVM
16.0.6 DRM 3.54 6.6.1-zen1-1-zen) device-ID: 1002:73ff memory: 7.81 GiB
unified: no
API: Vulkan v: 1.3.269 layers: 11 device: 0 type: discrete-gpu name: AMD
Radeon RX 6600 (RADV NAVI23) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:73ff surfaces: xcb,xlib device: 1 type: integrated-gpu
name: Intel Graphics (RKL GT1) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:4c8a surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
API: ALSA v: k6.6.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d4f class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: TP-Link TL-WN821N v5/v6 [RTL8192EU] driver: rtl8192eu type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-9.1:5
chip-ID: 2357:0107 class-ID: 0000 serial: <filter>
IF: wlp0s20f0u9u1 state: down mac: <filter>
Device-1: Belkin B8T017 Bluetooth+EDR 2.1 / F4U017 USB 2.0 7-port Hub
driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
bus-ID: 1- chip-ID: 050d:0017 class-ID: fe01 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 2.1
lmp-v: 4 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 694.93 GiB used: 343.16 GiB (49.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT250P2SSD8
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P2CR012 temp: 32.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: R022 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Silicon Power
model: SPCC Solid State Disk size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 61.3
scheme: MBR
ID-1: / raw-size: 215.53 GiB size: 215.53 GiB (100.00%)
used: 151.73 GiB (70.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 215.53 GiB size: 215.53 GiB (100.00%)
used: 151.73 GiB (70.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 215.53 GiB size: 215.53 GiB (100.00%)
used: 151.73 GiB (70.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 215.53 GiB size: 215.53 GiB (100.00%)
used: 151.73 GiB (70.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 17.06 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.43 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 33.0 C mobo: N/A gpu: amdgpu temp: 32.0 C
mem: 32.0 C
Fan Speeds (rpm): cpu: 1869 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0
fan-7: 0 fan-8: 0 fan-9: 0 fan-10: 0 gpu: amdgpu fan: 0
Processes: 330 Uptime: 18m wakeups: 0 Memory: total: 16 GiB note: est.
available: 15.43 GiB used: 4.12 GiB (26.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1856 libs: 521 tools: octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.2.15 running-in: konsole
inxi: 3.3.31
Garuda (2.6.18-1):
System install date:     2023-11-05
Last full system update: 2023-11-11
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:
1 Like

Try updating using sudo pacman -Syu (even though there is no issues in garuda-update ) , and can you please login using wayland session instead of X11

Thanks for your answer.

Unfortunately I tried to update with “sudo pacman -Syu” but the result is identical.

I also installed plasma-wayland-session so that it appears in SDDM, before entering the password I used wayland instead of xorg (bottom of the login screen) but the result is the same here too :frowning:

The problem persists

not a very likely thing to happen but have you tried using a different kernel?

sudo pacman -S linux-lts linux-lts-headers

and then while booting from grub advanced menu choose linux-lts.

1 Like

Thanks NaN
I installed the lts kernel, updated the system and selected it during boot… but unfortunately the problem remains the same :pensive:

can you,

cat /var/log/garuda/garuda-update | tb

and post the link
so we can see if maybe there is some error in post install hooks somewhere…? btw no need to go to a broken state for this your logs are unaffected while rolling back snapshots.

Thanks Nan!
here is the output
I hope it helps to do magic :slight_smile:

Although I am not quite sure what might be the issue but,

(15/28) Orphaned package notification...
kdsoap-ws-discovery-client 0.3.0-2
spdlog 1.12.0-2
wayland-protocols 1.32-1

I don’t think atleast kdsoap-ws-discovery-client and wayland-protocols should be orphans…?
This doesn’t look very promising either…

(12/30) Install DKMS modules
==> ERROR: Missing 6.1.63-1-lts kernel modules tree for module 8192eu/r293.f2fc8af.
==> ERROR: Missing 6.1.63-1-lts kernel modules tree for module vboxhost/7.0.12_OSE.

I hope someone more experienced can take a look and identify what’s going on. :sweat:

That’s the first thing I noticed: only linux-lts-headers-6.1.63-1… Is the kernel itself installed?
Post the output of pacman -Qs linux-lts

But that’s not the point. Plasma has a problem and I think something is missing.

(15/28) Orphaned package notification...
kdsoap-ws-discovery-client 0.3.0-2
spdlog 1.12.0-2
wayland protocols 1.32-1

Is Qt6 installed? Post the output of pacman -Qs qt6.

First of all thanks for your time and replies guys.

BEFORE the update
pacman -Qs qt6:

local/kdsoap-qt6 2.1.1-2
Qt-based client-side and server-side SOAP component
local/qt6-5compat 6.6.0-1 (qt6)
Module that contains unsupported Qt 5 APIs
local/qt6-base 6.6.0-3 (qt6)
A cross-platform application and UI framework
local/qt6-declarative 6.6.0-1 (qt6)
Classes for QML and JavaScript languages
local/qt6-imageformats 6.6.0-1 (qt6)
Plugins for additional image formats: TIFF, MNG, TGA, WBMP
local/qt6-multimedia 6.6.0-1 (qt6)
Classes for audio, video, radio and camera functionality
local/qt6-multimedia-ffmpeg 6.6.0-1
FFMpeg backend for qt6-multimedia
local/qt6-svg 6.6.0-2 (qt6)
Classes for displaying the contents of SVG files
local/qt6-translations 6.6.0-1 (qt6)
A cross-platform application and UI framework (Translations)

BEFORE the update
pacman -Qs linux-lts:

local/linux-lts-headers 6.1.62-1
Headers and scripts for building modules for the LTS Linux kernel

For linux-lts I installed it previously with the command
sudo pacman -S linux-lts linux-lts-headers
then I performed a system update with garuda-update and checked if Plasma would start… but it wouldn’t, so I restored the previous snapshot in which linux-lts wasn’t installed… maybe that’s why that error appears?

AFTER the update (plasma broken)

local/kdsoap-qt6 2.1.1-2
    Qt-based client-side and server-side SOAP component
local/qt6-5compat 6.6.0-1 (qt6)
    Module that contains unsupported Qt 5 APIs
local/qt6-base 6.6.0-3 (qt6)
    A cross-platform application and UI framework
local/qt6-declarative 6.6.0-1 (qt6)
    Classes for QML and JavaScript languages
local/qt6-imageformats 6.6.0-1 (qt6)
    Plugins for additional image formats: TIFF, MNG, TGA, WBMP
local/qt6-multimedia 6.6.0-1 (qt6)
    Classes for audio, video, radio and camera functionality
local/qt6-multimedia-ffmpeg 6.6.0-1
    FFMpeg backend for qt6-multimedia
local/qt6-svg 6.6.0-2 (qt6)
    Classes for displaying the contents of SVG files
local/qt6-translations 6.6.0-1 (qt6)
    A cross-platform application and UI framework (Translations)
local/linux-lts-headers 6.1.63-1
    Headers and scripts for building modules for the LTS Linux kernel

output of cat /var/log/garuda/garuda-update | tb after the update with plasma broken:

In the wiki I read “Orphans are packages that were installed as a dependency and are no longer required by any package
But how can it be possible that kdsoap-ws-discovery-client is orphaned if it is required by kio-extras , which is installed? (Arch Linux - kdsoap-ws-discovery-client 0.3.0-2 (x86_64))

pacman -Qs kio-extras
local/kio-extras 23.08.3-1 (kde-applications kde-network)
Additional components to increase the functionality of KIO

Did I misunderstand something?

It’s quite surprising how linux-lts is missing despite it’s headers having been downloaded given the command called for both packages.

sudo pacman -S linux-lts

if it successfully downloads follow with

sudo pacman -S linux-lts-headers

to compile kernel headers.

No you didn’t misunderstand anything. This is indeed a very peculiar situation.

kio-extras does not depend on this package, nor does any other package.

❯ pacman -Sii kdsoap-ws-discovery-client
Repository      : extra
Name            : kdsoap-ws-discovery-client
Version         : 0.3.0-2
Description     : WS-Discovery client library based on KDSoap
Architecture    : x86_64
URL             :
Licenses        : GPL3  custom
Groups          : None
Provides        : None
Depends On      : gcc-libs  glibc  kdsoap-qt6  qt6-base
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None

It should be safe to remove if you don’t need it.

Try creating a new user, and log in as them to see if they have the same issue.


Good morning and thanks for the reply.

I created a new user, I updated the system with garuda-update, plasma became unresponsive as usual, I rebooted and logged in with the new user and… IT WORKS!
With the new plasma user it starts, obviously there is no customization or anything else, but it works!! Thank you!

How can I now repair the old account or transfer the old account with all settings to the new one? there’s a way?

Can I copy the contents of the /home/user-old folder to the /home/user-new folder or will it not work?

Thanks again for the help

yea it may works , but the fear of copying the same thing that caused the problem is very likely to happen , so its safe to reconfigure it again .
edit : Please @Wolfz make @BluishHumility’s reply as a solution so others can benefit as well .

1 Like

Done, marked @BluishHumility’s reply as a solution
Thanks all!


I write this because it might be useful to someone else in the future.
After several attempts I recovered the old account without the need to create a new one.
The problem lies in the “~/.local/share/mime” folder, I don’t know what happened but by deleting that folder plasma works correctly again.

1 Like

Glad to hear you cracked the case @Wolfz! :man_detective:

If you don’t mind explaining how you figured out which was the problematic configuration, there is a good chance it could be useful for folks searching for a solution in the future.


Sure, I hope it can be useful.
After the suggestion to create a new user I found a similar case ([SOLVED] KDE/Plasma 5 stuck on splashscreen / Applications & Desktop Environments / Arch Linux Forums) where it was suggested to delete the ~/.local/share/kscreen folder.
Unfortunately for me it didn’t work but after renaming the “share” folder I noticed that plasma was starting up, so I slowly narrowed down the field by renaming the folders inside “share” one by one… until I found that the problematic folder was " mime".

Looking at the package list in the update I noticed that there is the package “shared-mime-info-2.4-1”… I wonder if it is it that corrupts the “mime” folder for me through the post installation hook" Update the MIME type database"? I don’t know, but I’m happy that with your help I solved it, thanks again!

EDIT: maybe maybe:


i also experienced this issue on plasma-wayland, but i just now realized that 80279 is already linked here. :sweat_smile:

According to that bug, shared-mime-info 2.4-1 will need to run glib2 with an upstream patch (so glib can handle circular references in the mime type DB). The new package isn’t released for arch yet. i didn’t know about using that, i was able to downgrade the shared-mime-info package to 2.3-1 with:

pacman -U

After successful install, clean up your system & home config

  • On wayland without X11, i don’t think you need to worry about the .Xauthority cookie

Then it may be necessary to:

  • rebuild the mime cache, though you might back it up if you’re worried about forward compatibility (i think it gets updated in the 2.4-1 post-install hook anyways) … please correct me if i’m wrong.
  • delete the ksycoca5*lock files from ~/.cache/
update-mime-cache "${XDG_DATA_HOME:-$HOME/.local/share}/mime"

That was the only thing that fixed it for me. There’s a few other things I tried listed below.

It probably affects anyone mixing nix or guix profiles containing mime types in their XDG_DATA_DIRS, as well as other users maybe. other desktop env’s may not be affected. i mix guix on top of garuda and it’s worked pretty well in the past, but guix is on shared-mime-types 1.15 and nix on 2.2.

i had a hard time with it:

  • i tried looking at timestamps in cache, but I’m running plasma, not X11.
  • a lot of systemd services weren’t starting, including the dbus-session … which i guess i should’ve caught. i honestly know guix’s tools better than systemd.
  • i ended up chasing a bunch of racing dbus service failures, depending on the order in which plasma was expecting them to start. initially, KDE was hanging on systemd user units using notify-send with an early target.
  • i did learn to write SDDM profiles though. I even got it to strace, since the QT logging wasn’t doing much
  • at that point, i tried reinstalling everything using the update tool, then deleted snapshots and rebalanced my disks.
  • i had already cleared pacman cache, so was the next best shortcut
1 Like