Plasma 6 black Screen

  Kernel: 6.7.6-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-linux
    root=UUID=8a69f047-feee-46cf-81a1-d299eb173883 rw rootflags=subvol=@ rd.udev.log_priority=3
    vt.global_cursor_default=0 loglevel=3 sysrq_always_enabled=1 mitigations=off
    amd_pstate=active amdgpu.ppfeaturemask=0xffffffff tsc=reliable clocksource=tsc nowatchdog
    nmi_watchdog=0 initrd=@\boot\initramfs-linux-cachyos.img
  Console: tty 3 DM: SDDM Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: P5.10 date: 10/20/2022
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3 serial: <filter>
    charge: 100% (should be ignored) rechargeable: yes status: discharging
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check
    built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 2
    microcode: 0xA20120A
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 1058 high: 3603 min/max: 550/4687 scaling: driver: amd-pstate-epp
    governor: performance cores: 1: 3603 2: 550 3: 3599 4: 550 5: 550 6: 550 7: 550 8: 550 9: 550
    10: 550 11: 550 12: 550 bogomips: 88797
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT] vendor: Gigabyte
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1,DP-2,HDMI-A-2 empty: HDMI-A-1
    bus-ID: 10:00.0 chip-ID: 1002:73df class-ID: 0300
  Display: server: v: with: Xwayland v: 23.2.4 compositor: kwin_wayland driver:
    X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    tty: 240x67
  Monitor-1: DP-1 model: LG (GoldStar) HDR WFHD serial: <filter> built: 2021 res: 2560x1080
    dpi: 81 gamma: 1.2 size: 798x334mm (31.42x13.15") diag: 869mm (34.2") modes: max: 2560x1080
    min: 640x480
  Monitor-2: DP-2 model: LG (GoldStar) TV SSCR2 serial: <filter> built: 2022 res: 3840x2160
    dpi: 61 gamma: 1.2 size: 1600x900mm (62.99x35.43") diag: 1836mm (72.3") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  Monitor-3: HDMI-A-2 model: LG (GoldStar) FULL HD serial: <filter> built: 2023 res: 1920x1080
    dpi: 102 gamma: 1.2 size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    gbm: drv: radeonsi surfaceless: drv: radeonsi inactive: wayland,x11
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 24.0.2-arch1.1 note: console (EGL sourced)
    renderer: AMD Radeon RX 6700 XT (radeonsi navi22 LLVM 16.0.6 DRM 3.57 6.7.6-1-cachyos),
    llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan v: 1.3.276 layers: 21 device: 0 type: discrete-gpu name: AMD Radeon RX 6700 XT
    (RADV NAVI22) driver: mesa radv v: 24.0.2-arch1.1 device-ID: 1002:73df surfaces: N/A device: 1
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 24.0.2-arch1.1 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: N/A
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 10:00.1 chip-ID: 1002:ab28 class-ID: 0403
  Device-2: Sony INZONE H9 / H7 driver: cdc_acm,hid-generic,snd-usb-audio,usbhid type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-2:3 chip-ID: 054c:0e53 class-ID: 0a00
  API: ALSA v: k6.7.6-1-cachyos status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 08:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlp8s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 0a:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Info: services: NetworkManager, smbd, sshd, systemd-timesyncd
  Device-1: Edimax Bluetooth Adapter driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-1.4.2:7 chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.1 lmp-v: 10 status:
    discoverable: yes pairing: yes class-ID: 6c0104
  Local Storage: total: 3.64 TiB used: 2.22 TiB (61.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD BLACK SN770 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 731120WD temp: 35.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 3B4QFXO7 temp: 34.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: CC41 scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 734.08 GiB (78.8%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 44.3 MiB (14.8%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 734.08 GiB (78.8%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 734.08 GiB (78.8%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 734.08 GiB (78.8%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 47.6 C mobo: 34.0 C gpu: amdgpu temp: 52.0 C mem: 56.0 C
  Fan Speeds (rpm): cpu: 1936 fan-1: 0 fan-3: 1322 fan-4: 1485 fan-5: 1241 gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.22 vbat: 3.28 gpu: amdgpu watts: 28.00
  Memory: total: 32 GiB available: 31.26 GiB used: 5.05 GiB (16.1%)
  Processes: 401 Power: uptime: 4m states: freeze,mem,disk suspend: s2idle wakeups: 0
    hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 12.49 GiB
    services: power-profiles-daemon Init: systemd v: 255 default: graphical tool: systemctl
  Packages: 2853 pm: pacman pkgs: 2810 libs: 633 tools: octopi,paru,yay pm: flatpak pkgs: 43
    Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0 running-in: tty 3
    inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2024-01-11
  Last full system update: 2024-03-02
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Following KDE 6 repository / testing - #213 by TNE

I tried installing plasma 6 but I just get a black screen when booting my PC

this is my journal

Hmm when it tries to load sddm it seems to complain about not being able to find the dr460nized theme…

Mar 02 16:25:52 Garuda-Linux sddm-greeter[7768]: file:///usr/share/sddm/themes/Dr460nized-Sugar-Candy/Main.qml: No such file or directory


Mar 02 16:25:51 Garuda-Linux sddm[988]: Unable to find autologin session entry "plasmawayland"
Mar 02 16:25:51 Garuda-Linux sddm[988]: Autologin failed!

EDIT: tried reseting my .config and .cache folders (ofc backing up .config beforhand)
with no luck so doesn’t seem to be config related… (at least in the home folder…)

1 Like

Interesting. What is set in /etc/sddm.conf / /etc/sddm.conf.d/* ? This was supposed to be switched to Dr460nized theme.

1 Like

I have a /etc/sddm.conf which was just empty and under /etc/sddm.conf.d/

I have the following

cat 10-wayland.conf 

CompositorCommand=kwin_wayland --no-lockscreen
[zany130@Garuda-Linux ~]$ cat kde_settings.conf 

HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot

Font=Noto Sans,10,-1,0,50,0,0,0,0,0


ServerArguments=-dpi 0

change this to the following to fix the situation:


Will look into why its not set automatically.


Yup making that change allows me to boot got a pop-up about migration of the dr460ized theme and everything seems to be working.

Thanks and good job​:+1: love your running theme btw :grin:

Thanks for debugging and finding this. This is now fixed in garuda-dr460nized-next 4.0.1, here’s to a smooth roll-out once plasma 6 releases!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.