Pipewirepulse high ram usage

Pipewire pulse is taking a lot of ram for what it does. 1 gb nearly. is this normal ?in the memory map the thing taking 1.2 gb is called [heap]

Use forum search function, please

1 Like

nope nothing found.

that is not my problem. pipewire pulse is using more than 1 gb of ram.

We change to pulseaudio.

it says unable to satisfy dependencies for gnome apps.

post as text the terminal in and output, nice formated.

:: pulseaudio and pipewire-pulse are in conflict. Remove pipewire-pulse? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'pulseaudio-bluetooth' required by pulseaudio-support
:: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth

In and out :smiley:

sudo pacman -Rns garuda-pipewire pipewire-alsa pipewire-pulse

then

sudo pacman -Syu
1 Like

no garuda pipewire.

accountsservice-0.6.55-3  bc-1.07.1-4  cheese-3.38.0-1  chrome-gnome-shell-10.1-5
              clutter-gst-3.0.27-3  colord-gtk-0.2.0-2  cups-pk-helper-0.2.6-4  gdm-3.38.2-1
              gnome-bluetooth-3.34.3-1  gnome-color-manager-3.36.0-1
              gnome-control-center-3.38.2-1  gnome-settings-daemon-3.38.1-1
              gnome-shell-extensions-3.38.2-1  gnome-shell-performance-1:3.38.1+15+gc555f19b1-1
              gnome-themes-extra-3.28-2  gnome-tweaks-3.34.1-1
              gnome-video-effects-0.5.0+4+g9554041-2  libcanberra-pulse-0.30+2+gc0620e4-3
              libgdm-3.38.2-1  libhandy0-0.0.13+12+gaa6b6f4-2  mutter-performance-3.38.2-1
              nautilus-bluetooth-0.1.6-1  pulseaudio-alsa-1:1.2.2-2  pulseaudio-ctl-1.68-1
              pulseaudio-equalizer-ladspa-3.0.2-4  shared-color-targets-0.1.7-3
              swh-plugins-0.4.17-4  pipewire-alsa-0.3.17-1  pipewire-pulse-0.3.17-1

it has to remove these if the command is to be run.

IDK what are you doing.
And if I want you to post in + out put from Terminal, why do you ignore it?
Use last working snapshot, look what change in update afterwards.

─λ sudo pacman -Rns garuda-pipewire pipewire-alsa pipewire-pulse
[sudo] password for pupperemeritus:
error: target not found: garuda-pipewire
╭─pupperemeritus at pupperemeritus in ⌁
╰─λ sudo pacman -Rns pipewire-alsa pipewire-pulse
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by gnome-settings-daemon
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by pulseaudio-alsa
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by pulseaudio-ctl
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by pulseaudio-equalizer-ladspa
╭─pupperemeritus at pupperemeritus in ⌁
╰─λ sudo pacman -Rnsc pipewire-alsa pipewire-pulse
checking dependencies...
:: arc-gtk-theme optionally requires gnome-themes-standard: for gtk2 themes
:: firefox optionally requires pulseaudio: Audio support
:: gtk2 optionally requires gnome-themes-standard: Default widget theme
:: lib32-fluidsynth optionally requires pulseaudio: PulseAudio sound support
:: libcanberra optionally requires libcanberra-pulse: PulseAudio driver
:: libxcursor optionally requires gnome-themes-standard: fallback icon theme
:: lightdm optionally requires accountsservice: Enhanced user accounts handling
:: phonon-qt5 optionally requires pulseaudio: PulseAudio support
:: pipewire optionally requires pipewire-pulse: PulseAudio support
:: speech-dispatcher optionally requires pulseaudio: PulseAudio support

Packages (29) accountsservice-0.6.55-3  bc-1.07.1-4  cheese-3.38.0-1  chrome-gnome-shell-10.1-5
              clutter-gst-3.0.27-3  colord-gtk-0.2.0-2  cups-pk-helper-0.2.6-4  gdm-3.38.2-1
              gnome-bluetooth-3.34.3-1  gnome-color-manager-3.36.0-1
              gnome-control-center-3.38.2-1  gnome-settings-daemon-3.38.1-1
              gnome-shell-extensions-3.38.2-1  gnome-shell-performance-1:3.38.1+15+gc555f19b1-1
              gnome-themes-extra-3.28-2  gnome-tweaks-3.34.1-1
              gnome-video-effects-0.5.0+4+g9554041-2  libcanberra-pulse-0.30+2+gc0620e4-3
              libgdm-3.38.2-1  libhandy0-0.0.13+12+gaa6b6f4-2  mutter-performance-3.38.2-1
              nautilus-bluetooth-0.1.6-1  pulseaudio-alsa-1:1.2.2-2  pulseaudio-ctl-1.68-1
              pulseaudio-equalizer-ladspa-3.0.2-4  shared-color-targets-0.1.7-3
              swh-plugins-0.4.17-4  pipewire-alsa-0.3.17-1  pipewire-pulse-0.3.17-1

i mean it is working but pipewire pulse is eating a lot of ram

Well what you can do is install

sudo pacman -S pulseaudio-support pulseaudio-bluetooth
2 Likes

That worked