Pipewire&pulseaudio issue

My garuda was having bove pipewire and pulseaudio (+ its dependencies) installed. This started to cause a problem with microphone which was not possible to be found (like a common problem).
I decided to only switch to pipewire by deleting pulseaudio.
Removing pulseaudio and other its subdependencies destroyed desktop audio trays and global audio settings.
And Removing only pipewire caused to broke docks on desktop and make it unable to add any panel on desktop. (Pipewire removed by pacman -Rdd cuz octopi wanted to remove like 170 system dependencies with pipewire)
In bove options ofc audio was working.
Which dependencies am i missing?
Which one do you suggest to stay with?

Hi and welcome.

Not sure what to advise (besides posting the garuda-inxi thing), but I see I have both of them, with PulseAudio provided by the pipewire-pulse package and not running. Excerpt from mine:

Audio:
  [...]
  Sound Server-1: ALSA v: k5.19.13-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.58 running: yes

(Yes I should update, there's PipeWire 0.3.59-2 now)

I'm almost sure it did so by itself, or maybe there was some announcement or advice here time ago which I don't remember. And sadly I don't understand much of this as good as I'd like, so... :man_shrugging:
Try searching around in this forum for "pulseaudio pipewire", "microphone pulseaudio", so on.
Maybe this?


pactree -r pulseaudio
fish❯ pactree -r pulseaudio
pipewire-pulse provides pulseaudio
├─easyeffects
├─gnome-bluetooth
│ └─blueberry
└─pipewire-support
pactree -r pipewire
fish❯ pactree -r pipewire
pipewire
├─fluidsynth
│ ├─calf
│ │ └─easyeffects
│ └─gst-plugins-bad
│   └─gstreamer-meta
├─gst-plugin-pipewire
│ └─pipewire-support
├─helvum
├─obs-studio
│ └─wlrobs-hg
├─pipewire-jack
│ ├─ffmpeg
│ │ ├─chromaprint
│ │ │ └─gst-plugins-bad
│ │ ├─ffmpegthumbnailer
│ │ ├─firedragon
│ │ ├─gst-libav
│ │ │ └─gstreamer-meta
│ │ ├─mpv
│ │ │ └─celluloid
│ │ ├─notcurses
│ │ ├─obs-studio
│ │ ├─qt5-webengine
│ │ │ ├─freecad
│ │ │ └─iaito
│ │ └─wf-recorder
│ ├─ffmpeg4.4
│ │ ├─opencascade
│ │ │ └─freecad
│ │ ├─vlc
│ │ └─wf-recorder
│ ├─fluidsynth
│ ├─gst-plugins-good
│ │ └─gstreamer-meta
│ ├─mpv
│ ├─obs-studio
│ ├─pipewire-support
│ ├─portaudio
│ │ ├─fluidsynth
│ │ └─libopenmpt
│ │   └─gst-plugins-bad
│ └─qemu-audio-jack
│   └─qemu-full
│     └─grub2-theme-preview
├─pipewire-pulse
│ ├─easyeffects
│ ├─gnome-bluetooth
│ │ └─blueberry
│ └─pipewire-support
├─pipewire-support
├─pipewire-v4l2
│ └─pipewire-support
├─pipewire-zeroconf
│ └─pipewire-support
├─qpwgraph
├─wireplumber
│ ├─gst-plugin-pipewire
│ ├─pipewire-alsa
│ │ └─pipewire-support
│ ├─pipewire-jack
│ ├─pipewire-pulse
│ ├─pipewire-v4l2
│ └─xdg-desktop-portal-wlr
│   └─xdg-desktop-portal
│     ├─imhex
│     └─xdg-desktop-portal-wlr
├─xdg-desktop-portal
└─xdg-desktop-portal-wlr

Note that I'm on Sway and I installed many other packages, so you may see a different output, but you get the picture: stuff depends on both of them. (pactree is in pacman-contrib).

As far as I can tell, PipeWire is "the way forward" and PulseAudio still there for compatibility with some things that depend on it, but has to be the pipewire-pulse one to coexist (and it depends on pipewire anyways, I surmise it's a compatibility layer much like XWayland is for X11 on Wayland).

pacman -Rdd, as you probably know already, means "remove it even if it breaks dependencies" and, well, something broke indeed.

If you have a snapshot from before trying to remove any of them, I guess you'd be better off restoring it and proceeding from there.
If not, I'd try reinstall pipewire and pipewire-pulse and reboot with my fingers crossed then do a garuda-update for good measure and reboot again.

In either case, garuda-inxi will tell you (and those who may help you, if you post it) whether they are running at the same time (they shouldn't) which would be a likely cause for the microphone problem. By the way, it's probably useful to know whether it's an internal laptop mic, or plugged in the sound card, or rather a USB or Bluetooth one.

5 Likes

Removed all pipewire dependencies and switched to pulseaudio and even i was trying it a few times now it worked. The problem is i can not remove pipewire, pipewire-audio and pipewire-jack and i guess its no longer needed here. By removing it, octopi wants to remove 323 other programs, sys dependencies etc.
Pacman does not acutally care for example about deleting pipewire-jack while installing pulseaudio-jack

You don't need to remove either Pipewire or Pulseaudio, just pick one of them (besides ALSA) and enable it and disable the other. Use Garuda Assistant > Settings tool.

4 Likes

I've have a familiar issue and changing the settings in the Garuda Assistant doesn't change it et all.
Both Pipewire server and Pulseaudio server are running and making huge issues.
I'm now stuck without audio except from a few applications which can utilize Pipewire.
I'd like to change to Pulseaudio completely and make things work again.

I dunno how since the dependencies from Pipewire are massive

Searching instead of whinging may make a difference. Of course, that may also take a few more key strokes.

It is always easier to blame some one, some group, some thing or some ideal for the lack of personal responsibility and initiative.

1 Like

Well in the end I had to change everything to pipewire, and my sound works. But it is still odd to me to have the option to change to Pulseaudio although it actually doesn't work.
Fair enough it could be that I'm missing something about that concept but in the end it was confusing o.o

2 Likes

And some here in the forum have had the reverse experience. The important thing is that you tried, and found, a solution that works for your system.

My apologies for coming down on you like a ton of bricks. :slight_smile:

4 Likes

I've been in the Gentoo forum for years, I'm used to that :rofl:
Everything is fine and thanks c00ter! :slight_smile:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.