Pipewire audio crackling/popping fix no longer works after KDE 6

╭─sly@Sly in ~
╰─λ garuda-inxi
Kernel: 6.8.2-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9a6c40f9-5527-4910-818c-36876e29d0d0 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=61b4f61d-d6a3-47d6-8143-a9051635e7f2 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop Mobo: Micro-Star model: MPG Z490 GAMING CARBON WIFI (MS-7C73)
v: 1.0 serial: <superuser required> uuid: <superuser required>
UEFI: American Megatrends v: 1.C0 date: 06/08/2022
Info: model: Intel Core i9-10850K bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 5 microcode: 0xFA
Topology: cpus: 1x cores: 10 tpc: 2 threads: 20 smt: enabled cache:
L1: 640 KiB desc: d-10x32 KiB; i-10x32 KiB L2: 2.5 MiB desc: 10x256 KiB
L3: 20 MiB desc: 1x20 MiB
Speed (MHz): avg: 800 min/max: 800/5200 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800 16: 800
17: 800 18: 800 19: 800 20: 800 bogomips: 144000
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none empty: DP-1, HDMI-A-1, HDMI-A-2, HDMI-A-3
bus-ID: 00:02.0 chip-ID: 8086:9bc5 class-ID: 0380
Device-2: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
vendor: Sapphire Pulse driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,DP-3,DP-4 empty: HDMI-A-4,Writeback-1
bus-ID: 03:00.0 chip-ID: 1002:73bf class-ID: 0300
Display: wayland server: X.org v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu,intel
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi,i965
gpu: i915,amdgpu d-rect: 7280x2520 display-ID: 0
Monitor-1: DP-2 pos: top-center res: 3440x1440 size: N/A modes: N/A
Monitor-2: DP-3 pos: bottom-l res: 1920x1080 size: N/A modes: N/A
Monitor-3: DP-4 pos: bottom-r res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: amd radeonsi platforms: device: 0
drv: iris device: 1 drv: radeonsi device: 2 drv: swrast surfaceless:
drv: iris wayland: drv: radeonsi x11: drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6800 (radeonsi navi21
LLVM 17.0.6 DRM 3.57 6.8.2-zen2-1-zen) device-ID: 1002:73bf
memory: 15.62 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 6800 (RADV NAVI21) driver: mesa radv v: 24.0.3-arch1.2
device-ID: 1002:73bf surfaces: xcb,xlib,wayland device: 1
type: integrated-gpu name: Intel UHD Graphics 630 (CML GT2)
driver: mesa intel v: 24.0.3-arch1.2 device-ID: 8086:9bc5
surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.3-arch1.2 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
API: ALSA v: k6.8.2-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 06:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:8 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 13.19 TiB used: 9.08 TiB (68.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Sabrent model: Rocket 4.0 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: RKT401.3 temp: 36.9 C
scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Sabrent model: Rocket 4.0 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: RKT401.3 temp: 41.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: 0001 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST6000DM003-2CY186
size: 5.46 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5425 serial: <filter> fw-rev: 0001 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD5000AAKX-753CA1 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: N/A serial: <filter> fw-rev: 1H19
scheme: MBR
ID-6: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD2002FAEX-007BA0 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: N/A serial: <filter> fw-rev: 1D05
scheme: MBR
ID-7: /dev/sde maj-min: 8:64 vendor: Western Digital
model: WD10JMVW-11AJGS2 size: 931.48 GiB block-size: physical: 512 B
logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1007 scheme: MBR
ID-1: / raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 1.19 TiB (67.8%)
fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3
ID-3: /home raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 1.19 TiB (67.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-4: /var/log raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 1.19 TiB (67.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 1.19 TiB (67.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.58 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
ID-2: swap-2 type: partition size: 68.84 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:5
System Temperatures: cpu: 32.0 C pch: 50.0 C mobo: N/A gpu: amdgpu
temp: 68.0 C mem: 66.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Memory: total: 64 GiB available: 62.58 GiB used: 6.82 GiB (10.9%)
Processes: 431 Power: uptime: 47m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 25 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 2311 pm: pacman pkgs: 2301 libs: 623 tools: octopi,pamac,paru
pm: flatpak pkgs: 10 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi
default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-08-04
Last full system update: 2024-03-30
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

When I was back on KDE 5 I had this command set saved to fix audio crackling/popping in pipewire related to audio powersave, but this no longer works on KDE 6

Power saving “can” lead to issues, however somethings to try:

sudo sed -i 's/--\["session.suspend-timeout-seconds"\] = 5/\["session.suspend-timeout-seconds"\] = 0/' /usr/share/wireplumber/main.lua.d/50-alsa-config.lua

systemctl restart --user pipewire.service

If Didn’t work, revert back:

sudo sed -i 's/\["session.suspend-timeout-seconds"\] = 0/--\["session.suspend-timeout-seconds"\] = 5/' /usr/share/wireplumber/main.lua.d/50-alsa-config.lua

systemctl restart --user pipewire.service

Does anyone have an updated command to do the same thing on KDE 6? Im getting this error because the directory got changed / moved. Thanks you.

╭─sly@Sly in ~ took 1s
╰─λ sudo sed -i ‘s/–[“session.suspend-timeout-seconds”] = 5/[“session.suspend-timeout-seconds”] = 0/’ /usr/share/wireplumber/main.lua.d/50-alsa-config.lua
[sudo] password for sly:
sed: can’t read /usr/share/wireplumber/main.lua.d/50-alsa-config.lua: No such file or directory

Im looking around in the new /usr/share/wireplumber/wireplumber.conf and I don’t see anything related to session timeout

I haven’t solved my issue yet due to time/work, but i found some resources that will hopefully solve my issue:

[SOLVED] Wireplumber 0.5.0 disable suspend / Multimedia and Games / Arch Linux Forums


It seems like the file location for “/usr/share/wireplumber/main.lua.d/50-alsa-config.lua” did get moved and i have to migrate and or create a new file

1 Like

Thank you.
I didn’t know there was even a fix for that since it happened on windows for me as well. but added the text from the aur PipeWire - ArchWiki Other then the one pop on login its stopped popping for me 100% when playing content with audio.

*Found the config I needed to add to here /usr/share/wireplumber/wireplumber.conf.d/


Awesome, thank you so much! I did exactly the same thing and its working just as expected!

It’s annoying that i had to fix this twice now though, I wish the devs would stop moving shit lol, but i’m happy that i made you aware of this fix

1 Like

I would be nice if things could stay in one spot. Every update I ask myself where is this file now. lol

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.