Pi-hole FTL offline

I installed pi-hole(server) of AUR but it showing pihole-FTL offline. I tried,
1.Disabling Port 53 by disabling systemd-resolved as in Arch wiki.
2.Reinstalling it.
3.Restarting pihole-FTL
4.Checking Port 53 listening status
5.Removing front '#' signs from pihole-FTL.conf file.

but anything is not working.

The command outputs are:

1.    pihole -c
    |¯¯¯(¯)_|¯|_  ___|¯|___        Core: version is 
    | ¯_/¯|_| ' \/ _ \ / -_)        Web: version is 5.2.
    |_| |_| |_||_\___/_\___|        FTL: 
     ——————————————————————————————————————————————————————————
      Hostname: study-travelmatep24(Garuda  )
        Uptime: 00:02:58                                                         
     Task Load: 6.12 3.40 1.34     (Active: 10 of 107 tasks)
     CPU usage: 17%                (4x 2.1 GHz @ 344k)
     RAM usage: 14%                (Used: 1 GB of 10 GB)
     HDD usage: 9%                 (Used: 41 GB of 466 GB)
      LAN addr: 192.168.43.131     (Gateway: 192.168.43.1)
       Pi-hole: Active             (Blocking: 0 sites)
     Ads Today: 0%                 (Total: 0 of 0)
    Local Qrys: 0%                 (2 DNS servers)
       Blocked: FTL offline                                                      
    Top Advert:                                                                  
    Top Domain:                                                                  
    Top Client:

2.sudo netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 127.0.0.1:4711          0.0.0.0:*               LISTEN      8005/pihole-FTL     
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      8005/pihole-FTL     
tcp6       0      0 ::1:4711                :::*                    LISTEN      8005/pihole-FTL     
tcp6       0      0 127.0.0.1:9614          :::*                    LISTEN      2452/java           
tcp6       0      0 :::53                   :::*                    LISTEN      8005/pihole-FTL     
udp        0      0 0.0.0.0:53              0.0.0.0:*                           8005/pihole-FTL     
udp        0      0 0.0.0.0:60627           0.0.0.0:*                           372/avahi-daemon: r 
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           372/avahi-daemon: r 
udp6       0      0 :::53                   :::*                                8005/pihole-FTL     
udp6       0      0 :::37856                :::*                                372/avahi-daemon: r 
udp6       0      0 :::5353                 :::*                                372/avahi-daemon: r 

3. ❯ sudo pihole-FTL debug
[sudo] password for study:
[2020-10-07 04:24:49.016 49487M] Using log file /run/log/pihole-ftl/pihole-FT
L.log
[2020-10-07 04:24:49.016 49487M] ########## FTL started! ##########
[2020-10-07 04:24:49.016 49487M] FTL branch: master
[2020-10-07 04:24:49.016 49487M] FTL version: 5.2
[2020-10-07 04:24:49.017 49487M] FTL commit: builtfromreleasetarball
[2020-10-07 04:24:49.017 49487M] FTL date: 2020-08-12
[2020-10-07 04:24:49.017 49487M] FTL user: root
[2020-10-07 04:24:49.017 49487M] Compiled for x86_64 (compiled locally) using
cc (GCC) 10.2.0
[2020-10-07 04:24:49.017 49487M] Starting config file parsing (/etc/pihole/pi
hole-FTL.conf)
[2020-10-07 04:24:49.017 49487M]    SOCKET_LISTENING: only local
[2020-10-07 04:24:49.017 49487M]    AAAA_QUERY_ANALYSIS: Show AAAA queries
[2020-10-07 04:24:49.017 49487M]    MAXDBDAYS: max age for stored queries is
365 days
[2020-10-07 04:24:49.017 49487M]    RESOLVE_IPV6: Resolve IPv6 addresses
[2020-10-07 04:24:49.017 49487M]    RESOLVE_IPV4: Resolve IPv4 addresses
[2020-10-07 04:24:49.017 49487M]    DBINTERVAL: saving to DB file every minut
e
[2020-10-07 04:24:49.017 49487M]    DBFILE: Using /etc/pihole/pihole-FTL.db
[2020-10-07 04:24:49.017 49487M]    MAXLOGAGE: Importing up to 24.0 hours of
log data
[2020-10-07 04:24:49.017 49487M]    PRIVACYLEVEL: Set to 0
[2020-10-07 04:24:49.017 49487M]    IGNORE_LOCALHOST: Show queries from local
host
[2020-10-07 04:24:49.017 49487M]    BLOCKINGMODE: Null IPs for blocked domain
s
[2020-10-07 04:24:49.017 49487M]    ANALYZE_ONLY_A_AND_AAAA: Disabled. Analyz
ing all queries
[2020-10-07 04:24:49.017 49487M]    DBIMPORT: Importing history from database
[2020-10-07 04:24:49.017 49487M]    PIDFILE: Using /run/pihole-ftl/pihole-FTL
.pid
[2020-10-07 04:24:49.017 49487M]    PORTFILE: Using /run/pihole-ftl/pihole-FT
L.port
[2020-10-07 04:24:49.017 49487M]    SOCKETFILE: Using /run/pihole-ftl/FTL.soc
k
[2020-10-07 04:24:49.017 49487M]    SETUPVARSFILE: Using /etc/pihole/setupVar
s.conf
[2020-10-07 04:24:49.017 49487M]    MACVENDORDB: Using /etc/pihole/macvendor.
db
[2020-10-07 04:24:49.017 49487M]    GRAVITYDB: Using /etc/pihole/gravity.db
[2020-10-07 04:24:49.017 49487M]    PARSE_ARP_CACHE: Active
[2020-10-07 04:24:49.017 49487M]    CNAME_DEEP_INSPECT: Active
[2020-10-07 04:24:49.017 49487M]    DELAY_STARTUP: No delay requested.
[2020-10-07 04:24:49.017 49487M]    NICE: Set process niceness to -10 (defaul
t)
[2020-10-07 04:24:49.017 49487M]    BLOCK_ESNI: Enabled, blocking _esni.{bloc
ked domain}
[2020-10-07 04:24:49.017 49487M]    NAMES_FROM_NETDB: Enabled, trying to get
names from network database
[2020-10-07 04:24:49.017 49487M] Finished config file parsing
[2020-10-07 04:24:49.018 49487M] WARNING: Starting pihole-FTL as user root is
not recommended
[2020-10-07 04:24:49.018 49487M] Database version is 7
[2020-10-07 04:24:49.018 49487M] Database successfully initialized
[2020-10-07 04:24:49.018 49487M] Imported 0 queries from the long-term databa
se
[2020-10-07 04:24:49.018 49487M]  -> Total DNS queries: 0
[2020-10-07 04:24:49.018 49487M]  -> Cached DNS queries: 0
[2020-10-07 04:24:49.018 49487M]  -> Forwarded DNS queries: 0
[2020-10-07 04:24:49.018 49487M]  -> Blocked DNS queries: 0
[2020-10-07 04:24:49.018 49487M]  -> Unknown DNS queries: 0
[2020-10-07 04:24:49.018 49487M]  -> Unique domains: 0
[2020-10-07 04:24:49.018 49487M]  -> Unique clients: 0
[2020-10-07 04:24:49.018 49487M]  -> Known forward destinations: 0
[2020-10-07 04:24:49.019 49487M] Successfully accessed setupVars.conf

dnsmasq: failed to create listening socket for port 53: Address already in us
e

Better you ask there :slight_smile:

I installed pi-hole on Odroid XU4 and it work OOTB

|¯¯¯(¯)_|¯|_  ___|¯|___        Core: v5.1.2.
| ¯_/¯|_| ' \/ _ \ / -_)        Web: v5.1.1.
|_| |_| |_||_\___/_\___|        FTL: v5.2.
 ——————————————————————————————————————————————————————————
  Hostname: odroid             (Ubuntu Beaver 18.04)
    Uptime: 11 days, 17:11:07                                                                                                                    
 Task Load: 0.22 0.17 0.06     (Active: 0 of 76 tasks)
 CPU usage: 1%                 (8x 300 MHz @ 331k)
 RAM usage: 21%                (Used: 412 MB of 2 GB)
 HDD usage: 74%                (Used: 22 GB of 30 GB)
  LAN addr: 192.168.178.26     (Gateway: 192.168.178.1)
   Pi-hole: Active             (Blocking: 1112991 sites)
 Ads Today: 1%                 (Total: 83 of 10040)
Local Qrys: 61%                (2 DNS servers)
   Blocked: msh.amazon.co.uk                                                                                                                     
Top Advert: msh.amazon.co.uk                                                                                                                     
Top Domain: localhost.fritz.box                                                                                                                  
Top Client: odroid.localhost                                                                                                                     

Why is your list empty?

3 Likes

https://forum.garudalinux.org/uploads/default/original/2X/5/514c5f8c19145964ca069ca112b26a1046d24a47.png
I want to ask only that my dns settings needs to change or not!!!!!!! and want to ask @SGS that which version of pihole are you using AUR or snap or other.

No problem, ask.

other, it is Ubuntu :slight_smile: , but I will upgrade now to '20.04.1 LTS'

2 Likes

Thank you @SGS

1 Like

I just think you will get better and faster answers in the pi-hole forum than here.

Since it works for me and I didn't have any problems with the installation, I don't remember the procedure, sorry.

4 Likes

If you want adblocking you can also use our welcome app to enable it, no need to run a pihole (unless there is a specific use case ofc) :slight_smile:

1 Like

Enabling Adguard DNS is not working for me.

For me it does. You can check here if it does for you, last option.

3 Likes

yes it is showing adguard dns status active but it can't even block the ads from youtube(trying chromium browser).

Well then. Isnt Ublock sufficient for this?

2 Likes

Yes, it is sufficient but I was looking for sytemwide ad-blocker. So I don't need any saperate ad blocker for all saperate browsers.