Performance Loss after Update

This is the output of garuda-inxi

System:
  Kernel: 5.15.31-1-lts arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: root=UUID=9279d3fa-41b3-4a57-8a34-fcde65d58047 rw
    [email protected] quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
    [email protected]\boot\intel-ucode.img [email protected]\boot\initramfs-linux-lts.img
  Desktop: GNOME v: 41.5 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 41.3
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Micro-Star product: GF65 Thin 9SEXR v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-16W1 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E16W1IMS.10B date: 05/19/2020
Battery:
  ID-1: BAT1 charge: 27.0 Wh (60.0%) condition: 45.0/51.3 Wh (87.7%)
    volts: 11.8 min: 11.4 model: MSI Corp. MS-16W1 type: Li-ion serial: N/A
    status: N/A
  ID-2: hidpp_battery_0 charge: 79% condition: N/A volts: 4.0 min: N/A
    model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
    serial: <filter> status: discharging
CPU:
  Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2353 high: 2399 min/max: 800/4100 scaling:
    driver: intel_pstate governor: performance cores: 1: 2310 2: 2374 3: 2399
    4: 2312 5: 2320 6: 2399 7: 2375 8: 2341 bogomips: 38400
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
    driver: i915 v: kernel ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.0
    compositor: gnome-shell driver: X: loaded: modesetting gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0xd0ed built: 2019 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.7 compat-v: 3.0 direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.31-1-lts running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 1.4 TiB used: 151.98 GiB (10.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: RKT303.3
    temp: 38.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: LITE-ON model: CL1-8D512
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1.00
    temp: 39.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 290 GiB size: 290 GiB (100.00%) used: 151.9 GiB (52.4%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
    used: 80.7 MiB (27.3%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:5
  ID-3: /home raw-size: 290 GiB size: 290 GiB (100.00%)
    used: 151.9 GiB (52.4%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 290 GiB size: 290 GiB (100.00%)
    used: 151.9 GiB (52.4%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-5: /var/tmp raw-size: 290 GiB size: 290 GiB (100.00%)
    used: 151.9 GiB (52.4%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.0 C pch: 67.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 342 Uptime: 3m wakeups: 3 Memory: 15.47 GiB
  used: 4.98 GiB (32.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 alt: 8 clang: 13.0.1 Packages: pacman: 1680 lib: 407 Shell: Zsh
  v: 5.8.1 running-in: tilix inxi: 3.3.14
Garuda (2.5.6-2):
  System install date:     2021-06-09
  Last full system update: 2022-03-27
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Timeshift (maybe)
  Failed units:

As the title says, after the last update gnome became very laggy, even in things like switching workspaces. I hadn't updated my system in a while, so I can't figure out which package is the responsible for this issue. Fortunately I have used timeshift to go back to the previously working state. When I try to update using garuda-update these are the packages showing up:

accountsservice-22.08.8-2  albert-0.17.2-2  alsa-card-profiles-1:0.3.49-1
               archlinux-appstream-data-pamac-1:20220327-1  at-spi2-core-2.44.0-2  babl-0.1.90-2
               bbswitch-dkms-0.8-495  blender-17:3.1.2-1  btrfs-assistant-1.2-1
               ca-certificates-mozilla-3.77-1  calibre-5.40.0-1  clutter-1.26.4-2
               clutter-gtk-1.8.4-3  cmake-3.23.0-1  cogl-1.22.8-2  colord-gtk-0.3.0-2
               colord-gtk-common-0.3.0-2  crda-4.14-4 [removal]  cups-filters-1.28.13-1
               curl-7.82.0-2  electron15-15.5.1-1  fish-3.4.1-1  fontconfig-2:2.14.0-1
               foomatic-db-3:20220328-1  foomatic-db-nonfree-3:20220328-1
               foomatic-db-nonfree-ppds-3:20220328-1  foomatic-db-ppds-3:20220328-1
               freetype2-2.12.0-1  garuda-welcome-1.0.16-1  gcr-3.41.0-2  gegl-0.4.36-2
               geocode-glib-3.26.2+r9+g6047da3-2  ghostscript-9.56.0-1  gimp-2.10.30-2
               gnome-autoar-0.4.3-2  gnome-color-manager-3.36.0+r25+g4aab8b59-1
               gnome-firmware-42.0-1  gnome-online-accounts-3.44.0-1  google-chrome-100.0.4896.60-1
               gparted-1.4.0-1  graphicsmagick-1.3.38-1  groff-1.22.4-7  grub-2:2.06-5
               gsound-1.0.3-2  gst-plugin-pipewire-1:0.3.49-1  gwe-0.15.5-1  harfbuzz-4.2.0-1
               harfbuzz-icu-4.2.0-1  hwloc-2.7.1-1  imagemagick-7.1.0.29-1  imath-3.1.5-1
               intel-compute-runtime-22.13.22789-1  intel-gmmlib-22.1.2-1
               intel-graphics-compiler-1:1.0.10778-1  jfsutils-1.1.15-8  json-glib-1.6.6-2
               ldb-2:2.5.0-1  lib32-krb5-1.19.3-2  lib32-libva-mesa-driver-22.0.0-1
               lib32-libxml2-2.9.13-1  lib32-mesa-22.0.0-1  lib32-mesa-vdpau-22.0.0-1
               lib32-nss-3.77-1  lib32-nvidia-utils-510.60.02-1  lib32-opencl-mesa-22.0.0-1
               lib32-opencl-nvidia-510.60.02-1  lib32-util-linux-2.38-1
               lib32-vulkan-intel-22.0.0-1  lib32-vulkan-mesa-layers-22.0.0-1
               lib32-vulkan-radeon-22.0.0-1  lib32-wayland-1.20.0-2  libarchive-3.6.0-2
               libcanberra-1:0.30+r2+gc0620e4-1  libchamplain-0.12.20-3  libcurl-gnutls-7.82.0-2
               libgcrypt-1.10.1-1  libgdata-0.18.1-2  libgnomekbd-1:3.26.1+r5+g54da436-1
               libgweather-40.0+r87+g80e5a652-2  libical-3.0.14-2  libinput-1.20.0-2
               libmediainfo-22.03-1  libnma-1.8.36-3  libnma-common-1.8.36-3  libnumbertext-1.0.9-1
               libreoffice-fresh-7.3.2-1  libreoffice-fresh-it-7.3.2-1  librsvg-2:2.54.0-2
               libsoup3-3.0.6-1  libspnav-1.0-1  libstemmer-2.2.0-2  libsysprof-capture-3.44.0-1
               libtiff-4.3.0-2  libva-mesa-driver-22.0.0-1  libvirt-1:8.2.0-3
               libvirt-python-1:8.2.0-1  libwpe-1.12.0-2  libx11-1.7.4-1  libxmlb-0.3.8-1
               libxnvctrl-510.60.02-1  libxvmc-1.0.13-1  linux-lts-5.15.32-1
               linux-lts-headers-5.15.32-1  mailspring-1.10.2-1  mdadm-4.2-2  mediainfo-22.03-1
               mesa-22.0.0-1  mesa-vdpau-22.0.0-1  mhwd-db-garuda-git-1:r62.889aefa-6
               minizip-1:1.2.12-1  mobile-broadband-provider-info-20220315-1  nss-3.77-1
               nvidia-dkms-510.60.02-1  nvidia-settings-510.60.02-1  nvidia-utils-510.60.02-1
               oh-my-zsh-git-r6588.53863e7b3-1  opencl-mesa-22.0.0-1  opencl-nvidia-510.60.02-1
               opencv-4.5.5-4  pdftk-3.3.2-2  perl-5.34.1-1  perl-html-parser-3.78-1
               pipewire-1:0.3.49-1  pipewire-alsa-1:0.3.49-1  pipewire-jack-1:0.3.49-1
               pipewire-pulse-1:0.3.49-1  pipewire-v4l2-1:0.3.49-1  pipewire-zeroconf-1:0.3.49-1
               plymouth-git-22.02.122.r36.gd021553-1  pybind11-2.9.2-1  pyside2-5.15.3-3
               pyside2-tools-5.15.3-3  python-3.10.4-1  python-click-8.1.2-1  python-evdev-1.5.0-1
               python-pillow-9.1.0-1  python-py7zr-0.18.3-1  python-pyppmd-0.18.2-1
               python-reportlab-3.6.9-1  python-shiboken2-5.15.3-3  python-sqlalchemy-1.4.34-1
               re2-1:20220401-1  samba-4.16.0-4  shared-mime-info-2.0+144+g13695c7-1
               simple-scan-42.0-1  smbclient-4.16.0-4  sqlite-3.38.2-1  sushi-41.1-1
               tela-circle-icon-theme-git-2022.03.07.r31.gb62e2e22-1  util-linux-2.38-1
               util-linux-libs-2.38-1  vim-8.2.4651-1  vim-runtime-8.2.4651-1
               visual-studio-code-bin-1.66.0-1  vte-common-0.68.0-1  vte3-0.68.0-1
               vulkan-intel-22.0.0-1  vulkan-mesa-layers-22.0.0-1  vulkan-radeon-22.0.0-1
               vulkan-swrast-22.0.0-1  wayland-1.20.0-2  webkit2gtk-2.36.0-2
               webkit2gtk-4.1-2.36.0-2  wireless-regdb-2022.02.18-3  wpebackend-fdo-1.12.0-2
               xdg-desktop-portal-1.14.2-1  xorg-xwayland-22.1.1-1  xow-git-1:0.5.r34.g8b44d8f-1
               yaru-sound-theme-22.04.3.1-1  zenity-3.42.0-1  zlib-1:1.2.12-1
               zram-generator-1.1.2-1

I guess the one responsible are the graphics packages, like mesa, vulkan and nvidia. I also see that gnome-firmware is being updated to version 42, but I don't know if that has to do with anything. Is there a way to troubleshoot this? Thanks in advance for any help

What extensions do you have installed? You should disable all extensions, see if the lagginess persists, and if not then re-enable them one-by-one to see if oner of them is causing the problem.

Rather than updating all packages to the current version, pick a date in the ALA and update to that point, then repeat until you identify the specific change where the problem occurs.

(Small, frequent updates of ~10 packages are always preferable to massive monthly or bi-monthly updates of 500 packages.)

4 Likes

As mentioned, disabling/removing any installed extensions is good to check. In general, I've found this guide here on the Garuda forum very useful, and it might be relevant enough to be worth digging through. Could be something kernel or NVIDIA related, which that linked guide has some steps for.

Anecdotally, I found switching to running GNOME under Wayland not only fixed some of my issues, but also led to noticeably increased performance for GNOME. I think based on that inxi output you're already on Wayland though, but it could be worth comparing the two? That's not really based on anything though.

Worth noting that I'm on a fresh install from the latest 03/29 .iso as of today after some messy issues (mostly of my own fault) with my previous garuda-gnome install. Your system configuration is definitely different, but I am on the latest available packages and not facing performance issues.

Also, are you using any of the performance/powersave tweaks available from the Garuda Assistant? It might be worth reviewing or fiddling with those to see if they yield any particular changes.

On the specific packages front I don't think I can provide any insight. In general though, it's been my experience with the wider world of Arch and Arch-based distros that letting a system get out of date and having to do really extensive upgrades like that has the tendency to break things. Unfortunately, partial upgrades can also be bad for their own reasons, as cautioned against on the Garuda Wiki.

If I've said anything particularly incorrect here please let me know. While I'm far from new to Linux, I am relatively new to Garuda, and I'm Just dropping this here since I've done a wealth of troubleshooting on the distro over the past couple days.

5 Likes

I have tried disabling gnome extensions to no avail. As you guessed I am already using wayland and to me it seems like it usually runs better than xorg. I am however using performance tweaks since I am on a laptop, but that didn't hinder system performance until now, so I'd probably remove it from the possible causes. I will try the guide that you linked and the @jonathon suggestion of installing packages only until a certain date. In any case, if none of the above steps worked, I will probably do a fresh install. Fortunately I have all my dotfiles synced up and the garuda install process is really smooth (or at least it has been for me for the previous two times)

3 Likes