pCloud not working after recent system update

Hi there, has anyone experienced the same problem with pCloud not working any more? Is has been fine for the last few years. I couldn’t find any information on the web. I use the latest pCloud Linux version 1.14.3 (14/12/2023) and a fully updated Garuda Linux (Gnome). Here is the console output with error message:

./pcloud
QApplication: invalid style override ‘kvantum’ passed, ignoring it.
Available styles: qt5ct-style, Windows, Fusion
/tmp/.mount_pcloudg2M8MG/AppRun: line 49: /tmp/.mount_pcloudg2M8MG/pcloud: Software caused connection abort

Thank you for your help
Stephane

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

1 Like

Maybe you can post the complete garuda-inxi?
garuda-assistant / System Infos can help you.

Sorry, didn’t realise it has only copied the visible part of the output. Here is the lot:

System:
  Kernel: 6.6.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: hpet
    available: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=596af91a-fe87-415d-9545-c6711cedc266 rw rootflags=subvol=@ quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
    loglevel=3 ibt=off
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.39 wm: gnome-shell dm: GDM v: 45.0.1
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: BESSTAR TECH model: UM700 v: V1.0 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: AF5NV701.25 date: 12/15/2020
CPU:
  Info: model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen/Zen+
    note: check gen: 1 level: v3 note: check built: 2019 process: GF 12nm family: 0x17 (23)
    model-id: 0x18 (24) stepping: 1 microcode: 0x8108102
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2390 high: 3645 min/max: 1400/2300 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 1834 2: 2300 3: 3635 4: 3645 5: 1891 6: 1828
    7: 1689 8: 2300 bogomips: 36731
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series] driver: amdgpu
    v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 05:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 41.0 C
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3 compositor: gnome-shell driver:
    X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Acer KG271 G serial: <filter> built: 2021
    res: 1920x1080 hz: 75 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    surfaceless: drv: radeonsi x11: drv: radeonsi inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.2-arch1.2 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Vega 10 Graphics (radeonsi raven LLVM 16.0.6 DRM 3.54
    6.6.10-zen1-1-zen) device-ID: 1002:15d8 memory: 250 MiB unified: no
  API: Vulkan v: 1.3.274 layers: 7 device: 0 type: integrated-gpu name: AMD Radeon Vega 10
    Graphics (RADV RAVEN) driver: mesa radv v: 23.3.2-arch1.2 device-ID: 1002:15d8
    surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits)
    driver: mesa llvmpipe v: 23.3.2-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 05:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x v: kernel
    alternate: snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x,
    snd_pci_ps, snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.10-zen1-1-zen status: kernel-api tools: N/A
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session status: active
    tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa type: plugin
    2: pulseaudio-jack type: module tools: pacat,pactl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-3: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: eno1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2:2 chip-ID: 8087:0a2a class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: <filter> bt-v: 4.2 lmp-v: 8 status: discoverable: no
    pairing: no
Drives:
  Local Storage: total: 685.61 GiB used: 221.21 GiB (32.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3256B-A01 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: EDFK0S03 temp: 48.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 041 scheme: GPT
Partition:
  ID-1: / raw-size: 358.12 GiB size: 358.12 GiB (100.00%) used: 221.21 GiB (61.8%) fs: btrfs
    dev: /dev/sda3 maj-min: 8:3
  ID-2: /home raw-size: 358.12 GiB size: 358.12 GiB (100.00%) used: 221.21 GiB (61.8%) fs: btrfs
    dev: /dev/sda3 maj-min: 8:3
  ID-3: /var/log raw-size: 358.12 GiB size: 358.12 GiB (100.00%) used: 221.21 GiB (61.8%)
    fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/tmp raw-size: 358.12 GiB size: 358.12 GiB (100.00%) used: 221.21 GiB (61.8%)
    fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.33 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 40.9 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 325 Uptime: 18m wakeups: 0 Memory: total: 16 GiB note: est. available: 15.33 GiB
  used: 3.41 GiB (22.2%) Init: systemd v: 255 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: pm: pacman pkgs: 1749 libs: 534 tools: octopi,paru
  pm: flatpak pkgs: 0 Client: shell wrapper v: 5.2.21-release inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2021-03-26
  Last full system update: 2024-01-08
  Is partially upgraded:   No
  Relevant software:       timeshift NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:            

Sounds like an environment variable issue.
Any change you made to your Styles or env var?
Any package got updated at the same time as pCloud that have an effect on Styles? Not easy to find out but at least looking is a good start.

What if you start pCloud with

 QT_STYLE_OVERRIDE="" pcloud
1 Like

I don’t think it has to do with the styles. I run QT_ST… first and it will omit the style error, but the connection abort still persists.

~/Applications  QT_STYLE_OVERRIDE=“”
~/Applications  ./pcloud
/tmp/.mount_pcloudT2SE5w/AppRun: line 49: /tmp/.mount_pcloudT2SE5w/pcloud: Software caused connection abort

Please :slight_smile:

~/Applications  QT_STYLE_OVERRIDE=“”
~/Applications  ./pcloud
/tmp/.mount_pcloudT2SE5w/AppRun: line 49: /tmp/.mount_pcloudT2SE5w/pcloud: Software caused connection abort

Sorry :flushed:

1 Like

Is this the package you installed?

If yes, when did it stop working? On the day you installed that version number or later on?

I don’t understand this!? I couldn’t find this pCloud-Drive entry in octopi.
For years I have always downloaded pCloud directly from their website and updated to the latest version through the update option in the app.
I only downloaded the latest version a few hours ago and it didn’t launch. Now I have downloaded it again and it works !?!?!
How can I make pcloud-drive visible in octopi. I guess it’s a special repository. Would it be better to use the version on the Arch Repository?
Thanks so much for your help.

PS: it’s now 1.14.3

1 Like

Its in chaotic -aur as -git, just use pacman !!!

╰─λ paru -Ss pcloud-drive
aur/pcloud-drive 1.14.3-2 [+76 ~1.87]
pCloud drive. Electron edition.

You could ask to integrate it in Chaotic-Aur repo as this would prevent it from being built directly on your machine on every update.

Or you could just install it from AUR repo in Terminal

paru -S pcloud-drive

But since now you say it works, maybe you should leave things put and don’t break your running system.

Not sure it’s the same package as pcloud-drive?

chaotic-aur/pcloudcc-git r1471.4b42e3c-1 [1.18 MiB 2.64 MiB]
A simple linux console client for pCloud cloud storage.

But anyway, if his system is working now I think it’s better to leave it running as is.

1 Like

Yes, I agree. It’s getting a bit confusing now. I don’t want to install the client but just the drive. As it is working will now with the downloaded version I will keep it as that.

You are great and thanks for all your help and dedication.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.