Path of Exile says that my GPU is RX480 instead of actual RX580

Hi everyone! My first post on this forum.
So the problem is that MHWD detects my GPU as GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590. But when I start for example Path of Exile, the game says that my GPU is RX480 instead of my actual RX580.
Is this a real problem or I should forget about it?
Here's my inxi -Fxxxza:

System:    
Kernel: 5.12.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=333e437c-76ce-4dce-a52d-2e50d5722f18 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: B450 GAMING X v: x.x serial: <filter> 
UEFI: American Megatrends LLC. v: F61a date: 03/29/2021 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
model-id: 71 (113) stepping: 0 microcode: 8701021 cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 91031 
Speed: 2554 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 2554 2: 2717 
3: 2699 4: 2632 5: 2708 6: 2912 7: 2485 8: 2717 9: 2503 10: 2685 11: 2762 12: 2786 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: ASUSTeK 
driver: amdgpu v: kernel bus-ID: 07:00.0 chip-ID: 1002:67df class-ID: 0300 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu 
note: n/a (using device driver) display-ID: :0 screens: 1 
Screen-1: 0 s-res: 3840x1920 s-dpi: 96 s-size: 1013x506mm (39.9x19.9") s-diag: 1132mm (44.6") 
Monitor-1: HDMI-A-0 res: 1920x1080 dpi: 102 size: 476x268mm (18.7x10.6") diag: 546mm (21.5") 
Monitor-2: HDMI-A-1 res: 1080x1920 hz: 60 
OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0 5.12.6-zen1-1-zen LLVM 11.1.0) 
v: 4.6 Mesa 21.1.1 direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: ASUSTeK 
driver: snd_hda_intel v: kernel bus-ID: 07:00.1 chip-ID: 1002:aaf0 class-ID: 0403 
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403 
Sound Server-1: ALSA v: k5.12.6-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 
v: kernel port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.94 TiB used: 247.03 GiB (12.5%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Smartbuy model: m.2 PS5013-2280T 128GB 
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
rotation: SSD serial: <filter> rev: EDFM00.5 scheme: GPT 
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPSX-00A6WT0 size: 931.51 GiB 
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
rev: 1A01 scheme: GPT 
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB 
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
rev: 1A02 scheme: GPT 
Partition: ID-1: / raw-size: 39.24 GiB size: 39.24 GiB (100.00%) used: 21.92 GiB (55.9%) fs: btrfs 
dev: /dev/nvme0n1p5 maj-min: 259:5 
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.7 MiB (26.7%) fs: vfat 
dev: /dev/nvme0n1p1 maj-min: 259:1 
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 225.09 GiB (24.2%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/log raw-size: 39.24 GiB size: 39.24 GiB (100.00%) used: 21.92 GiB (55.9%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 39.24 GiB size: 39.24 GiB (100.00%) used: 21.92 GiB (55.9%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.3 GiB used: 129 MiB (9.7%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.3 GiB used: 131.7 MiB (9.9%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.3 GiB used: 135.8 MiB (10.2%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.3 GiB used: 137 MiB (10.3%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 1.3 GiB used: 128.6 MiB (9.6%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 1.3 GiB used: 134.9 MiB (10.1%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 1.3 GiB used: 130.3 MiB (9.8%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 1.3 GiB used: 128.6 MiB (9.6%) priority: 32767 dev: /dev/zram7
ID-9: swap-9 type: zram size: 1.3 GiB used: 129.5 MiB (9.7%) priority: 32767 dev: /dev/zram8
ID-10: swap-10 type: zram size: 1.3 GiB used: 137.2 MiB (10.3%) priority: 32767 dev: /dev/zram9
ID-11: swap-11 type: zram size: 1.3 GiB used: 126.5 MiB (9.5%) priority: 32767 dev: /dev/zram10
ID-12: swap-12 type: zram size: 1.3 GiB used: 136.9 MiB (10.3%) priority: 32767
dev: /dev/zram11
Sensors:   System Temperatures: cpu: 44.6 C mobo: 16.8 C gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1163
Info:      Processes: 407 Uptime: 3h 06m wakeups: 0 Memory: 15.63 GiB used: 5.99 GiB (38.3%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1821 lib: 554
Shell: fish v: 3.2.2 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.04

It's detecting the class of card, so you can ignore it.

Also, PoE uses Proton so there's an extra layer between the game and the OS.

2 Likes

Mine says that too. I think it's RADV that doesn't know the exact model, just the series. I have 590. I think it's that the driver is more generic in Linux than on Windows, could be that it has the same driver for all 500 series.

But it knows it's RX 580 on output:

OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0 5.12.6-zen1-1-zen LLVM 11.1.0)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.