Partition slowly stops reading

Hello, I've been using Garuda for maybe a month now, and a problem which has been prevalent from the beginning is that a partition on my secondary drive (/mnt/Storage - /dev/sda2) slowly stops reading over a few hours. I have the partition mounted on boot using the Gnome Disks program, and the partition works fine and is readable at the start, but a few hours later I notice that it no longer reads much data on the disk and only displays some of the folders which were on the drive but clicking them will show only a few files, I'm assuming maybe only previously cached directories and files are shown? Eventually, it stops reading all together and I receive an input/output error number 5 when trying to access through Dolphin.

I've tried unmounting and then mounting again but after unmounting, Gnome Disks just says the partition type is unknown and doesn't let me mount it again. If I try using sudo mount /dev/sda2 /mnt/Storage I receive the following error: mount: /mnt/Storage: can't read superblock on /dev/sda2.

The partition worked completely fine on Windows as well as a different Arch based distro before I moved to Garuda.

System:
Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=05d5d275-9d5d-4068-972e-e3a74cc04a7d loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: LENOVO product: 3227AC4 v: ThinkCentre M92p
serial: <superuser required> Chassis: type: 3 serial: <superuser required>
Mobo: LENOVO model: MAHOBAY serial: <superuser required> UEFI: LENOVO
v: 9SKT99AUS date: 06/30/2017
CPU:
Info: model: Intel Core i5-2400 bits: 64 type: MCP arch: Sandy Bridge
family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 2027 high: 2800 min/max: 1600/3400 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2800 2: 1710 3: 1676
4: 1923 bogomips: 24744
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ASUSTeK driver: nvidia
v: 470.94 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:128b
class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7")
s-diag: 554mm (21.8")
Monitor-1: VGA-0 res: 1920x1080 hz: 60 dpi: 102
size: 476x268mm (18.7x10.6") diag: 546mm (21.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e0f
class-ID: 0403
Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e
v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.24 TiB used: 834.01 GiB (65.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWD110
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A8R0
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: SK Hynix model: HFS120G32TND-N1A2A
size: 111.79 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0P10 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WDS240G2G0A-00JH30 size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 0400
scheme: GPT
Partition:
ID-1: / raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 49.05 GiB (47.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 49.05 GiB (47.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 49.05 GiB (47.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 49.05 GiB (47.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
ID-2: swap-2 type: zram size: 7.69 GiB used: 3.82 GiB (49.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.0 C mobo: 27.8 C gpu: nvidia temp: 63 C
Fan Speeds (RPM): N/A
Info:
Processes: 268 Uptime: 11h 4m wakeups: 0 Memory: 7.69 GiB
used: 6.28 GiB (81.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1522 lib: 457 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

It sounds as if the drive could be in a pre-failure state (or it may simply have correctable errors). How old is this hard drive? As it is 1 TB platter drive (from the looks of your inxi) it may be getting close to end of life. Even if the results of the test say "passed" the drive can start creating problems in its end stage before a failure actually occurs. Do not assume that just because a drive was not having issues on Windows that the drive cannot be the problem on Linux. Windows and Linux can behave very differently with borderline hardware.

I would suggest installing smartmon and running diagnostic tests on the drive.

Also please post your fstab entries:

cat /etc/fstab

What file system is in use on the problematic partition? Please post your full drive information:

sudo blkid -o list

Strange as it may sound, I would suggest testing out some alternate kernels. I would also suggest searching your logs for any I/O errors.

Welcome to the forum BTW.

3 Likes

4 Likes

I'm unsure about the age of the drive, it's from a pre-built PC which had some really old hardware to begin with so you may be right about the pre-failure state.

I'm unsure if this is what you meant by diagnostics but here's the SMART status of the drive:

smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.15.11-zen1-1-zen] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     Toshiba P300
Device Model:     TOSHIBA HDWD110
Serial Number:    59396U6FS
LU WWN Device Id: 5 000039 fdae05fec
Firmware Version: MS2OA8R0
User Capacity:    1,000,204,886,016 bytes [1.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Form Factor:      3.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Thu Dec 30 22:39:09 2021 GMT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x84)	Offline data collection activity
					was suspended by an interrupting command from host.
					Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		( 7264) seconds.
Offline data collection
capabilities: 			 (0x5b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					command.
					Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   1) minutes.
Extended self-test routine
recommended polling time: 	 ( 121) minutes.
SCT capabilities: 	       (0x003d)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   094   094   016    Pre-fail  Always       -       786447
  2 Throughput_Performance  0x0005   143   143   054    Pre-fail  Offline      -       66
  3 Spin_Up_Time            0x0007   115   115   024    Pre-fail  Always       -       199 (Average 199)
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       3975
  5 Reallocated_Sector_Ct   0x0033   084   084   005    Pre-fail  Always       -       447
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   110   110   020    Pre-fail  Offline      -       36
  9 Power_On_Hours          0x0012   100   100   000    Old_age   Always       -       5806
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       2968
192 Power-Off_Retract_Count 0x0032   096   096   000    Old_age   Always       -       4914
193 Load_Cycle_Count        0x0012   096   096   000    Old_age   Always       -       4914
194 Temperature_Celsius     0x0002   230   230   000    Old_age   Always       -       26 (Min/Max 16/39)
196 Reallocated_Event_Count 0x0032   067   067   000    Old_age   Always       -       761
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

fstab entries:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=16B0-B4D6                            /boot/efi      vfat    umask=0077 0 2
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /              btrfs   subvol=/@,default
s,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /home          btrfs   subvol=/@home,def
aults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /root          btrfs   subvol=/@root,def
aults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /srv           btrfs   subvol=/@srv,defa
ults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /var/cache     btrfs   subvol=/@cache,de
faults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /var/log       btrfs   subvol=/@log,defa
ults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a3e426c7-a9dc-4788-8231-e69d5ccee7b3 /var/tmp       btrfs   subvol=/@tmp,defa
ults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=05d5d275-9d5d-4068-972e-e3a74cc04a7d swap           swap    defaults,noatime 
0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,
mode=1777 0 0
LABEL=Storage /mnt/Storage auto nosuid,nodev,nofail,x-gvfs-show 0 0

The file system on the partition is NTFS, here's the full drive information:

device      fs_type label    mount point     UUID
---------------------------------------------------------------------------------
/dev/sdb2   btrfs            (in use)        a3e426c7-a9dc-4788-8231-e69d5ccee7b3
/dev/sdb3   swap    swap     [SWAP]          05d5d275-9d5d-4068-972e-e3a74cc04a7d
/dev/sdb1   vfat    NO_LABEL /boot/efi       16B0-B4D6
/dev/sdc2   vfat             (not mounted)   E654-8510
/dev/sdc3                    (not mounted)
/dev/sdc1   ntfs    Recovery (not mounted)   86F4522CF4521EAD
/dev/sdc4   ntfs             (not mounted)   504E639C4E637A1C
/dev/sda2   ntfs    Storage  /mnt/Storage    BEC25E57C25E13CD
/dev/sda3   btrfs            (not mounted)   2760d785-3b00-451d-8ff2-0c972fa073ab
/dev/sda1   ntfs    System Reserved (not mounted) 1E56A91056A8E9AB
/dev/zram0  swap    zram0    [SWAP]          44d7d03f-dada-4db3-b677-d01ce00630a1

Thank you!

Ah yes, first thing tomorrow morning :grimacing:

Hi there, welcome to the community.

I had similar issue with my hard drive, and it indeed eventually failed. I ended up buying new ssd.

But for my hdd, the issue was there with all operating systems, and not limited to one.
So first of all, boot into other operating system and try. I guess it should show similar behavior there too.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.