Panel system tray not working

Another issue after update… Some application icons that used to minimize and run in background not showing in the tray like they used to… Also when attempting to expand the tray it does not show expansion menu

Please advise

  Kernel: 6.8.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=86610dfc-7685-4c6a-95b3-2ae213cf3d58 rw rootflags=subvol=@ quiet
    resume=/dev/mapper/luks-e4abcb24-e541-4f0e-956a-bfa10df8475b loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
  Type: Laptop System: Acer product: Predator PH315-52 v: V1.12 serial: <superuser required>
    Chassis: type: 10 serial: <superuser required>
  Mobo: CFL model: Covini_CFS v: V1.12 serial: <superuser required> part-nu: 0000000000000000
    uuid: <superuser required> UEFI: Insyde v: 1.12 date: 07/28/2020
  ID-1: BAT0 charge: 39.2 Wh (100.0%) condition: 39.2/39.2 Wh (100.0%) volts: 16.4 min: 15.4
    model: SMP KT00407009 AP18E7M type: Li-ion serial: <filter> status: full
  Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3999 high: 4001 min/max: 800/4100 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4000 2: 4000 3: 3998 4: 4001 5: 4000 6: 4000 7: 4000 8: 3995
    bogomips: 38400
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: DP-2,
    DP-3, DP-4, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Acer Incorporated ALI driver: nvidia
    v: 550.76 alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04;
    EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: none empty: DP-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1f11 class-ID: 0300
  Device-3: Quanta HD User Facing driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 1-7:3 chip-ID: 0408:a061 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.6 compositor: kwin_wayland
    driver: X: loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
    gpu: i915,nvidia display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: iris device: 3 drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: iris x11:
    drv: iris inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.5-arch1.1 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL GT2) device-ID: 8086:3e9b
    memory: 30.45 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 10 device: 0 type: integrated-gpu name: Intel UHD Graphics 630
    (CFL GT2) driver: mesa intel v: 24.0.5-arch1.1 device-ID: 8086:3e9b surfaces: xcb,xlib,wayland
    device: 1 type: discrete-gpu name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.76
    device-ID: 10de:1f11 surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
    17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.5-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348
    class-ID: 0403
  Device-2: NVIDIA TU10
6 High Definition Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f9 class-ID: 0403
  API: ALSA v: k6.8.7-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Acer Incorporated ALI
    driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 08:00.0
    chip-ID: 1969:e0b1 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer driver: iwlwifi v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp9s0 state: up mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-14:4 chip-ID: 8087:0029 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
    hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11 status: discoverable: no
    pairing: no
  Local Storage: total: 3.72 TiB used: 85.86 GiB (2.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Fanxiang model: S790 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: SN13683 temp: 37.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Asgard model: AN3 1TNVMe-M.2 80 size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 42A7T36A temp: 32.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: A3J0 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Chipsbank model: ChipsBnk Flash size: 58.94 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0
    tech: SSD serial: <filter> fw-rev: 5.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 919.26 GiB size: 919.26 GiB (100.00%) used: 34.99 GiB (3.8%) fs: btrfs
    dev: /dev/dm-0 maj-min: 254:0 mapped: luks-5318fdb5-0d15-4992-8460-566ef494dc78
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 728 KiB (0.2%) fs: vfat
    dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-3: /home raw-size: 919.26 GiB size: 919.26 GiB (100.00%) used: 34.99 GiB (3.8%) fs: btrfs
    dev: /dev/dm-0 maj-min: 254:0 mapped: luks-5318fdb5-0d15-4992-8460-566ef494dc78
  ID-4: /var/log raw-size: 919.26 GiB size: 919.26 GiB (100.00%) used: 34.99 GiB (3.8%) fs: btrfs
    dev: /dev/dm-0 maj-min: 254:0 mapped: luks-5318fdb5-0d15-4992-8460-566ef494dc78
  ID-5: /var/tmp raw-size: 919.26 GiB size: 919.26 GiB (100.00%) used: 34.99 GiB (3.8%) fs: btrfs
    dev: /dev/dm-0 maj-min: 254:0 mapped: luks-5318fdb5-0d15-4992-8460-566ef494dc78
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 34.3 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
    maj-min: 254:1 mapped: luks-e4abcb24-e541-4f0e-956a-bfa10df8475b
  ID-2: swap-2 type: zram size: 31.19 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 51.0 C pch: 54.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 32 GiB available: 31.19 GiB used: 4.16 GiB (13.4%)
  Processes: 306 Power: uptime: 24m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: 
shutdown, reboot, suspend, test_resume image: 12.43 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 2164 libs: 596 tools: octopi,paru Compilers: clang: 17.0.6
    gcc: 13.2.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-04-21
  Last full system update: 2024-04-21 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            


Should be expanding to show networks, sound options, etc, but its not anymore

When i select an icon it seems to do something but its not showing correctly like it supposed to… Something with the graphics?

So I just backed up what I needed and reinstalled the desktop environment… It worked ok again after reinstall… but after system update goes back to same problem… Bullshit!!

Though mine is hardwired instead of WiFi, it works just fine for me for all systray icons. Back up your stuff and try and reinstall as something may have gotten wonky in your configs.

Edit: Mine just looks different because I have a different global theme applied. I am also updated as of this post, so it shouldn’t be different if you’re updated as well.

Before you do a full reinstall, reboot and try again. That’s what that symbol on the end means.


Works fine here, try X11


Right click on the panel, select “Enter Edit Mode” and remove the “System Tray”. Then add the “System tray” widget again.

If that doesn’t work, then remove the whole panel and recreate it.

I dont get it… It worked ok 2 days ago… I tried all the suggestions above so far with no luck

I did notice if i change theme with desktop and layout checked off, it will work ok, But if I go back to dragonized theme and layout (my favorite) it has the same glitch

OK, after changing the theme with desktop and window layout checked option off a few times it seems to just work again… so frustrating
Thanks all

Update: Still have some icons not minimizing to the tray when running in the backgroung like syncthing and veracrypt… they still run in the background and work ok, but their icons dont show up in the tray like they used to before the recent update, not as big of a problem but still an issue

If the problem occurs again, try making the changes step by step so you can find out what is causing the issue:

I just tested veracrypt in a vm and can reproduce the behavior you described, the icon is no longer displayed in the top panel.

I could reproduce the behavior, with both Dragonized and Breeze. Switching to X11 solved it for me.

Whenever I make any system changes I usually try to go step by step. And thats what i did this time… I literally just changed the theme with both options checked and tested each time and after a few theme switches it just works again like it used to, except veracrypt and syncthing background tray icons still not showing in the tray like they should

Are they by chance deactivated in the controlpanel of the tray?

After switching the themes the tray seemed to work ok again, minus a couple background apps not showing the icons in the tray… So i tested x11 always on and it made no difference for me.
And no, the syncthing icon and veracrypt icon still not showing in tray or in tray options like they used to, they still run in the background tho… Other apps i run in background show there, just those couple acting weird

Seeing the same issue with latest Test ISOs. Also not able to see wifi networks when using system settings to connect.

Have you tried replacing the system tray? Like removing the widget an adding it back. For things in the background have you Right clicked on the tray down arrow an hit “Configure System Tray” then do this for the items you want shown

It might help just to manually make the panel as well


the tray, clock and others are under “Add Widgets” just drag them over might need to add a spacer as well so it sits to the side, can also use the garuda top panel as well


Ya I actually messed around with all those settings… some background running apps just dont show and arent listed in those settings… they used to a few days before I made this post… so far I have syncthing, veracrypt and virtual machine manager icons not showing up in the tray and tray settings, but they are still running in the background… Even when I choose the option to show all entries, no icons or options for those few

1 Like

Looks like the whole thing is very buggy right now:


This also happened to me before Garuda’s latest release in another distro and system and then it came up to Garuda yesterday evening. I applied the same solution, added a new panel replacing the most similar look and feel with the DEs, and this did good in both distro tray panel incidents.