Pamac stuck: Syncing all file systems

Pamac keeps freezing when trying to install packages. I even backed up my home directory and tried a clean install just to see if it would happen again to no avail. No consistency in packages. could my ssd be failing?

System:
  Kernel: 5.16.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e5909ed7-d633-480d-9d75-9c33cf303423 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: G7 7790 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0CNDTP v: A02 serial: <superuser required> UEFI: Dell
    v: 1.15.3 date: 06/04/2021
Battery:
  ID-1: BAT0 charge: 58.0 Wh (100.0%) condition: 58.0/60.0 Wh (96.7%)
    volts: 16.9 min: 15.2 model: BYD DELL HYWXJ9B type: Li-poly
    serial: <filter> status: Full
  ID-2: hidpp_battery_0 charge: 89% condition: N/A volts: 4.1 min: N/A
    model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
    serial: <filter> status: Discharging
CPU:
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4397 high: 4401 min/max: 800/4500 scaling:
    driver: intel_pstate governor: performance cores: 1: 4401 2: 4394 3: 4401
    4: 4401 5: 4400 6: 4400 7: 4401 8: 4384 9: 4400 10: 4388 11: 4400
    12: 4401 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:1f11 class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:7 chip-ID: 0c45:671f class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.3 compositor: gnome-shell driver:
    loaded: modesetting,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6810x1680 s-dpi: 96 s-size: 1802x445mm (70.9x17.5")
    s-diag: 1856mm (73.1")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 128
    size: 381x214mm (15.0x8.4") diag: 437mm (17.2")
  Monitor-2: DP-1 res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.9x11.8") diag: 609mm (24")
  Monitor-3: HDMI-1-0 res: 1920x1080 hz: 120 dpi: 30
    size: 1600x900mm (63.0x35.4") diag: 1836mm (72.3")
  Monitor-4: DP-1-0 res: 1050x1680
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:3 chip-ID: 0951:16a4
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.16.9-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek vendor: Dell driver: r8169 v: kernel port: 3000
    bus-ID: 3c:00.0 chip-ID: 10ec:2502 class-ID: 0200
  IF: enp60s0 state: down mac: <filter>
  Device-2: Intel Wireless-AC 9260 vendor: Rivet Networks driver: iwlwifi
    v: kernel bus-ID: 3d:00.0 chip-ID: 8086:2526 class-ID: 0280
  IF: wlp61s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 1-14:9 chip-ID: 8087:0025 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 942.7 GiB used: 91.84 GiB (9.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
    temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 3B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 91.84 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 91.84 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 91.84 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 91.84 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.44 GiB used: 2.5 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 52.0 C pch: 69.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 339 Uptime: 32m wakeups: 9 Memory: 15.44 GiB
  used: 3.31 GiB (21.4%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1359 lib: 351 Shell: fish
  v: 3.3.1 running-in: gnome-terminal inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-02-16
  Last full system update: 2022-02-16
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            

Which packages? If it's something from the AUR that needs to be compiled then it will take some time to complete the process.

I'd also try with pacman to rule out Pamac as the cause.

This might indicate a disk issue, but that should also show up in dmesg or journalctl. You can also check disk health with smartctl.

3 Likes

Smartctl doesn't turn up anything bad. So it's pamac being weird? Any way to figure out why? I'm assuming this should be fixed at some point because this is a clean install and pamac should be working. it's hanging on aur and chaotic-aur packages. I'm talking hours no output kinda freeze

** (pamac:4672): CRITICAL **: 20:49:24.634: pamac_transaction_clone_build_files_if_needed: assertion 'pkgname != NULL' failed

I keep getting this whenever a package needs to be built

Use pacman (octopi, yay) as recommended by Garuda Linux or write a bug report to pamac.
Garuda Linux has no control over this app.

5 Likes

That was an easy thing to search on the internet :wink:.There are sites reporting the problem. E.g.

Being pamac a Manjaro tool the source to follow should be:

4 Likes

seriously, Garuda is Arch without the hard work of configuring it, and as with any Arch flavour, pacman and yay at the terminal are easy to learn, an awful lot faster , and much much less likely to run into such issues as pamac has had over the last day with aur. Pacman is the Arch linux package manager, pamac is a gui overlay for clickability purposes (from Manjaro folks i think) and hence puts another step in the process.

6 Likes

if you havent resolved yet: i have opened a thread days and days ago and a user kindly told a workaround:

  • in the pamac gui disable the AUR support
  • sudo pacman -S yay
  • yay -S 'the-aur-package-name'

this will solve your issues

EDIT:
Thanks again to @Gavin

Using pacman (and yay/paru for AUR packages) is a good approach generally. :wink:

6 Likes

There is a reason why we no longer recommend using pamac to update. The reason for that is because of pamac's propensity towards a complete failure to work on a regular basis.

The terminal is the most reliable and recommended method to update your system.

6 Likes

Pamac is the most disappointing program ever built for Linux in my opinion. I would never again use it or suggest anyone to use it. It's a failure of epic proportions. I would strongly encourage you to dump it like a bad girlfriend and learn the few update/install/remove commands. You'll be so much happier in the end.

2 Likes

I would never use pamac to update or install aur packages but do like it for search for programs and info as I'm lazy.
Learn how to use pacman to do everything, then worry about short cuts later.

3 Likes

do you have any suggestion?!

Absolutely. I would always strongly encourage everyone using an Arch based distro, to update via pacman. For AUR - I like yay, but I know Garuda ships with paru - both are fine.

https://wiki.archlinux.org/title/Pacman/Rosetta

5 Likes

Been using baph by natemaia for sometime now and think I'll stick with it.

3 Likes

I see pamac has been updated and the lib as well.

Although I agree with other here that recommend using pacman + yay/paru (or my favorite pikaur) from the command line, if you must use a graphical package manager, bauh seems to be far more stable than pamac. It also seems to be excruciatingly slow, but it doesn't seem to catastrophically fail periodically like Pamac. You might give it a try.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.