Pamac not showing packages from AUR or chaotic-aur

I have been using pamac-flatpak, the GUI for pacman, ever since I moved to Garuda, but recently I am not seeing packages from the AUR, or chaotic-aur

I have tried reinstalling, and switching to pamac-aur, but nothing seems to help

I also faintly recall there being an “All” section in pamac, but I don’t see that there anymore either

Is anyone else having this issue?

System:
  Kernel: 6.8.9-x64v-xanmod1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod
    root=UUID=30342c7e-f5f2-4539-b072-b8c3e5701d39 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.41 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: 1: GDM v: 46.0 note: stopped 2: SDDM
    Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: B550 Phantom Gaming 4/ac
    serial: <superuser required> uuid: <superuser required> UEFI: American
    Megatrends LLC. v: P2.20 date: 02/24/2022
Battery:
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A
    status: N/A
CPU:
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3800 min/max: 2200/4850 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 3800 2: 3800 3: 3800
    4: 3800 5: 3800 6: 3800 7: 3800 8: 3800 9: 3800 10: 3800 11: 3800 12: 3800
    13: 3800 14: 3800 15: 3800 16: 3800 bogomips: 121371
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 550.78 alternate: nvidiafb,nouveau,nvidia_drm
    non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: none off: DP-1,HDMI-A-1 empty: DP-2,DP-3 bus-ID: 06:00.0
    chip-ID: 10de:2482 class-ID: 0300
  Device-2: Microdia Dual Mode Camera (8006 VGA) driver: hid-generic,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-1:2
    chip-ID: 0c45:8006 class-ID: 0301
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.7
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3520x1152 s-dpi: 96 s-size: 931x305mm (36.65x12.01")
    s-diag: 980mm (38.57")
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: primary,top-left
    model: Sceptre K25 built: 2022 res: 1920x1080 dpi: 90 gamma: 1.2
    size: 543x302mm (21.38x11.89") diag: 621mm (24.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: bottom-r
    model: HP V20 serial: <filter> built: 2021 res: 1600x900 hz: 60 dpi: 94
    gamma: 1.2 size: 432x240mm (17.01x9.45") diag: 501mm (19.7") ratio: 16:9
    modes: max: 1600x900 min: 640x480
  Monitor-3: Unknown-1 mapped: None-1-1 note: disabled size-res: N/A
    modes: 1920x1080
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3070 Ti/PCIe/SSE2
    memory: 7.81 GiB
  API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3070 Ti driver: nvidia v: 550.78 device-ID: 10de:2482
    surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 06:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.8.9-x64v-xanmod1-1 status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 05:00.0
    chip-ID: 8086:24fb class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
  IF-ID-1: eth0 state: down mac: <filter>
  IF-ID-2: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5.1:6 chip-ID: 0bda:8771
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
  Local Storage: total: 4.55 TiB used: 860.56 GiB (18.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-00BBHA0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 QVO 4TB
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 1.2 TiB size: 1.2 TiB (100.00%) used: 860.53 GiB (70.1%)
    fs: btrfs dev: /dev/sdb5 maj-min: 8:21
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 28.1 MiB (29.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 1.2 TiB size: 1.2 TiB (100.00%)
    used: 860.53 GiB (70.1%) fs: btrfs dev: /dev/sdb5 maj-min: 8:21
  ID-4: /var/log raw-size: 1.2 TiB size: 1.2 TiB (100.00%)
    used: 860.53 GiB (70.1%) fs: btrfs dev: /dev/sdb5 maj-min: 8:21
  ID-5: /var/tmp raw-size: 1.2 TiB size: 1.2 TiB (100.00%)
    used: 860.53 GiB (70.1%) fs: btrfs dev: /dev/sdb5 maj-min: 8:21
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
    zswap: no
  ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 45.1 C mobo: N/A gpu: nvidia temp: 53 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
  Memory: total: 32 GiB available: 31.27 GiB used: 5.36 GiB (17.1%)
  Processes: 484 Power: uptime: 27m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.45 GiB services: gsd-power,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1843 pm: pacman pkgs: 1761 libs: 529 tools: octopi,paru
    pm: flatpak pkgs: 82 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
    default: fish v: 3.7.1 running-in: gnome-terminal inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-05-05
  Last full system update: 2024-05-16 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

No, we do not use pamac.
Use pacman in the terminal and best is to use

garuda-update

We recommnad to use pamac and octopi only for searching.

For any help it is the best way to ask the developer.

2 Likes

No, we do not use pamac.

I know this isn’t recommended for Garuda, but is there a specific reason why? It seems to be doing the job just fine until recently

We recommnad to use pamac and octopi only for searching.

I am considering this. The GUI is lacking compared to pamac but at least it finds packages

These GUIs work with pacman but always cause errors. Please search the WWW yourself.
As already said, ask the manufacturer, we do not provide support for this app.

2 Likes

I asked here because:

  • I spent hours searching for something on Google, but I couldn’t find anything even somewhat related. Pamac isn’t widely used in the arch community (they stick to terminal, which I do understand), much less pamac-flatpak or pamac-all.

  • The GitLab repo is closer linked to Manjaro but does manual approval for account registrations (I do not already have an account)

  • I figured at least one person in here might use pamac and see this

Anyway, I did happen to find one solution (through a frustrating, ill-advised conversation with ChatGPT):

mv ~/.config/pamac ~/.config/pamac_backup

This told me nothing until I realized that pamac had managed to set the software_mode parameter to true (it should be false), which seems to filter out AUR and chaotic-aur for some reason

Octopi looks nice as well though, although there doesn’t seem to be image support for app previews and stuff

Anyways, on the off-chance that someone’s using pamac with Garuda, and had this issue, this is the solution

If I were me and needed a “GUI” I’d use pacseek

4 Likes

Sorry @crypti1c , but you could just as well ask why someone uses pamac/octopi even though they are often error-prone. The syntax of pacman is really not rocket science.
Or like @fbodymechanic wrote use pacseek instead.

2 Likes

I use terminal / garuda-update (-a) and paru but I do use the GUI (Octopi) just to look at certain info sometimes (no actual package management). I actually installed pacseek as a backup in case the GUI package manager ever breaks.

3 Likes

You’re right, there is more potential for error. I’ve had to manually roll back certain packages either through terminal or Snapper before. That being said, I moved to Linux from Windows and every other distro has a GUI for their respective package managers, so I just stayed used to that

And to reply to @fbodymechanic, pacseek looks sick! Actually for a bit I tried to make my own little GUI for pacman, but I quickly realized that even with help it’s very very complicated making something that looks decent and can handle packages, dependencies, installs/uninstalls, etc etc…

First of all, I don’t want to attack you, I just want to give a bit food for thought.

This is the curse that operating systems from MS (or e.g. Mint etc.) leave behind for many users after years of use.
For decades, every little thing was hidden from users behind a supposedly great GUI. One could argue that they did this simply to offer the user more comfort. But you could also argue that many things are deliberately hidden to make it almost impossible for the average user to change anything. Or it takes a lot of time to read and/or various tools.

When I switched my computers to Linux about 15 years ago (my first experience was with SUSE 5.0, so much longer ago), I too was looking for GUIs for all kinds of crap. Back then, there were far fewer of these tools than today. At some point, I thought I had to learn if I wanted to know what was going on in my system and I didn’t want to ask someone for every little problem. This also applies to things like not opening the graphical file manager as root, but simply using the console. I claim that it doesn’t take an hour to learn the most necessary things. Everything else comes with time. You don’t sit there for 2 weeks at a time to learn, it’s an ongoing process. New little things are constantly being added and you become less dependent on superfluous GUIs and help from others.

Don’t get me wrong, GUIs can be a great thing and for some things they are almost indispensable. Who wants to make all possible settings in the e.g. KDE Settings Manager on foot in dozens of configuration files?
But there are rudimentary things for which a console is the only right choice. Then there is efficiency. By the time I have called up pamac, it is started, I clicked on update, the console has been downloading for a long time.

If people come from the windows world, they often have the wrong mindset.
Pacseek looks sick? From the point of view of a modern, visually enhanced system, that may be true. But is it really the most important thing how it looks? More appearance than reality, like pamac/octopi? For me, function always comes before any visual design. As you have seen for yourself, the beautiful pamac has done rather unsightly things to your system. Pacseek looks like a tool from the 80s? Yep, maybe, but fu** it, it does what it’s supposed to do and it does it really well.

2 Likes

looks-good-to me

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.