Pamac GUI and other minor issues

Hello, lads!

First post here, so be kind :stuck_out_tongue_winking_eye: Anyways, I am generally new to Linux. I've been getting a lot better lately and I actually regret not "dipping my toes" earlier, as that would have gotten me pretty far by now.

I've been distrohopping a bit earlier before settling for Manjaro (Arch and its' derivatives are dope) because I'm not too comfortable with switching to Arch quite yet. I saw your distro and I have to admit that I fell in love at first sight. I've tried to install several flavours of it and I liked the Wayfire edition (I wanted to install it on my laptop, but it was too buggy) but I always fall back to Xfce.

Anyways, long story short: I installed Garuda on my laptop but I managed to bork my first install right after I got a little carried away and went kinda nuts on the configuration. I suspect that what went wrong in the first installation was that I activated GDM Wayland, because when I tried to launch garuda-settings-manager through the terminal, it kept telling me that qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found. I tried to google for it and found the environment variables in the Arch wiki but I really don't know what to do with that information.

The issue I'm experiencing now is that the package list doesn't show up in the pamac-gui... I can search for packages and all, but there isn't anything to browse - is this some kind of bug? Is there any way to fix this?

Also, I wanted to give you a heads up that the link to terminal launcher in the dock is broken :slight_smile:

-Cheers and keep up the good work!


A workaround

sudo zcat /usr/share/app-info/xmls/community.xml.gz | sed 's|<em>||g;s|<\/em>||g;' | gzip > "new.xml.gz"
sudo cp new.xml.gz /usr/share/app-info/xmls/community.xml.gz
sudo appstreamcli refresh-cache --force

Thanks for the prompt answer, but the last command fails with the output sudo: appstreamcli: command not found

Install appstream

1 Like

Damn, that was fast! I tried with sudo pacman -S appstreamcli :sweat_smile: