Pamac can't install packages because of ruby gem

A while ago I installed a ruby gem : ruby-colorls using Pamac.
But after doing that, I was not able anymore to install packages using Pamac.
So I just used the regular sudo pacman -S <package>

Today I tried to install Nautilus (file manager) using Pamac but the same error as always occurred

Failed to prepare transaction

Because of ruby-colorls.
So I removed colorls using Pamac, then tried to install it back :

Target not found: ruby-colorls

Installed colorls with gem install colorls.
Prompt told the installation was successful.

Now the problem is :

  • I'm not able to install packages using pamac because of a package I don't even have [ruby-colorls], when I try to install it with pacman : error: target not found: ruby-colorls.
  • I'm not able to use the gem colorls : zsh: command not found: colorls

Here's garuda-inxi if needed :

  Kernel: 6.1.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=394702fa-734d-4ffe-be2e-fc60fa05f197 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=6e50783f-d483-49d4-ae7f-6d21a4cb652d loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: Vivobook_ASUSLaptop M3401QA_M3401QA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: M3401QA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: M3401QA.303 date: 08/06/2021
  ID-1: BAT0 charge: 54.3 Wh (100.0%) condition: 54.3/63.0 Wh (86.2%)
    volts: 12.0 min: 12.0 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging cycles: 53
  Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 10% (should be ignored) rechargeable: yes
    status: discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1324 high: 3200 min/max: 1200/4462 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1198 2: 1200
    3: 1197 4: 1200 5: 1200 6: 1200 7: 1200 8: 1200 9: 1200 10: 1200 11: 1197
    12: 1200 13: 1200 14: 3200 15: 1200 16: 1198 bogomips: 102206
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-1,eDP-1 empty: none
    bus-ID: 03:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 46.0 C
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-3:3 chip-ID: 13d3:5458 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1200 s-dpi: 96 s-size: 1015x317mm (39.96x12.48")
    s-diag: 1063mm (41.86")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary,right model: AOC 27B2
    serial: <filter> built: 2020 res: 1920x1080 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 mapped: eDP pos: left model: Samsung 0x4154 built: 2020
    res: 1920x1200 hz: 90 dpi: 161 gamma: 1.2 size: 302x189mm (11.89x7.44")
    diag: 356mm (14") ratio: 16:10 modes: max: 2880x1800 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.4 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.10-zen1-1-zen) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 1-2:2 pcie: chip-ID: 0d8c:0102 gen: 3 class-ID: 0300
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Device-4: C-Media CM106 Like Sound Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.10-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 3-2:2 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 953.87 GiB used: 84.09 GiB (8.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU010TZ
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 002C temp: 29.9 C scheme: GPT
  ID-1: / raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 84.09 GiB (9.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 84.09 GiB (9.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 84.09 GiB (9.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 84.09 GiB (9.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.61 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 15.03 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 55.6 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (RPM): cpu: 2500
  Processes: 404 Uptime: 32m wakeups: 7 Memory: 15.03 GiB
  used: 6.83 GiB (45.5%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1959 libs: 395 tools: octopi,pamac,paru Shell: Zsh v: 5.9
  running-in: xfce4-terminal inxi: 3.3.25
Garuda (2.6.14-1):
  System install date:     2022-01-04
  Last full system update: 2023-02-09 ↻
  Is partially upgraded:   No
  Relevant software:       snapper(custom) NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:

The first thing is, it's generally better not to install packages with pamac.

Not sure if you actually need colorls in the first place, exa (should be installed by default, not sure if this is true of all the editions) or lsd should be better options for the same functionality.

Assuming you really want it, ruby-colorls is not (anymore?) in the official package repositories, but it's available in the AUR. I don't know, but I guess it was removed for some reason.

Two options: either build the package "by hand" (makepkg) or use an AUR helper (there are many , each with its own strengths and weaknesses, we generally use paru but I've heard pikaur is also good and aura should be a good option too).
But first, remove the one installed by gem or you'll likely get a conflict anyhow.
For the command not found, likely it's not in PATH. It's long I don't use ruby, if I recall correctly there should be a directory where gem puts wrapper scripts for executable commands.


Always! :face_with_hand_over_mouth::joy:

And yes, it's true that exa does that for most of the editions. All but XFCE :eyes:


Installing colorls with paru worked perfectly fine, thanks.
Now the only problem remaining is I still can't download packages with pamac

Failed to generate ceph-libs information

This message appears when I try to install any package.
Of course ceph-libs is installed.

Sounds like this:

I guess you could not upgrade for a long time, is it?

Also, notice the little red icon in Last full system update: 2023-02-09 ↻: better reboot.

And, you may know this already, but very important, do your upgrades with garuda-update or the Garuda GUI tool, "Garuda Assistant", "Maintenance" page, "System update" button.

The distro tools do much more than just calling pacman -Syu, they also take care of other necessary tasks.


Upgrades worked fine, never been broken.
Yes last system update was today, rebooted several times.
I use garuda-update :slight_smile:
Thought that would fix an issue with my VSCode, but it didn't (can't detect includes headers properly, it was doing just right yesterday)

are you using

garuda-update -a

to update the aur packages


never used the option -a
garuda-update -a is currently running, it found 84 packages to install / update


84 packages

That's going to be some time compiling stuff, luckily you have a very good machine.

can't detect includes headers properly

Strange that it stopped working, you may want to look into the issues on github if there's anything about it. Likely, not vscode itself but the c++ extension.
It's a while I don't use it, I recall sometimes it takes very long before it finds them.
And for one project I had to tell it where to find them, my bad I don't remember how (I think I found advice somewhere). It was one of those json files.


Update just finished

error: packages failed to build: ceph-17.2.5-5 (ceph-libs)
Paru exited with error code 1

So I rebooted, run garuda-update -a again, same result.

Opened pamac, which has been updated apparently, new tab available : 'Updated'.
In this tab there is only one package to update : ceph-libs.
I tried to update it, but it does not work, this error again

Failed to generate ceph-libs information

You can probably just uninstall ceph-libs. See the thread above about it.


I removed it, as everyone in the thread.
Now he error I get from pacam when I try to install a package is

target not found: libuvc-git

Also, should I remove all the orphans, in the orphan pamac tab ?

I see libuvc-git is not in the official repos either, but available in the AUR.

Try with pacman -R libuvc-git, if removing it would break something it will tell you.

Before removing all orphans though, first check that they're actually unneeded.
It may happen (and it happened to me also) when packages are a bit messed up some end up unexpectedly as orphans. Search "orphans" in the forum for more info, there are some reports.


Yup, removing the package fixed it.
Pamac is now able to install packages :slight_smile:

Before I go, is the command garuda-update -a the most optimal way to update my system ?
Are there some options I could add ?

Yes, that's the best and recommended way (or simply update -a which is a symlink to the former).
You may also give it --skip-mirrorlist if you know your mirrors are stable, to save some time and bandwidth.


Thanks for Helping :slight_smile:
Have a great day !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.