Pacman libalpm.so.13 error

I’ve had this error since kde 6.0.3 " pacconf: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory it doesn’t negatively affect me in any real way but is there any real way to get rid of it. i happend when panmac( I dont use it) wouldn’t update so I removed it. an got this error. I tried adding it back to solve it weeks later but its still there

Generated 488 total GRUB entries. You might experience issues loading snapshots menu in GRUB.
Found 50 snapshot(s)
Unmount /tmp/grub-btrfs.JH5OpIezbC .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme1n1.
done
(10/12) Checking which packages need to be rebuilt
pacconf: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory
pacconf: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory
pacconf: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory
pacconf: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory
pacconf: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory
foreign	ds4drv
foreign	guiscrcpy
foreign	python-pdftopng
foreign	python-setuptools-markdown
(11/12) Performing snapper post snapshots for the following configurations...
==> root: 1408
(12/12) Syncing all file systems...

--> Updating AUR packages with paru..
:: Looking for devel upgrades...
:: packages not in the AUR: garuda-dr460nized-next  khotkeys  kpeoplevcard  kquickcharts5  libretro-duckstation  mailspring-bin  qgpgme-qt5  warp-terminal
:: marked out of date: plasma5-applets-eventcalendar  protonvpn  pyside2  python-shiboken2
:: orphans: guiscrcpy  kdav5  plasma5-applets-eventcalendar  python-setuptools-markdown  stacer-bin  vst2sdk
 there is nothing to do

System updated! 🐧
 garuda-inxi
System:
  Kernel: 6.8.9-4-cachyos-bore arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos-bore
    root=UUID=32b5fe90-e0ee-4bf1-9b2b-e31c263c99bc rw rootflags=subvol=@
    splash quiet resume=UUID=7983a378-8438-48a4-9a5e-a348c611eb88 loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
    wm: kwin_wayland tools: avail: lxlock vt: 1 dm: SDDM Distro: Garuda
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-PRO v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 4802 date: 06/15/2023
CPU:
  Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701030
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3855 high: 4359 min/max: 2200/4426 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4357 2: 4112
    3: 4353 4: 3502 5: 3982 6: 3923 7: 3600 8: 3600 9: 4359 10: 4031 11: 3821
    12: 3600 13: 3600 14: 3617 15: 3600 16: 3637 bogomips: 115202
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M] vendor: Sapphire
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
    built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2, HDMI-A-1, HDMI-A-2, Writeback-1 bus-ID: 0c:00.0
    chip-ID: 1002:744c class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: DP-1 res: 3440x1440 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd v: N/A glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 7900 GRE (radeonsi navi31 LLVM
    17.0.6 DRM 3.57 6.8.9-4-cachyos-bore) device-ID: 1002:744c
    memory: 15.62 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 13 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7900 GRE (RADV NAVI31) driver: mesa radv
    v: 24.2.0-devel (git-43bb989070) device-ID: 1002:744c
    surfaces: xcb,xlib,wayland device: 1 type: cpu name: llvmpipe (LLVM
    17.0.6 256 bits) driver: mesa llvmpipe v: 24.2.0-devel (git-43bb989070)
    (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Texas Instruments PCM2900C Audio CODEC
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 5-2:3 chip-ID: 08bb:29c0 class-ID: 0300
  API: ALSA v: k6.8.9-4-cachyos-bore status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:08b1 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-6:3 chip-ID: 8087:07dc
    class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
  Info: acl-mtu: 1021:5 sco-mtu: 96:6 link-policy: rswitch hold sniff
    link-mode: peripheral accept
Drives:
  Local Storage: total: 6.53 TiB used: 3.46 TiB (53.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: HP model: SSD EX920 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 32A0T2IA temp: 40.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:7 vendor: Samsung model: SSD 980 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 45.9 C
    scheme: GPT
  ID-3: /dev/nvme2n1 maj-min: 259:11 vendor: Western Digital
    model: WD BLACK SN770 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 731100WD temp: 49.9 C scheme: GPT
  ID-4: /dev/sda maj-min: 8:0 vendor: OCZ model: VERTEX3 size: 111.79 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 2.22 scheme: GPT
  ID-5: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD20EZAZ-00L9GB0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-6: /dev/sdc maj-min: 8:32 vendor: Toshiba model: TransMemory
    size: 29.08 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 1.8 TiB size: 1.8 TiB (100.00%) used: 1.29 TiB (71.8%)
    fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:9
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 27.4 MiB (9.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:8
  ID-3: /home raw-size: 1.8 TiB size: 1.8 TiB (100.00%)
    used: 1.29 TiB (71.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:9
  ID-4: /var/log raw-size: 1.8 TiB size: 1.8 TiB (100.00%)
    used: 1.29 TiB (71.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:9
  ID-5: /var/tmp raw-size: 1.8 TiB size: 1.8 TiB (100.00%)
    used: 1.29 TiB (71.8%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:9
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.52 GiB used: 1.27 GiB (8.2%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.08 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:10
Sensors:
  System Temperatures: cpu: 46.0 C mobo: 41.0 C gpu: amdgpu temp: 47.0 C
    mem: 66.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 601
Info:
  Memory: total: 16 GiB available: 15.52 GiB used: 5.84 GiB (37.6%)
  Processes: 522 Power: uptime: 48m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.19 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 2882 pm: pacman pkgs: 2864 libs: 622
    tools: octopi,pacseek,pamac,paru pm: flatpak pkgs: 18 Compilers:
    clang: 17.0.6 gcc: 14.1.1 alt: 12/13 Shell: garuda-inxi default: fish
    v: 3.7.1 running-in: kitty inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-02-23
  Last full system update: 2024-05-14 
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

~the flatpack is for bottles~

hmm even with pamac-aur libpamac-aur gone it’s still there oh well no big deal. Its not hurting anything haha.

I’d try an

update remote fix 

In addition to the pacman conf this reinstalls the pacman binary, and this might help.

2 Likes

I gave it a shot but yea same issue. But im planning on a fresh install in the future so its fine for now. Thank you for the suggestion.