Pacman and pamac not working properly for me

pamac stucks during downloading


and after 2 to 5 minutes it start to download updates and once it finishes downloading updates it stucks again at checking integrity and few minutes it starts to download whole update again and this process is repeting

i have tried to update system using pacman and got some error mentioned below

sudo pacman -Syu
[sudo] password for aakarsh:         
When you're walking home tonight, and some homicidal maniac comes after you with a bunch of loganberries, don't come crying to me!
[sudo] password for aakarsh:        
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                          1141.5 KiB   207 KiB/s 00:06 [------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (186) alsa-lib-1.2.5.1-3  alsa-topology-conf-1.2.5.1-1  alsa-ucm-conf-1.2.5.1-1
archlinux-appstream-data-pamac-20210612-1  attica-5.83.0-1  audit-3.0.2-1  baloo-5.83.0-1
beautyline-20210620-1  bind-9.16.18-1  bluedevil-1:5.22.1-1  bluez-5.59-2
bluez-hid2hci-5.59-2  bluez-libs-5.59-2  bluez-plugins-5.59-2  bluez-qt-5.83.0-1
bluez-utils-5.59-2  breeze-5.22.1-1  breeze-icons-5.83.0-1  chaotic-keyring-20210617-1
chaotic-mirrorlist-20210620-1  cups-filters-1.28.9-1  editorconfig-core-c-0.12.5-1
enchant-2.2.15-4  exiv2-0.27.4-2  firefox-89.0.1-1  frameworkintegration-5.83.0-1
fuse-common-3.10.4-1  fuse3-3.10.4-1  fwupd-efi-1.1-1  game-devices-udev-0.14-1
garuda-assistant-1.0.5-1  garuda-dr460nized-1.5.0-2  garuda-hooks-1.0.6-2
garuda-setup-assistant-1.0.10-1  gd-2.3.2-3  glib2-2.68.3-1  google-chrome-91.0.4472.114-1
graphviz-2.47.3-1  grub-2:2.06-1  hwids-20210613-1  imagemagick-7.1.0.0-1  jasper-2.0.32-1
kactivities-5.83.0-1  kactivities-stats-5.83.0-1  kactivitymanagerd-5.22.1-1
karchive-5.83.0-1  kauth-5.83.0-1  kbookmarks-5.83.0-1  kcalendarcore-5.83.0-1
kcmutils-5.83.0-1  kcodecs-5.83.0-1  kcompletion-5.83.0-1  kconfig-5.83.0-1
kconfigwidgets-5.83.0-1  kcontacts-1:5.83.0-1  kcoreaddons-5.83.0-1  kcrash-5.83.0-1
kdbusaddons-5.83.0-1  kde-cli-tools-5.22.1-1  kde-gtk-config-5.22.1-1  kdeclarative-5.83.0-1
kdecoration-5.22.1-1  kded-5.83.0-1  kdelibs4support-5.83.0-1  kdenlive-21.04.2-2
kdeplasma-addons-5.22.1-1  kdesu-5.83.0-1  kdnssd-5.83.0-1  kemoticons-5.83.0-1
kfilemetadata-5.83.0-1  kglobalaccel-5.83.0-1  kguiaddons-5.83.0-1  kholidays-1:5.83.0-1
khotkeys-5.22.1-1  ki18n-5.83.0-1  kiconthemes-5.83.0-1  kidletime-5.83.0-1
kimageformats-5.83.0-2  kinfocenter-5.22.1-1  kinit-5.83.0-1  kio-5.83.0-1  kirigami2-5.83.0-1
kitemmodels-5.83.0-1  kitemviews-5.83.0-1  kjobwidgets-5.83.0-1  kjs-5.83.0-1
kmenuedit-5.22.1-1  knewstuff-5.83.0-1  knotifications-5.83.0-1  knotifyconfig-5.83.0-1
kpackage-5.83.0-1  kparts-5.83.0-1  kpeople-5.83.0-1  kpty-5.83.0-1  kquickcharts-5.83.0-1
krunner-5.83.0-1  kscreen-5.22.1-1  kscreenlocker-5.22.1-1  kservice-5.83.0-1
ksystemstats-5.22.1-1  ktexteditor-5.83.0-1  ktextwidgets-5.83.0-1  kunitconversion-5.83.0-1
kvantum-theme-sweet-git-r192.7341748-1  kwallet-5.83.0-1  kwallet-pam-5.22.1-1
kwayland-5.83.0-1  kwayland-integration-5.22.1-1  kwayland-server-5.22.1-1
kwidgetsaddons-5.83.0-1  kwin-5.22.1-1  kwindowsystem-5.83.0-1  kxmlgui-5.83.0-1
latte-dock-git-0.9.91.r125.g7b8bef6b-1  layer-shell-qt-5.22.1-1  lib32-llvm-libs-12.0.0-2
libavif-0.9.1-1  libkscreen-5.22.1-1  libksysguard-5.22.1-1  libnm-1.32.0-1  libva-2.12.0-1
libwpe-1.10.1-1  linux-5.12.12.arch1-1  linux-zen-5.12.12.zen1-1
linux-zen-headers-5.12.12.zen1-1  llvm-libs-12.0.0-2  m4-1.4.19-1  mhwd-nvidia-465.31-1
milou-5.22.1-1  mkinitcpio-busybox-1.33.1-1  modemmanager-qt-5.83.0-1  mtools-1:4.0.31-1
nano-5.8-1  networkmanager-1.32.0-1  networkmanager-qt-5.83.0-1  nfs-utils-2.5.4-1
nfsidmap-2.5.4-1  nm-cloud-setup-1.32.0-1  obs-studio-27.0.1-1  openvpn-2.5.3-1
pace-1.4.1.1-2  perl-libwww-6.55-1  plasma-browser-integration-5.22.1-1
plasma-desktop-5.22.1-1  plasma-disks-5.22.1-1  plasma-firewall-5.22.1-1
plasma-framework-5.83.0-1  plasma-integration-5.22.1-1  plasma-nm-5.22.1-1  plasma-pa-5.22.1-1
plasma-systemmonitor-5.22.1-1  plasma-thunderbolt-5.22.1-1  plasma-vault-5.22.1-1
plasma-workspace-5.22.1-1  plasma5-applets-window-appmenu-0.7.0-1
plasma5-applets-window-title-0.7.0-1  polkit-kde-agent-5.22.1-1  polkit-qt5-0.114.0-1
powerdevil-5.22.1-1  prison-5.83.0-1  purpose-5.83.0-1  qqc2-desktop-style-5.83.0-1
qt5-base-5.15.2+kde+r199-1  qt5-script-5.15.5-1  qt5-wayland-5.15.2+kde+r28-1
qt5-webengine-5.15.5-1  sddm-kcm-5.22.1-1  solid-5.83.0-1  sonnet-5.83.0-1  sshfs-3.7.2-1
starship-0.55.0-1  sweet-kde-git-r192.7341748-1  syndication-5.83.0-1
syntax-highlighting-5.83.0-1  systemsettings-5.22.1-1  threadweaver-5.83.0-1  unrar-1:6.0.7-1
upower-0.99.12-2  visual-studio-code-bin-1.57.1-1  vlc-3.0.16-1  vulkan-icd-loader-1.2.178-1
whoogle-git-0.5.4_r341.gd894bd3-1  wpebackend-fdo-1.10.0-1  xapp-2.2.1-1
xdg-desktop-portal-kde-5.22.1-1  xfsprogs-5.12.0-1

Total Download Size:      0.01 MiB
Total Installed Size:  2368.01 MiB
Net Upgrade Size:         5.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
beautyline-20210620-1-any is up to date
garuda-assistant-1.0.5-1-any is up to date
kvantum-theme-sweet-git-r192.7341748-1-any is up to date
sweet-kde-git-r192.7341748-1-any is up to date
garuda-dr460nized-1.5.0-2-any is up to date
garuda-hooks-1.0.6-2-any is up to date
garuda-setup-assistant-1.0.10-1-any    12.4 KiB  9.14 KiB/s 00:01 [------------------------------------] 100%
google-chrome-91.0.4472.114-1-x86_64 is up to date
latte-dock-git-0.9.91.r125.g7b8bef6b-1-x86_64 is up to date
mhwd-nvidia-465.31-1-any is up to date
visual-studio-code-bin-1.57.1-1-x86_64 is up to date
whoogle-git-0.5.4_r341.gd894bd3-1-x86_64 is up to date
Total (12/12)                          12.4 KiB  1953   B/s 00:06 [------------------------------------] 100%
(186/186) checking keys in keyring                                 [------------------------------------] 100%
downloading required keys...
:: Import PGP key 0706B90D37D9B881, "Pedro Henrique Lara Campos <[email protected]>"? [Y/n] y
(186/186) checking package integrity                               [------------------------------------] 100%
error: beautyline: key "45ECA705E3897524654A37880706B90D37D9B881" is unknown
:: Import PGP key 45ECA705E3897524654A37880706B90D37D9B881? [Y/n] y
error: key "45ECA705E3897524654A37880706B90D37D9B881" could not be looked up remotely
:: File /var/cache/pacman/pkg/beautyline-20210620-1-any.pkg.tar.zst is corrupted (invalid or corrupted package(PGP signature)).
Do you want to delete it? [Y/n] y
error: garuda-assistant: key "45ECA705E3897524654A37880706B90D37D9B881" is unknown
:: Import PGP key 45ECA705E3897524654A37880706B90D37D9B881? [Y/n]

i think both pacmac and pamac having same issue and this issue is mentioned here

but problem not solved methods shown there

You basically just need to install chaotic-keyring before all other packages as it contains the new signing key which is shown as unknown currently. (kind of a security measure) Then, you can proceed installing/updating.

sudo pacman -Sy chaotic-keyring && sudo pacman -Su
12 Likes

thanks bro it worked :ok_hand: :ok_hand:
now i got no errors

sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
there is nothing to do
3 Likes

The keyring on the Chaotic-AUR website is still the old signing key. What's the new one?

1 Like

The key which is mentioned on the Chaotic-AUR website is still valid, we just added 2 new ones (one for the soon to be revived Garuda builder as Pedro did not want to reuse his own key for it and one for my VPS as I lost the previous key during backing up - lesson learned! :sweat_smile: )

5 Likes

The syslinks were indeed outdated. Pedro fixed them now...

(The key that signs the keyring is still that one in the site)

4 Likes

Thanks a bunch, @dr460nf1r3 & @lolimancer. :happy_dance:

@lolimancer I just noticed you--nice to see you. :smiley:

2 Likes

this worked for me too:

❯ history|tail -5                                                                                                                                       ─╯
 1035  reboot
 1036  sudo su -
 1037  exit
 1039  sudo pacman -Sy chaotic-keyring
 1040  upd

thx!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.