Packet loss, doesn't happen in other OS

Hi, since I first installed garuda it always had some packet loss when playing dota and when updating garuda it sometimes gets great speeds and sometimes super slow.. I didn't know I was dealing with packet loss until trying to run the same game (dota 2) both in garuda and windows. In garuda it always shows some packet loss and in windows it shows 0 packet loss. I'm thinking this is a driver issue but couldn't figure out how to install the drivers for the ethernet adapter.
Here's my garuda-inxi

System:
Kernel: 6.1.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1249bf2a-24a3-4faf-8815-b38b30282b57 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 amdgpu.ppfeaturemask=0xffffffff
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-E GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4901
date: 07/25/2022
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 2201 high: 2230 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 2198 2: 2195
3: 2200 4: 2200 5: 2200 6: 2200 7: 2230 8: 2200 9: 2200 10: 2200 11: 2200
12: 2193 bogomips: 88795
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1 empty: DP-2,HDMI-A-1,HDMI-A-2
bus-ID: 0c:00.0 chip-ID: 1002:73df class-ID: 0300
Device-2: Logitech C920 HD Pro Webcam type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1:2 chip-ID: 046d:0892
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: DP-1 mapped: DisplayPort-0 model: AOC 24G2W1G4 serial: <filter>
built: 2020 res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x296mm (20.75x11.65")
diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon RX 6700 XT (navi22
LLVM 15.0.7 DRM 3.49 6.1.7-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 1-1:2 gen: 4 chip-ID: 046d:0a5b class-ID: 0300 speed: 16 GT/s
lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech G933 Wireless Headset Dongle type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Logitech C920 HD Pro Webcam type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1:2 chip-ID: 046d:0892
class-ID: 0102 serial: <filter>
Sound API: ALSA v: k6.1.7-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp5s0 state: down mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-6:4 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 2.76 TiB used: 449.42 GiB (15.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Seagate
model: XPG GAMMIX S70 BLADE size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3.2.F.46 temp: 46.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
model: WDS250G1B0C-00S6U0 size: 232.89 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: 201000WD temp: 35.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: B1D2 scheme: MBR
ID-4: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD120 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: ACF0 scheme: MBR
ID-5: /dev/sdc maj-min: 8:32 type: USB vendor: A-Data
model: USB Flash Drive size: 28.91 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 103.45 GiB size: 103.45 GiB (100.00%)
used: 68.34 GiB (66.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:8
ID-2: /boot/efi raw-size: 534.1 MiB size: 533 MiB (99.80%)
used: 612 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:7
ID-3: /home raw-size: 103.45 GiB size: 103.45 GiB (100.00%)
used: 68.34 GiB (66.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:8
ID-4: /var/log raw-size: 103.45 GiB size: 103.45 GiB (100.00%)
used: 68.34 GiB (66.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:8
ID-5: /var/tmp raw-size: 103.45 GiB size: 103.45 GiB (100.00%)
used: 68.34 GiB (66.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.0 C mobo: 37.0 C gpu: amdgpu temp: 55.0 C
mem: 60.0 C
Fan Speeds (RPM): cpu: 1146 case-1: 1394 case-2: 1781 case-3: 1849
gpu: amdgpu fan: 0
Power: 12v: 10.14 5v: N/A 3.3v: N/A vbat: 3.25 gpu: amdgpu watts: 31.00
Info:
Processes: 383 Uptime: 6m wakeups: 0 Memory: 15.54 GiB
used: 4.42 GiB (28.4%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1457
libs: 465 tools: octopi,pamac,paru Shell: fish v: 3.6.0 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-20
Last full system update: 2023-01-22 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Here's the dmesg for igb:

[    7.834622] igb: Intel(R) Gigabit Ethernet Network Driver
[    7.834624] igb: Copyright (c) 2007-2014 Intel Corporation.
[    7.863072] igb 0000:04:00.0: added PHC on eth0
[    7.863073] igb 0000:04:00.0: Intel(R) Gigabit Ethernet Network Connection
[    7.863074] igb 0000:04:00.0: eth0: (PCIe:2.5Gb/s:Width x1) 04:d4:c4:52:6e:de
[    7.863075] igb 0000:04:00.0: eth0: PBA No: FFFFFF-0FF
[    7.863076] igb 0000:04:00.0: Using MSI-X interrupts. 2 rx queue(s), 2 tx queue(s)
[    8.255079] igb 0000:04:00.0 enp4s0: renamed from eth0
[   11.693291] igb 0000:04:00.0 enp4s0: igb: enp4s0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX

I tried installing drivers from intel website, but when I use make install it shows the following:

*** The target kernel has CONFIG_MODULE_SIG_ALL enabled, but
*** the signing key cannot be found. Module signing has been
*** disabled for this build.
make[1]: Entering directory '/usr/lib/modules/6.1.7-zen1-1-zen/build'
CC [M]  /home/bruno/Downloads/igb-5.13.7/src/igb_main.o
/home/bruno/Downloads/igb-5.13.7/src/igb_main.c: In function ‘igb_alloc_q_vector’:
/home/bruno/Downloads/igb-5.13.7/src/igb_main.c:1144:9: error: too many arguments to function ‘netif_napi_add’
1144 |         netif_napi_add(adapter->netdev, &q_vector->napi,
|         ^~~~~~~~~~~~~~
In file included from /home/bruno/Downloads/igb-5.13.7/src/igb_main.c:9:
./include/linux/netdevice.h:2569:1: note: declared here
2569 | netif_napi_add(struct net_device *dev, struct napi_struct *napi,
| ^~~~~~~~~~~~~~
make[2]: *** [scripts/Makefile.build:250: /home/bruno/Downloads/igb-5.13.7/src/igb_main.o] Error 1
make[1]: *** [Makefile:1990: /home/bruno/Downloads/igb-5.13.7/src] Error 2
make[1]: Leaving directory '/usr/lib/modules/6.1.7-zen1-1-zen/build'
make: *** [Makefile:87: default] Error 2

Could anyone help troubleshooting this?

Install drivers only with pacman.
How do you install this game?
Open issue or help request on the "game" web side.

Not sure how to install the drivers with pacman... It doesn't show nothing like intel-ethernet. Tried arch documentation, but it shows only stuff about other adapters.

I installed from steam, but the internet is slow all around, I'm now trying to test if the linux-lts will solve my problem, but it is downloading at 20kbps

Seems ok.

There are a couple of packages in the AUR.
igp looks only a bit older than the version you mentioned from Intel website and should be only for the linux-lts kernel (I think).
Read more here:
https://aur.archlinux.org/packages/igb
igb-dkms should work with linux-zen, but it seems outdated/unmaintained:
https://aur.archlinux.org/packages/igb-dkms
To install from AUR you can use the paru helper, e g.:

paru igb

Exit the PKGBUILD review with button q and confirm installation.

1 Like

Tried that, but it returns the same error as the one I get when trying to install from intel website. Its awkward because it worked just fine when I fresh installed, but after a while it broke, may have been an update. If it doesn't work in lts I'll fresh install again.

If the igb firmware was updated, it's possible it could have introduced a regression. It is possible to test older versions of the linux-firmware package by downgrading. It would also be worth testing out the linux-mainline kernel.

1 Like